Jump to content

TuneIn


arrbee99
 Share

Recommended Posts

The current source is using the server core 3.6.0.36-beta.  That might be the problem.

I can have a go at rebuilding it as see if it works.  But I don't use tunein.

 

You can try this if you like, it is using the same libraries as the Hue plugin I just released.

MediaBrowser.Plugins.TuneIn.dll.zip

Edited by BillOatman
Link to comment
Share on other sites

MediaOneWatch

The current source is using the server core 3.6.0.36-beta.  That might be the problem.

I can have a go at rebuilding it as see if it works.  But I don't use tunein.

 

You can try this if you like, it is using the same libraries as the Hue plugin I just released.

downloaded the attached zip... reinstalled tunein via the emby control dashboard.  restarted emby.  Replaced dll  restarted emby... "Playback error no compatible streams are currently available."

showing multiple radio stations that are local to me.  Looks like 8 of 16 FM stations are working now. 7 of 11 AM working. 4 of 11 internet "stations" working.

 

Win 10 Home edition.. Updates are current as of last night from Dell and Microsoft.  500 mbps/100 mbps internet connection.  Emby installed 2 days ago.  o. Loveland OH, East of Cincinnati.

Link to comment
Share on other sites

downloaded the attached zip... reinstalled tunein via the emby control dashboard.  restarted emby.  Replaced dll  restarted emby... "Playback error no compatible streams are currently available."

showing multiple radio stations that are local to me.  Looks like 8 of 16 FM stations are working now. 7 of 11 AM working. 4 of 11 internet "stations" working.

 

Win 10 Home edition.. Updates are current as of last night from Dell and Microsoft.  500 mbps/100 mbps internet connection.  Emby installed 2 days ago.  o. Loveland OH, East of Cincinnati.

All that I see on config is a request for Tune In logon and a lat/long... even blank it autosensed my location (IPV4 as my V6 is "elsewhere") Nothing plays even with an ID

 

@@MediaOneWatch please see how to report a media playback issue. thanks.

Link to comment
Share on other sites

downloaded the attached zip... reinstalled tunein via the emby control dashboard.  restarted emby.  Replaced dll  restarted emby... "Playback error no compatible streams are currently available."

showing multiple radio stations that are local to me.  Looks like 8 of 16 FM stations are working now. 7 of 11 AM working. 4 of 11 internet "stations" working.

 

Win 10 Home edition.. Updates are current as of last night from Dell and Microsoft.  500 mbps/100 mbps internet connection.  Emby installed 2 days ago.  o. Loveland OH, East of Cincinnati.

Ahhh well, I tried. :)

Link to comment
Share on other sites

FYI on the topic of TuneIn, the link for LatLong redirects and is broken at github.

Link to comment
Share on other sites

FYI on the topic of TuneIn, the link for LatLong redirects and is broken at github.

 

What does that mean?

Link to comment
Share on other sites

BillOatman

What does that mean?

 

There is a link on the config page to a site to get your longitude and latitude, it is broken/dead and redirects to a 404 github page.

I tried it and it is indeed broken.

 

I started looking at this code while eating lunch today and will play with it some and see where it goes.  I changed the link in my local version.

  • Like 1
Link to comment
Share on other sites

BillOatman

What the heck do you put for latlong ?  I have this

5d1bed46f024e_Clipboard01.jpg

 

It doesn't give me many channels, but the ones it gives me work.

Edited by BillOatman
Link to comment
Share on other sites

What the heck do you put for latlong ? I have this

5d1bed46f024e_Clipboard01.jpg

 

It doesn't give me many channels, but the ones it gives me work.

Now we know where you live

 

Sent from my SM-G960U1 using Tapatalk

Link to comment
Share on other sites

BillOatman

Western Canada?

 

Sent from my SM-G960U1 using Tapatalk

No, ilke I said, I changed the numbers :)

 

This plugin mostly works for me.  The channels it displays, work.  The problem I see is that not all channels display.  That seems to be due to not handing a returned data type.  For example, local stations display and work for me.  This is a sample of the data:

<outline text="AM">
<outline type="audio" text="800 | CJBQ (Country Music)" URL="http://opml.radiotime.com/Tune.ashx?id=s31207&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="48" reliability="99" guide_id="s31207" subtext="Angel Eyes - Jeff Healey Band" genre_id="g26" formats="aac,mp3" playing="Angel Eyes - Jeff Healey Band" show_id="p634654" item="station" image="http://cdn-radiotime-logos.tunein.com/s31207q.png" current_track="CJBQ Music" now_playing_id="s31207" preset_id="s31207"/>
<outline type="audio" text="860 | ICI Radio-Canada Première - Toronto (Public Radio)" URL="http://opml.radiotime.com/Tune.ashx?id=s31206&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="128" reliability="95" guide_id="s31206" subtext="Le midi trente Ontario" genre_id="g266" formats="mp3" show_id="p553705" item="station" image="http://cdn-profiles.tunein.com/s31206/images/logoq.png?t=154264" current_track="Le midi trente Ontario" now_playing_id="s31206" preset_id="s31206"/>
<outline type="audio" text="990 | WDCX (Christian Contemporary)" URL="http://opml.radiotime.com/Tune.ashx?id=s30629&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="95" guide_id="s30629" subtext="Thru The Bible" genre_id="g99" formats="aac,mp3" show_id="p32850" item="station" image="http://cdn-radiotime-logos.tunein.com/s30629q.png" current_track="Thru The Bible" now_playing_id="s30629" preset_id="s30629"/>
<outline type="audio" text="1010 | NEWSTALK 1010 (Local News)" URL="http://opml.radiotime.com/Tune.ashx?id=s31141&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="40" reliability="99" guide_id="s31141" subtext="Beyond the Mic" genre_id="g3126" formats="aac" show_id="p274959" item="station" image="http://cdn-radiotime-logos.tunein.com/s31141q.png" current_track="Beyond the Mic" now_playing_id="s31141" preset_id="s31141"/>
<outline type="audio" text="1040 | WYSL (Talk)" URL="http://opml.radiotime.com/Tune.ashx?id=s24258&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="98" guide_id="s24258" subtext="Talking Back W/ Shannon Joy" genre_id="g2" formats="mp3" show_id="p511558" item="station" image="http://cdn-radiotime-logos.tunein.com/s24258q.png" current_track="Talking Back W/ Shannon Joy" now_playing_id="s24258" preset_id="s24258"/>
<outline type="audio" text="1140 | CJ Country (Country Music)" URL="http://opml.radiotime.com/Tune.ashx?id=s27875&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="98" guide_id="s27875" subtext="Justin Moore - Small Town USA" genre_id="g26" formats="aac" playing="Justin Moore - Small Town USA" playing_image="http://cdn-albums.tunein.com/gn/41Z0TMJX5Kd.jpg" show_id="p595339" item="station" image="http://cdn-radiotime-logos.tunein.com/s27875q.png" current_track="CJ Country’s Classic Café with Kelli" now_playing_id="s27875" preset_id="s27875"/>
<outline type="audio" text="1160 | ESPN Ithaca (Sports Talk & News)" URL="http://opml.radiotime.com/Tune.ashx?id=s21956&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="32" reliability="98" guide_id="s21956" subtext="The Dan LeBatard Show with Stugotz" genre_id="g2723" formats="mp3" show_id="p182499" item="station" image="http://cdn-radiotime-logos.tunein.com/s21956q.png" current_track="The Dan LeBatard Show with Stugotz" now_playing_id="s21956" preset_id="s21956"/>
<outline type="audio" text="1310 | Classic Country WOKR (News)" URL="http://opml.radiotime.com/Tune.ashx?id=s22583&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="100" guide_id="s22583" subtext="Country from when it was still country" genre_id="g255" formats="mp3,aac" item="station" image="http://cdn-profiles.tunein.com/s22583/images/logoq.png?t=154653" now_playing_id="s22583" preset_id="s22583"/>
<outline type="audio" text="1370 | WXXI (US News)" URL="http://opml.radiotime.com/Tune.ashx?id=s24089&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="99" guide_id="s24089" subtext="Public Media for Rochester" genre_id="g3124" formats="aac,mp3" item="station" image="http://cdn-radiotime-logos.tunein.com/p355550q.png" now_playing_id="s24089" preset_id="s24089"/>
<outline type="audio" text="1460 | Catholic Radio (Catholic Talk)" URL="http://opml.radiotime.com/Tune.ashx?id=s23890&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="10" guide_id="s23890" subtext="Take 2 with Jerry and Debbie" genre_id="g270" formats="mp3" show_id="p761846" item="station" image="http://cdn-profiles.tunein.com/s23890/images/logoq.png?t=152094" current_track="Take 2 with Jerry and Debbie" now_playing_id="s23890" preset_id="s23890"/>
<outline type="audio" text="1490 | WBTA (Adult Hits)" URL="http://opml.radiotime.com/Tune.ashx?id=s27619&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="64" reliability="95" guide_id="s27619" subtext="WBTA 1490" genre_id="g3" formats="mp3" item="station" image="http://cdn-radiotime-logos.tunein.com/s27619q.png" now_playing_id="s27619" preset_id="s27619"/>
</outline>

It shows the AM direcrtory in the UI and when you drill in, you see the channels.

 

One that shows nothing in the UI is talk shows.  It's data looks like:

<body>
<outline type="link" text="Your Favourite Presenters" URL="http://opml.radiotime.com/Browse.ashx?id=c100001482&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100001482"/>
<outline type="link" text="Most Popular News Stations" URL="http://opml.radiotime.com/Browse.ashx?id=c100001416&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100001416"/>
<outline type="link" text="Talk Show Replays" URL="http://opml.radiotime.com/Browse.ashx?id=c100001673&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100001673"/>
<outline type="link" text="De Deportes" URL="http://opml.radiotime.com/Browse.ashx?id=c100003813&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100003813"/>
<outline type="link" text="Catholic Talk" URL="http://opml.radiotime.com/Browse.ashx?id=c100000603&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100000603"/>
<outline type="link" text="De Noticias" URL="http://opml.radiotime.com/Browse.ashx?id=c100003812&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100003812"/>
<outline type="link" text="Top podcasts auf Deutsch" URL="http://opml.radiotime.com/Browse.ashx?id=c100000091&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123"guide_id="c100000091"/>
</body>
 
The type of :"link" doesn't seem to be handled in the plugin code. The first one in that section's ("Your Favourite Presenters") data looks like:
<body>
<outline type="audio" text="Rire & Chansons SKETCHES" URL="http://opml.radiotime.com/Tune.ashx?id=s127211&formats=mp3,aac&partnerId=uD1X52pA"&serial=abc123" bitrate="128" reliability="98" guide_id="s127211" subtext="La plus grande collection de sketches du monde" genre_id="g209" formats="mp3" item="station" image="http://cdn-profiles.tunein.com/s127211/images/logoq.png?t=636270" now_playing_id="s127211" preset_id="s127211"/>
</body>
 
Edited by BillOatman
Link to comment
Share on other sites

  • 8 months later...

Have been trying the tunen plugin but cant get streams to play. Chosing: local- stations and hit play on random channel in that catogry gets this message: playback error! No compabile streams are present.

Link to comment
Share on other sites

Hello! Good Morning from India. I just now installed Tune In Plug in (getting my new password  as I forgot my password created years back) on my Emby on my Windows 10 PC. Its perfectly working and there are many stations/shows. Of course a few are not working for reasons not known. 

Thought I'd have a go at TuneIn which I installed ages ago. Had a browse round and found lots of stations, non of which played. Thought I'd better have at look for any plugin options, and I see it expects a TuneIn user name and Lat/Long, so I registered and got myself a use name and put in a lat/long for were I live and zero stations showed up. Tried again with a lat/long for London and nothing showed up. Any ideas please ?

 

Lat/long tried = 51.5, 0.0 in that format

 

Tried the London one at 11.42 am approx.

Link to comment
Share on other sites

If i recall correctly I believe it's that some streams are not allowed to be played via the API, but unfortunately there's no way to filter them out of the results and just exclude them altogether.

Link to comment
Share on other sites

Ok. None stations work for my country. But tunein works for an example with kodi addon. But maybe they are not written in the same way?

Link to comment
Share on other sites

  • 1 month later...

Hi, just have installed TuneIn, works kind OKish.

 

I did not login or provide any lat/lon info. It can play local stations, but there is a Scheduled Task which is not able to finish for about half an hour now:

 

5ebd1c6f69a8a_refesh_nofinish.png

 

Is this okay? I need to wait more to finish (hours, maybe)?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...