Jump to content
EODCrafter

ANSWERED Using XTeVe with Emby

Recommended Posts

Spaceboy

Your saying you have to use 4 digit numbers in xTeVe? This is not so. My Channels start at 1-700. If you meant Emby, Sry :)

 

Let me clarify: By default xTeVe starts numbering at 1000 to give you the space between 1-999 to renumber the Channels.

im not sure what you are saying but yes if you are supplying only a m3u to be matched to emby gracenote data you cannot use 3 digit channel numbers. if you are supplying emby with a m3u and xmltv file from xteve you can do what you like
  • Like 1

Share this post


Link to post
Share on other sites
EODCrafter

5d07a20d95c39_Capture.png

im not sure what you are saying but yes if you are supplying only a m3u to be matched to emby gracenote data you cannot use 3 digit channel numbers. if you are supplying emby with a m3u and xmltv file from xteve you can do what you like

Perhaps I am Missing the whole purpose of this Thread?

Share this post


Link to post
Share on other sites
Spaceboy

I have never seen such a fuss about using a Developers forum. It really seems like a lot of nonsense. I didn't know of xTeVe Discord when I first seeked help but now the link is provided. Please don't expect us to continuously monitor and update this thread, but we will try.

for someone who doesnt continuously monitor and update this thread you seem to monitor and update this thread quite frequently. often adding zero value

 

5d07a20d95c39_Capture.png

Perhaps I am Missing the whole purpose of this Thread?

definitely missing something. in the brain department.

 

i still don't think you get it. neither of the two things i have described are not "Using Xteve with Emby". i have answered flippers question with the correct information. if you don't get that that you shouldnt be "running" this thread.

 

i'd stick to your discord channel in future

Share this post


Link to post
Share on other sites
EODCrafter

for someone who doesnt continuously monitor and update this thread you seem to monitor and update this thread quite frequently. often adding zero value

 

definitely missing something. in the brain department.

 

i still don't think you get it. neither of the two things i have described are not "Using Xteve with Emby". i have answered flippers question with the correct information. if you don't get that that you shouldnt be "running" this thread.

 

i'd stick to your discord channel in future

Renumbering and the amount of digits have nothing to do with Metadata Logo being persistent in Emby.

 

What is your Problem? The question and Non-answer/Work-Around was actually addressed properly by @@Sammy and Me.

Edited by EODCrafter

Share this post


Link to post
Share on other sites
Sammy

Gentlemen!

 

And I use that term lightly!

 

Sent from my SM-G960U1 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
flipper26

I'm using Emby Server, version 4.1.1.0 on my Nvidia Shield. I use xteve to filter down my m3u playlist from my iptv provider. The parsed down m3u and xml files are on a folder within the internal storage of the  Nvidia Shield and are accessed by the Emby Server. Each day I update the m3u and xml files and update the Guide in Emby. Recently, I've noticed that the Emby Server gradually increases the storage that it takes on the Shield from about 567 mb to over 5 Gigs, almost as if there was some sort of memory leak going on. The Shield is turned off after use. The only way to clear this 5 Gigs is restart the Shield, go into Apps on the Shield and Emby Server and it will somehow reset itself. 
 
I'm still quite new to all of this so I don't have any of my movies loaded in the Media library, just a couple of recordings while testing things out. 

 

I don't see an attachment button so not able to attach my log file. Wondering if anyone has any ideas about this problem. Thanks.
 

Share this post


Link to post
Share on other sites
alexpaton

every time emby server updates the epg, it caches the xml file from emby.  On my Linux server, it regularly reaches 10GB or more, if left unchecked.  I am unclear on whether emby uses these files at all, once the EPG update has happened.  I don't think so though.  I regularly delete them all.  I feel that emby ought to handle this housekeeping automatically.

Share this post


Link to post
Share on other sites
flipper26

The cache in the Emby server is quite low and I do clear it out regularly. Just clearing out the cache doesn't resolve the problem though. I have to restart the Shield and go back into Apps within Settings and go into Emby server before it will reduce the internal storage size. 

Share this post


Link to post
Share on other sites
revengineer

Is there an easy way to bulk-renumber channels in XTeVe? I currently have an overlap between my calbe and IPTV channels and would like to resolve by starting my IPTV channels at 2000 or higher. But manually doing that for hundreds of channels is tedious. Does the bulk edit feature help here?

  • Like 1

Share this post


Link to post
Share on other sites
Spaceboy

Is there an easy way to bulk-renumber channels in XTeVe? I currently have an overlap between my calbe and IPTV channels and would like to resolve by starting my IPTV channels at 2000 or higher. But manually doing that for hundreds of channels is tedious. Does the bulk edit feature help here?

nope. Yes it’s tedious. But worth it. I did it properly once and that’s been it for 6 months plus now.

Share this post


Link to post
Share on other sites
revengineer

nope. Yes it’s tedious. But worth it. I did it properly once and that’s been it for 6 months plus now.

Thanks for confirming. I think I will procrastinate a little longer. :-)

  • Like 1

Share this post


Link to post
Share on other sites
EODCrafter

5d1f642973f52_Capture.png

Share this post


Link to post
Share on other sites
Tony B.

What is the latest update with the newest version? Still in Beta?

Share this post


Link to post
Share on other sites
EODCrafter

What is the latest update with the newest version? Still in Beta?

Yea....Very, Very close to release...ironing out Docker/Git. ect.

Edited by EODCrafter

Share this post


Link to post
Share on other sites
meatball

nope. Yes it’s tedious. But worth it. I did it properly once and that’s been it for 6 months plus now.

Yes I think a lot of us did this. In the beginning I invested some hours cleaning up and reorganizing channels etc. You kinda have too otherwise it’s a mess.

 

You’re right- it’s totally worth it. Once it’s done it makes it much more enjoyable and you don’t have to sweat it again.

Share this post


Link to post
Share on other sites
mbc0

Hi,

 

I have a question regarding the number of tuners please?

 

In Settings you can select number of tuners and with each m3u file you can also select the number of tuners?

 

I have two m3u playlists which allow 2 simultaneous streams so should the number of tuners be 4 and playlist tuner/streams be 2 for each playlist?

 

Many Thanks in Advance!

 

 

Share this post


Link to post
Share on other sites
Spaceboy

As far as I know neither xteve or emby allow you to aggregate m3u tuners like that

Share this post


Link to post
Share on other sites
Tony B.

Hi,

 

I have a question regarding the number of tuners please?

 

In Settings you can select number of tuners and with each m3u file you can also select the number of tuners?

 

I have two m3u playlists which allow 2 simultaneous streams so should the number of tuners be 4 and playlist tuner/streams be 2 for each playlist?

 

Many Thanks in Advance!

In my opinion, it's better to have separate instances, instead of all going into one.

Share this post


Link to post
Share on other sites
mbc0

hmm ok, I did try using separate installs of xteve as I run it on unraid, problem is I cannot change the port numbers on the docker so I can have 2 instances of xteve but using the same IP and port, 

Share this post


Link to post
Share on other sites
Tony B.

Docker is a nightmare. I would suggest using Windows. It's a pain in the ass to even use Linux. It has to start as a service and you can't know if it's started already

Share this post


Link to post
Share on other sites
dcol

Docker is a nightmare. I would suggest using Windows. It's a pain in the ass to even use Linux. It has to start as a service and you can't know if it's started already

I totally agree, And I am an IT person.

Share this post


Link to post
Share on other sites
EODCrafter

hmm ok, I did try using separate installs of xteve as I run it on unraid, problem is I cannot change the port numbers on the docker so I can have 2 instances of xteve but using the same IP and port, 

xteve -port="8080" It's shown on the download page for http://xteve.de. You will just have to change the Docker File to reflect that run switch. 2 Instances cannot run on the same Port. Docker

Edited by EODCrafter

Share this post


Link to post
Share on other sites
mbc0

I now have 3 instances running perfectly using the xteve.txt config file in each container defining a different port for each :-)

 

5d40d48737f3e_xteve.jpg

Share this post


Link to post
Share on other sites
CBers

I totally agree, And I am an IT person.

 

As a job, or just fiddling ?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...