Jump to content

Using XTeVe with Emby


EODCrafter
Go to solution Solved by EODCrafter,

Recommended Posts

alexpaton

Hmm.  well assuming that xteve is running, pasting the address in should just work.

Have you added a TV Guide Data Provider, and added the xml link as well?

Link to comment
Share on other sites

flipper26

I've copied and pasted the xml from xsteve in the EPG section but it is taking forever to load and doesn't seem like it's pulling in Guide information correctly. 

Link to comment
Share on other sites

flipper26

I've loaded the xteve files into Emby and can see a list of all the channels that I've selected however there's no program information. When I go into Emby under Live TV and select map channels under the TV Guide Data Provider section (I'm using the xml file from xteve) and go into individual channels I can see the channel number and name. Underneath that channel number and name is a reference to the xmltv file with a name (sometimes exactly the same as the name just above) but no channel number. It doesn't seem like there's anything to map but why isn't program information being loaded? thanks. 

Link to comment
Share on other sites

EODCrafter

I've loaded the xteve files into Emby and can see a list of all the channels that I've selected however there's no program information. When I go into Emby under Live TV and select map channels under the TV Guide Data Provider section (I'm using the xml file from xteve) and go into individual channels I can see the channel number and name. Underneath that channel number and name is a reference to the xmltv file with a name (sometimes exactly the same as the name just above) but no channel number. It doesn't seem like there's anything to map but why isn't program information being loaded? thanks. 

This is Emby...If you need support for xTeVe, join discussion over there. xTeVe

 

BTW, the channels should already be mapped if your using xTeVe to match Channels/EPG ;)

Edited by EODCrafter
Link to comment
Share on other sites

Tony B.

@@EODCrafter

 

Do you know how difficult it is to get a straight answer in Discord?

 

Such as; I needed a systemd script to use multiple instances of xTeve. A post here will get a lot more attention than some Mobile app that I have to use Google Lens to translate into text, without spacing. Translating that into spacing, sure, I know how to do it, but a different person looking to do the same thing, how would they know?

 

Give a little break. Please. As long as it's legal, we have a good conversation going.

 

If you feel you need to comment, please do it privately. No reason to clutter this awesome thread.

Link to comment
Share on other sites

EODCrafter

@@EODCrafter

 

Do you know how difficult it is to get a straight answer in Discord?

 

Such as; I needed a systemd script to use multiple instances of xTeve. A post here will get a lot more attention than some Mobile app that I have to use Google Lens to translate into text, without spacing. Translating that into spacing, sure, I know how to do it, but a different person looking to do the same thing, how would they know?

 

Give a little break. Please. As long as it's legal, we have a good conversation going.

 

If you feel you need to comment, please do it privately. No reason to clutter this awesome thread.

Well, It is my Thread... lol  :lol: I guess I can delete it to get rid of your useless advice? Your example just shows complete lack of any effort, We have had a Tutorial Posted for SystemD setup posted in #readfirst forever <<<<< Hmm #readfirst tells me I should probably Read That First.  Don't be a Jerk, Please.

 

 

5cf70664c3c21_Capture.png

Edited by EODCrafter
  • Like 1
Link to comment
Share on other sites

Sammy

It isn't because it is your thread, it is just because the way discord is (not) organized into topics. It is just chronological and things just scroll up the page and are impossible to find a day later as 15 more people have make 100 more comments since, all in the same thread.

Link to comment
Share on other sites

EODCrafter

It isn't because it is your thread, it is just because the way discord is (not) organized into topics. It is just chronological and things just scroll up the page and are impossible to find a day later as 15 more people have make 100 more comments since, all in the same thread.

Yea, As I said before...xTeVe doesn't have the Money Emby does...It's all volunteers and the software is free. No reason to re-type everything we have already posted in 2 places and clutter up @@Luke Premium Forum Software. If Luke would do something with IPTV, Emby users wouldn't even have to use xTeVe.

 

BTW @@Sammy 2.0 Beta testing going well, should be out soon!

Edited by EODCrafter
  • Like 1
Link to comment
Share on other sites

Sammy

Yea, As I said before...xTeVe doesn't have the Money Emby does...It's all volunteers and the software is free. No reason to re-type everything we have already posted in 2 places and clutter up @@Luke Premium Forum Software. If Luke would do something with IPTV, Emby users wouldn't even have to use xTeVe.

 

BTW @@Sammy 2.0 Beta testing going well, should be out soon!

Fortunately it is a pretty easy program to figure out how to use.

 

Sent from my SM-G960U1 using Tapatalk

  • Like 1
Link to comment
Share on other sites

Tony B.

@@Luke. @@ebr . I asked him to comment on a personal thread. This is not right .. .. .. I love this topic but I am sorry for getting it "out" of conversation.

 

Apparently this is a very heated conversation but, I only wanted to voice an opinion that EOD didn't get.

You can feel free to delete this as you see fit.

 

"Flame" is not our mantra

Link to comment
Share on other sites

flipper26

This is Emby...If you need support for xTeVe, join discussion over there. xTeVe

 

BTW, the channels should already be mapped if your using xTeVe to match Channels/EPG ;)

the thread is called "using xteve with emby" which is what I am doing and why this seemed like the logical place to post my question. As far as I can tell xteve is working as intended, it is Emby that is not working as I had expected by not showing any program information. I'm a new user to Emby and although i like some of what i've seen, I'm not married to this software. I have been through the xteve discord discussions and have looked at various documentation regarding xteve and Emby and looked at different discussions online. I'm not lazy, I try to find solutions on my own first. If I can't get it working or get any support in the forums I'll just look for other options. Thanks for welcoming me here and helping out all the newbies. 

Link to comment
Share on other sites

EODCrafter

the thread is called "using xteve with emby" which is what I am doing and why this seemed like the logical place to post my question. As far as I can tell xteve is working as intended, it is Emby that is not working as I had expected by not showing any program information. I'm a new user to Emby and although i like some of what i've seen, I'm not married to this software. I have been through the xteve discord discussions and have looked at various documentation regarding xteve and Emby and looked at different discussions online. I'm not lazy, I try to find solutions on my own first. If I can't get it working or get any support in the forums I'll just look for other options. Thanks for welcoming me here and helping out all the newbies. 

You mentioned Mapping after you are in Emby...If your using xTeVe, this is not the way to do it. We have a lovely You-tube Video, also in Read-First that describes all the steps very easily followed. Sorry that Plex is used instead of Emby, but that part is the easy part. If you guys insist we double Post everything, I'll put that link here for the Video.

 

Edited by EODCrafter
Link to comment
Share on other sites

EODCrafter

Instead of Using DVR IP, you of course want to use the link to the .m3u file and link to the .xml file, Both found at the Top of the WebUI on xTeVe. Before that make sure your using xepg and all channels have been "Mapped" in the xTeVe Mapping Section to "Match" your channels with the EPG you Provided.

Edited by EODCrafter
Link to comment
Share on other sites

CBers

If you guys insist we double Post everything

 

I understand where you're coming from, but people start with Emby, then discover xTeVe, so this for them is the natural place to ask questions.

 

You started this thread, obviously to get help yourself, but other have been helped as well.

 

 

 

If double-posting is what people need, then perhaps that is the answer, until Channel Management is started to be worked on my Luke.

 

I wouldn't be surprised to see Luke reaching out to @@marmei to help with the Chanel Management.

 

He did promise this year, so we still have almost 6 months for it to appear :)

  • Like 2
Link to comment
Share on other sites

EODCrafter

I understand where you're coming from, but people start with Emby, then discover xTeVe, so this for them is the natural place to ask questions.

 

You started this thread, obviously to get help yourself, but other have been helped as well.

 

 

 

If double-posting is what people need, then perhaps that is the answer, until Channel Management is started to be worked on my Luke.

 

I wouldn't be surprised to see Luke reaching out to @@marmei to help with the Chanel Management.

 

He did promise this year, so we still have almost 6 months for it to appear :)

I have never seen such a fuss about using a Developers forum. It really seems like a lot of nonsense. I didn't know of xTeVe Discord when I first seeked help but now the link is provided. Please don't expect us to continuously monitor and update this thread, but we will try.

Link to comment
Share on other sites

CBers

I have never seen such a fuss about using a Developers forum. It really seems like a lot of nonsense. I didn't know of xTeVe Discord when I first seeked help but now the link is provided. Please don't expect us to continuously monitor and update this thread, but we will try.

 

I'm sure the Emby/xTeVe users will appreciate the help.

Link to comment
Share on other sites

MRobi

I have never seen such a fuss about using a Developers forum. It really seems like a lot of nonsense. I didn't know of xTeVe Discord when I first seeked help but now the link is provided. Please don't expect us to continuously monitor and update this thread, but we will try.

The #read-first section on the discord server was a big help for me when setting it up on FreeNAS. But anything beyond that, the #support section is pretty much a jumbled mess with months worth of conversations in one spot to sift through to try to find your answer. It wouldn't be my first choice either as a place to go for trying to get help either. I get that it's a free to use program, with no budget, and setting up support forums like this one costs money that just probably isn't there. So the discord is better than nothing at all. But I think the format that discord uses is why you're seeing such a fuss about it.

Link to comment
Share on other sites

marmei

the thread is called "using xteve with emby" which is what I am doing and why this seemed like the logical place to post my question. As far as I can tell xteve is working as intended, it is Emby that is not working as I had expected by not showing any program information. I'm a new user to Emby and although i like some of what i've seen, I'm not married to this software. I have been through the xteve discord discussions and have looked at various documentation regarding xteve and Emby and looked at different discussions online. I'm not lazy, I try to find solutions on my own first. If I can't get it working or get any support in the forums I'll just look for other options. Thanks for welcoming me here and helping out all the newbies.

 

I assume in your XMLTV file from your provider are no current program data included. Open it with an editor and see if the program information of tomorrow is included. Emby will only display new program data, anything old or missing will not be displayed.

  • Like 1
Link to comment
Share on other sites

EODCrafter

Not sure about other Helpers but if you want specific help, then just Private Message one of the Staff Assistants listed on the right-hand column. I can personally say I wouldn't mind a lot less cluttered conversation as well and that avoids "know-it-all's" from jumping in submitting bad advice as well. 

@@MRobi

 https://emby.media/community/index.php?/user/53202-mrobi/

 

5cf7fd4a49ba3_Capture.png

 

This has always worked for me as well.....

 

5cf7ff57ea391_Capture.png

 

 

Edited by EODCrafter
Link to comment
Share on other sites

Sammy

Yea, As I said before...xTeVe doesn't have the Money Emby does...It's all volunteers and the software is free. No reason to re-type everything we have already posted in 2 places and clutter up @@Luke Premium Forum Software. If Luke would do something with IPTV, Emby users wouldn't even have to use xTeVe.

 

BTW @@Sammy 2.0 Beta testing going well, should be out soon!

 

BTW, Is the 2.0 Beta stable enough to test? TIA

  • Like 1
Link to comment
Share on other sites

flipper26

Thanks for your help everyone. I've managed to get my parsed down channels list from xteve loaded with program information. There are some channels that're off though, for example the program will say "Billions" and that's what's actually playing but the channel logo and description will be "NBA local". To correct this would i just go into xteve and change the name and logo to be "Showtime" in the Filters?

 

Also, is there a way to group similar channels together, for instance all news channels in the 100's, sports in the 200's, etc?

Link to comment
Share on other sites

alexpaton

flipper26 - Re: your channel being the wrong name; it is possible that your provider has screwed up.  Yes, you can rename it in xteve.  There is always the possibility that your provider may correct their mistake in the future.

As to renumbering channels; yes, just click on the channel number in Mapping, and you can edit it.

Link to comment
Share on other sites

flipper26

I update the providers playlist and xml each morning and run it through xteve. The new file gets posted to Emby. I refresh the Guide in Emby and then the Guide shows properly as a grid in Emby. If I go out of Emby for a few hours and then go back into Emby and click on the Guide in Live TV the grid view is gone and it only comes back if I refresh the Guide again. Is this a flaw in Emby or is there a setting/preference that can be enabled somewhere? thanks.

Link to comment
Share on other sites

CBers

I update the providers playlist and xml each morning and run it through xteve. 

 

You can schedule that to be done in xTeVe itself - I do it 4 times per day, followed by 4 refreshes in Emby.

 

Probably overkill, but you never know.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...