Jump to content

External Subtitles not showing


maximilianh75
 Share

Recommended Posts

I'v tested the addon and it's working with external subs. Great, thank you!

 

But the external subs aren't working on Chromecast and iOS / Android apps.

In Google Chrome, Xbox and LG TV app they are working. Is this a bug in the server or are there any issues with the apps?

Link to comment
Share on other sites

I'v tested the addon and it's working with external subs. Great, thank you!

 

But the external subs aren't working on Chromecast and iOS / Android apps.

In Google Chrome, Xbox and LG TV app they are working. Is this a bug in the server or are there any issues with the apps?

 

Please see how to report a media playback issue. thanks.

Link to comment
Share on other sites

weird... this issue occured with me while using vpn. soon as i disconnected it, i was able to make it work, strange enough.

Edited by hattori87
Link to comment
Share on other sites

Hi

Also have this problem on Nvidia shield with latest nightly Kodi 18 and the plugin version 3.1.32b

External subtitles or subtitles downloaded from opensubtitles.org do not show up.

Log: https://paste.kodi.tv/ligulujoqe

 

 

Hello

Exactly the same problem but client is running on Amazon Fire TV.

Not at home at the moment. Later will post log if necessary

Edited by Aleta
Link to comment
Share on other sites

I am experiencing the same problem with embyCon. Internal subtitles will play but not external ones.

I am using latest EmbyCon beta, latest beta Emby server and Kodi Nov 06 nightly build.

Tried to enable performance profiling but it just comes up with a popup asking if I want to enable it; click yes and it just pops up again. 

Link to comment
Share on other sites

Can you guys confirm if you're having this issue for both Movies and TV Shows? I'm asking this because I'm having a problem (not sure if it's the same one reported here) where external subtitles are not available, but just for TV Shows (Movies have no problems).

Link to comment
Share on other sites

@Angelblue05:

I tried changing the position of the subtitles as suggested in the post but that did not resolve the issue.

The issue is only with EmbyCon. Emby for Kodi works perfectly with subtitles. 

Link to comment
Share on other sites

After playing a number of files it seems that Emby for Kodi recognises the external subtitles properly as regarding their language for example English. However, EmbyCon sees the same external subtitle as unknown as regards to language. 

Link to comment
Share on other sites

That is because of a limitation in the Kodi api. It takes the language tag from the filename and there's none when using url subtitles (which is part of the emby api). The only reason it works for the emby for kodi addon is because it downloads the subtitles locally with the proper tag and so Kodi recognizes the language.

 

It would be better if the Kodi api simply allowed to name the subtitle track :)

Edited by Angelblue05
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...