Jump to content

External Subtitles not showing


maximilianh75
 Share

Recommended Posts

Hi, I have the same issue. With latest beta.

Maybe it isn’t only the addon issue? On my iPhone with the Emby app I also don’t have subtitles but on my laptop in Google Chrome I have the subtitles.

Edited by MattBlacK85
Link to comment
Share on other sites

I'm having this error in the log files:

 

2018-10-20 23:41:51.852 Error Dlna: Error in BeginListeningForBroadcasts
 *** Error Report ***
 Version: 3.5.3.0
 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
 Operating system: Unix 4.15.0.36
 64-Bit OS: True
 64-Bit Process: True
 User Interactive: True
 Processor count: 8
 Program data path: /var/lib/emby
 Application directory: /opt/emby-server/system
 System.Net.Sockets.SocketException (98): Address already in use
    at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Bind(EndPoint localEP)
    at Emby.Server.Implementations.Net.UdpSocket..ctor(Socket socket, Int32 localPort, IPAddress ip)
    at Emby.Server.Implementations.Net.SocketFactory.CreateUdpMulticastSocket(String ipAddress, Int32 multicastTimeToLive, Int32 localPort)
    at Rssdp.Infrastructure.SsdpCommunicationsServer.ListenForBroadcastsAsync()
    at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginListeningForBroadcasts()
 System.Net.Sockets.SocketException
    at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Bind(EndPoint localEP)
    at Emby.Server.Implementations.Net.UdpSocket..ctor(Socket socket, Int32 localPort, IPAddress ip)
    at Emby.Server.Implementations.Net.SocketFactory.CreateUdpMulticastSocket(String ipAddress, Int32 multicastTimeToLive, Int32 localPort)
    at Rssdp.Infrastructure.SsdpCommunicationsServer.ListenForBroadcastsAsync()
    at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginListeningForBroadcasts()
 

Not sure if this has to do with it but how can i resolve?

 

If i compare the log between the iOS app and the Chrome i'm not seeing any differences. Will try tommorrow between Chrome and the Kodi Emby addon.

Link to comment
Share on other sites

I'm having this error in the log files:

 

2018-10-20 23:41:51.852 Error Dlna: Error in BeginListeningForBroadcasts

 *** Error Report ***

 Version: 3.5.3.0

 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb

 Operating system: Unix 4.15.0.36

 64-Bit OS: True

 64-Bit Process: True

 User Interactive: True

 Processor count: 8

 Program data path: /var/lib/emby

 Application directory: /opt/emby-server/system

 System.Net.Sockets.SocketException (98): Address already in use

    at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)

    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

    at System.Net.Sockets.Socket.Bind(EndPoint localEP)

    at Emby.Server.Implementations.Net.UdpSocket..ctor(Socket socket, Int32 localPort, IPAddress ip)

    at Emby.Server.Implementations.Net.SocketFactory.CreateUdpMulticastSocket(String ipAddress, Int32 multicastTimeToLive, Int32 localPort)

    at Rssdp.Infrastructure.SsdpCommunicationsServer.ListenForBroadcastsAsync()

    at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginListeningForBroadcasts()

 System.Net.Sockets.SocketException

    at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)

    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

    at System.Net.Sockets.Socket.Bind(EndPoint localEP)

    at Emby.Server.Implementations.Net.UdpSocket..ctor(Socket socket, Int32 localPort, IPAddress ip)

    at Emby.Server.Implementations.Net.SocketFactory.CreateUdpMulticastSocket(String ipAddress, Int32 multicastTimeToLive, Int32 localPort)

    at Rssdp.Infrastructure.SsdpCommunicationsServer.ListenForBroadcastsAsync()

    at Rssdp.Infrastructure.SsdpCommunicationsServer.BeginListeningForBroadcasts()

 

Not sure if this has to do with it but how can i resolve?

 

If i compare the log between the iOS app and the Chrome i'm not seeing any differences. Will try tommorrow between Chrome and the Kodi Emby addon.

 

Hi, is this about the log message, or is there a subtitle problem? If there is a subtitle problem, then please make sure to follow all of the guidelines in how to report a media playback issue, part of which is attaching full and complete log files. thanks !

Link to comment
Share on other sites

If you can replicate the issue in the web app, that'll be the most straightforward. Then you'd only need to provide your complete emby log that captures the play attempt.

Link to comment
Share on other sites

maximilianh75

If you can replicate the issue in the web app, that'll be the most straightforward. Then you'd only need to provide your complete emby log that captures the play attempt.

This is log that's capture in play attemp. If i'm doing something wrong, please tell me

short log2.txt

Link to comment
Share on other sites

This is log that's capture in play attemp. If i'm doing something wrong, please tell me

 

What is that a play attempt from? Please attach the full and complete emby server log. thanks.

Link to comment
Share on other sites

maximilianh75

What is that a play attempt from?

AngelBlue05 says : If you can replicate the issue in the web app, that'll be the most straightforward. Then you'd only need to provide your complete emby log that captures the play attempt. 

I suppose that the moment I play the movie

Edited by maximilianh75
  • Like 1
Link to comment
Share on other sites

maximilianh75

Did you try selecting the subtitles by clicking the CC icon in the web app video player?

 

The web app works well, the problem is in kodi that does not detect the path correctly and when you try to open the subtitle it gives an error. In the browser the subtitles work correctly

Edited by maximilianh75
  • Like 1
Link to comment
Share on other sites

That is really not how I understood it. I will check it out today. I finally have time. Thanks for your patience.

Link to comment
Share on other sites

maximilianh75

That is really not how I understood it. I will check it out today. I finally have time. Thanks for your patience.

No, thanks you for working on that and sorry if can not be so clear to explain. My first lenguage is spanish and i try hard to communicate with you

  • Like 1
Link to comment
Share on other sites

@@maximilianh75

 

I see the issue, I'm just not sure how it's happening. My external subtitles work corrected. Can you play in Kodi and provide your Kodi log? Ensure addon logging is enabled (emby for kodi settings > advanced > log level set to info, disable Kodi debug). Thank you.

Link to comment
Share on other sites

maximilianh75

@@maximilianh75

 

I see the issue, I'm just not sure how it's happening. My external subtitles work corrected. Can you play in Kodi and provide your Kodi log? Ensure addon logging is enabled (emby for kodi settings > advanced > log level set to info, disable Kodi debug). Thank you.

Here's the log. I open the same movie

 

Thx

kodi(10_22).log

  • Like 1
Link to comment
Share on other sites

@@Luke

 

Is the DeliveryUrl not supposed to be an emby url? This is the first time I see an actual path returned.

      {
        u'IsInterlaced': False,
        u'DisplayTitle': u'Spa',
        u'IsExternalUrl': True,
        u'Language': u'spa',
        u'Index': 2,
        u'DeliveryUrl': u'E:\\MH\\MOVIES\\1080p(LB)\\Easy Money (1983)\\Easy Money (1983).spa.srt',
        u'SupportsExternalStream': True,
        u'DeliveryMethod': u'External',
        u'Codec': u'srt',
        u'IsForced': False,
        u'Path': u'E:\\MH\\MOVIES\\1080p(LB)\\Easy Money (1983)\\Easy Money (1983).spa.srt',
        u'Type': u'Subtitle',
        u'IsTextSubtitleStream': True,
        u'IsDefault': False,
        u'IsExternal': True
      }
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...