Jump to content

Chrome not allowing full screen


WaterGrunt
 Share

Recommended Posts

WaterGrunt

I am running Emby on a FreeNAS server and yesterday, I went to watch a movie and when it started, I noticed the Emby player controls were at the top of the page. I clicked on the full screen button and it did not work. So I tried all the buttons including the volume slide bar and mute function. None of them worked. 

I opened Emby in Microsoft Edge and everything works as it should. Was there a recent Chrome update that would have caused this and if so does anyone know of a fix? 

 

I have attached a screen shot of the top of the Chrome browser.

 

 

Link to comment
Share on other sites

WaterGrunt

I am running Emby on a FreeNAS server and yesterday, I went to watch a movie and when it started, I noticed the Emby player controls were at the top of the page. I clicked on the full screen button and it did not work. So I tried all the buttons including the volume slide bar and mute function. None of them worked And I can no longer scroll down on the movie main page to view actors info. 

I opened Emby in Microsoft Edge and everything works as it should. Was there a recent Chrome update that would have caused this and if so does anyone know of a fix? 

 

I have attached a screen shot of the top of the Chrome browser.

 

 

post-91654-0-23216300-1538329936_thumb.jpg

Link to comment
Share on other sites

  • 1 year later...
JPTechNerd

Hi,

 

I'm having the same issue. The full screen button is not working in only Chrome. I'm running a reverse proxy using Nginx.

 

Debug console error:

 

5e38f5df5e670_Fullscreenerror.png

 

 

Nginx config file:

 

worker_processes  1;
 
events {
    worker_connections  1024;
}
 
http {
    include       mime.types;
    default_type  application/octet-stream;
 
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 120;
types_hash_max_size 2048;
 
server {
        listen 80 default_server;
        listen [::]:80 default_server;
}
 
# SSL reverse proxy server 
server { 
listen      443 ssl; 
server_name www.domain.com;
 
ssl_certificate      server.crt; 
ssl_certificate_key  server.key;
 
ssl_prefer_server_ciphers on; 
ssl_ciphers EECDH+AESGCM:EDH+AESGCM;
ssl_session_timeout  10m;
ssl_session_cache shared:SSL:10m;
ssl_session_tickets off;
ssl_stapling on;
ssl_stapling_verify on;
 
add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
add_header Referrer-Policy "no-referrer-when-downgrade";
add_header Feature-Policy "geolocation none;midi none;notifications none;push none;sync-xhr none;microphone none;camera none;magnetometer none;gyroscope none;speaker self;vibrate none;fullscreen www.domain.com;payment none;";
add_header Content-Security-Policy "default-src *  data: blob: 'unsafe-inline' 'unsafe-eval'; script-src * data: blob: 'unsafe-inline' 'unsafe-eval'; img-src * data: blob: 'unsafe-inline';";
add_header X-Frame-Options "SAMEORIGIN";
add_header X-Content-Type-Options nosniff;
add_header X-XSS-Protection "1; mode=block";
 
location /emby {
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-Proto $remote_addr;
proxy_set_header X-Forwarded-Protocol $scheme;
proxy_redirect off;
 
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection "upgrade";
}
location ~* ^/files/images/(\w+)/.+\.(jpg|png|gif)$ {
alias C:\nginx\html\images\emby\$1.$2;
}    
}
}
Link to comment
Share on other sites

JPTechNerd

Yes, when I click the full screen icon  5e390ae36d3bd_Capture.png  it will do nothing and display the error in the console. I only have this issue in Chrome when I'm accessing it through my reverse proxy. It works locally in Chrome.

Link to comment
Share on other sites

pir8radio

I dont have time to look at his config right now, gotta run to work,  but try removing:

proxy_set_header X-Forwarded-Protocol $scheme;

and changing:

proxy_set_header Connection "upgrade";

to:

proxy_set_header Connection $http_connection;
Link to comment
Share on other sites

JPTechNerd

The issue was add_header Feature-Policy. I was creating a policy for fullscreen which I just went ahead and removed. I appreciate the help.

Link to comment
Share on other sites

pir8radio

The issue was add_header Feature-Policy. I was creating a policy for fullscreen which I just went ahead and removed. I appreciate the help.

lol I glanced right over your two policies..  good job..

Link to comment
Share on other sites

  • 10 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...