Jump to content

a problem with login on an Apple TV 4K


zengzhiping
 Share

Go to solution Solved by guesmsi,

Recommended Posts

I'm having a problem with login on an Apple TV 4K. 

I have 2 user accounts, one is a master account and one is an account for my AppleTV. 

 Both accounts can not login 

 

"Oops.Something went wrong..

error signing in"

 

emby server @@windows 10:Version 3.5.3.0 

 

Apple TV 4K:tvOS12.0

 

PS: I'm just become a Emby Premiere Number 

can i refund lol

embyserver.txt.rtf

Edited by zengzhiping
Link to comment
Share on other sites

Hey @@zengzhiping --

 

I'm sorry to hear you're having problems logging in. Does this problem only exist on Apple TV or does it persist on other devices like iOS or web applications?

 

Do the user names happen to have any special characters in them?

 

@@Luke -- Any thoughts on the server logs posted?

Link to comment
Share on other sites

Was there an ffmpeg log? Can you attach that too? Thanks.

 

He's having trouble logging in.

 

zeng - can you log in from a web browser or your phone using these same users?  Are you positive you are inputting the password correctly?

Link to comment
Share on other sites

Ok sorry my mistake. Looking at his log, yes I do see a problem.

 

Did you by any chance go back and forth between beta and stable releases? If so then you can't do that, you'll need to go back to the beta and stay on it until the next release. When the stable release catches up to the current beta, then you can switch over to the stable channel. 

 

Thanks.

2018-09-24 08:28:24.798 Info SessionManager: Creating new access token for user bbc71393-d6c8-49eb-9958-10c6c7fab775 
2018-09-24 08:28:24.800 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.5.3.0
	Command line: C:\emby-server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 8
	Program data path: C:\emby-server\programdata
	Application directory: C:\emby-server\system
	Constraint: NOT NULL constraint failed: Tokens.DeviceName
	SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown.
	   at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc)
	   at SQLitePCL.pretty.StatementImpl.MoveNext()
	   at Emby.Server.Implementations.Security.AuthenticationRepository.<>c__DisplayClass5_0.<Create>b__0(IDatabaseConnection db)
	   at SQLitePCL.pretty.DatabaseConnection.<>c__DisplayClass20_0.<RunInTransaction>b__0(IDatabaseConnection db)
	   at SQLitePCL.pretty.DatabaseConnection.RunInTransaction[T](
Link to comment
Share on other sites

He's having trouble logging in.

 

zeng - can you log in from a web browser or your phone using these same users?  Are you positive you are inputting the password correctly?

 iOS and web applications login emby server just fine

Link to comment
Share on other sites

 iOS and web applications login emby server just fine

 

See Luke's post above.  Did you install the beta and then go back to the stable release?

Link to comment
Share on other sites

See Luke's post above.  Did you install the beta and then go back to the stable release?

 

I'm no sure .emby server automatically upgrade to the latest version。which stable release can support tvOS12.0?

Link to comment
Share on other sites

At this point if you've gone back and forth between beta and stable then you may need to start with a fresh install of the server. thanks.

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

I'm also having a problem with login on an Apple TV 4K. 

Accounts can not login 

"Oops.Something went wrong..

error signing in"

 

emby server @debian 9:Version 3.5.3.0 

 

Apple TV 4K : tvOS12.0 - can not login, now working fine

Apple TV 4 : tvOS12.0 - working fine

iOS App - working fine

 

The problem was in the name of Apple TV device, after changing device name it works

 

  • Like 1
Link to comment
Share on other sites

Thanks for the feedback. We have a fix for that in the apple tv beta and will hopefully be releasing it soon.

Link to comment
Share on other sites

 

I'm also having a problem with login on an Apple TV 4K. 

Accounts can not login 

"Oops.Something went wrong..

error signing in"

 

emby server @debian 9:Version 3.5.3.0 

 

Apple TV 4K : tvOS12.0 - can not login, now working fine

Apple TV 4 : tvOS12.0 - working fine

iOS App - working fine

 

The problem was in the name of Apple TV device, after changing device name it works

 

 Thank you very much

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...