Jump to content

Backup & Restore Plugin - Windows to Synology


Recommended Posts


Hello All!


I've been using Emby Server on Windows for quite a while, but decided to shift to a NAS based server.  I started with the Synology DS218.


I've used the Backup and Restore Plugin multiple times in the past when reloading Emby Server on both the same and new PC's and never had any issues.


I've search the forum looking for the answer, but haven't been able to find anything.


** SETUP **


I ran through the tutorial for setting up Synology Folder Permissions, giving the "embsvr" user read/write access to all folders, then rebuilt the library structure and migrated the media files to the NAS.  The libraries have populated and display correctly in the home page of the NAS-based Server (Multiple "(500) Internal Server Error" related to FanArt.TV, but I read on other threads that this was fairly common and may resolve itself.)


Because the libraries are displayed, I am assuming my permissions are correctly set up, but I could be mistaken.


Both the Windows-based Server and the NAS-based Server are running the same version of the Backup & Restore Plugin (




I'd like to restore the user information from my Windows-based Server.  I ran a backup from the Windows-based Server, transferred the folder to the NAS, but when I click on the backup file from the plug-in page, all I get is a perpetual "thinking" circle with no options or error messages on the screen.


When looking in the logs, I see a "could not find handler" error... (see attached log).




Why would the server not be able to find the handler for a plugin that was just installed?

Is the handler different in the Windows-based Server and the NAS-based Server so the file created on the Windows-based Server is unreadable by the NAS-based Server?  

Did I miss something else in the server setup that would prevent the "embsvr" user from accessing some of the program files?



Link to comment
Share on other sites

You can use it across different platforms but I would suggest restoring users and user data only. Restoring anything with path information could be a problem. Thanks.

Link to comment
Share on other sites


Thanks for the quick response... I just shifted it to another location in my home and the restore worked. A you said, I just restored user and user data and nothing else. You guys are awesome!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...