Jump to content

.NET Core Package Test Programme for Synology/XPEnology


solabc16
 Share

Go to solution Solved by solabc16,

Recommended Posts

poerlemans

@@solabc16

 

Good day James,

 

I would like to test the new beta version on my DS918+.

I have already the stable Emby version (3.5.3.0) running on this machine.

I understand that both a stable Emby version and a beta Emby version can be installed parallel to each other on the same machine. But that only one of both versions should run.

In case you expect that problems may arise, I can also install the beta version on a DS216+

 

Peter

Link to comment
Share on other sites

AlwinHummels

Hi James,

 

Would like to test .NET 

 

Running DS415+ with Emby server Versie 3.6.0.2 beta

Link to comment
Share on other sites

Hi, I'd like to test the new version aswell. I'm on a DS918+ user with 12GB of RAM. 

What can I expect to the .NET core version compared to the "regular" version?

Link to comment
Share on other sites

solabc16

Hello @@oRBIT

 

There are a few drivers behind the move to .NET core, one of which is performance; which we expect to improve and continue to improve over time.

 

Having said that, it is likely to be workload specific and the performance gap to Mono has reduced, thanks to the collective community efforts.

 

The are efficiencies to be gained on the development side, as it makes support for various platforms a little easier and potentially more robust; see threads on the real-time monitoring as an example.

 

Best

- James

Link to comment
Share on other sites

solabc16

 

Thanks for offering to help test the upcoming .NET Core release of Emby Server on Synology.

 

I've sent you an invite to the group.

 

* Please make sure to start at the beginning and read the first couple of posts on the PM!

 

Best

- James

Edited by solabc16
Link to comment
Share on other sites

solabc16

Hello @@Kalua85

 

Sorry, I didn't forget you. Thanks for your interest, I've added you to the list so I can update you.

 

We do not have a .NET Core package available for the 'evansport' architecture yet.

 

Best

- James

Link to comment
Share on other sites

solabc16

Hello @@EagleMitchell
 
Thanks for offering to help test the upcoming .NET Core release of Emby Server on Synology.
 
I've sent you an invite to the group.
 
* Please make sure to start at the beginning and read the first couple of posts on the PM!
 
Best
- James

Edited by solabc16
Link to comment
Share on other sites

Hi,

 

I have a DS418play and would be happy to test a .NET release of Emby, which is used for many hours each day.

 

Regards

Alan

Link to comment
Share on other sites

solabc16

Hello @@alanr

 

Thanks for offering to help, I've sent you an invite to the group - please make sure to start at the beginning and read the first couple of posts on the PM!
 
Best
- James

Link to comment
Share on other sites

Spidey74

Hi James,

 

I recently upgraded to a DS918+ with 8GB of RAM and am very interested to test the .NET core as I am reinstalling everything here.

 

Can you please also add me to the test group for the apollolake version?

 

Regards,

Edwin

Link to comment
Share on other sites

solabc16

Hello @@Spidey74

 

Sorry for the delay in responding, there was an issue introduced with beta 3.6.0.52 that we wanted to resolve before bringing any more testers on board.

 

Thanks for offering to help, I've sent you an invite to the group - please make sure to start at the beginning and read the first couple of posts on the PM!
 
Best
- James

Edited by solabc16
Link to comment
Share on other sites

  • 3 weeks later...
Everbrave

VA-API used to work well with DS918+, but now it is no longer available in this server version (3.6.0.58), what is the appropriate HW selection of the Decoding method for DS918+?

 

When is HW Encoding necessary to select, if at all?

 

Thanks

Link to comment
Share on other sites

VA-API used to work well with DS918+, but now it is no longer available in this server version (3.6.0.58), what is the appropriate HW selection of the Decoding method for DS918+?

 

When is HW Encoding necessary to select, if at all?

 

Thanks

 

Server log? Thanks.

Link to comment
Share on other sites

Everbrave

Server log? Thanks.

 

 

VA-API is not available as an option!

The server log is attached as well as screen shots for the Web-UI.

 

EDIT: I think the server lo I sent, log-11.txt, is from my Windows server, so please ignore this one.

post-262327-0-69707900-1541019973_thumb.png

post-262327-0-65964700-1541019987_thumb.png

Log-11.txt

Edited by Everbrave
Link to comment
Share on other sites

solabc16

Hello @Everbrave 

 

As per the development/test thread, can you post a log from just after the server has started, so we can see the FFmpeg decoder/encoder detection.

 

Best

- James

Link to comment
Share on other sites

Everbrave

Hello @Everbrave 

 

As per the development/test thread, can you post a log from just after the server has started, so we can see the FFmpeg decoder/encoder detection.

 

Best

- James

 

 

here you go :)

Log-13.txt

Log-12.txt

Link to comment
Share on other sites

solabc16

Hello @@Everbrave

 

Unfortunately, these are still after a log rotation, rather than from when Emby Server is first started.

 

When convenient, the best thing to do will be to restart Emby Server - which you can do from the dashboard, then grab the most recent log.

 

Best

- James

Edited by solabc16
Link to comment
Share on other sites

Everbrave

Hello @@Everbrave

 

Unfortunately, these are still after a log rotation, rather than from when Emby Server is first started.

 

When convenient, the best thing to do will be to restart Emby Server - which you can do from the dashboard, then grab the most recent log.

 

Best

- James

 

done; hope these help.

Log-14.txt

Log-15.txt

Link to comment
Share on other sites

VA-API is not available as an option!

The server log is attached as well as screen shots for the Web-UI.

 

EDIT: I think the server lo I sent, log-11.txt, is from my Windows server, so please ignore this one.

 

This is rather a misunderstanding

 

There's no missing or dropped functionality

 

In the second screenshot you can see the "VAAPI H.264" encoder. That's all VAAPI support that has ever existed. 

 

Emby didn't have VAAPI accelerated decoding before.

 

(Don't believe? Go to the transcoding settings of an older Emby version; select QuickSync or Nvenc and see the decoder checkboxes; select VAAPI => no decoder checkboxes)

 

 

The only thing that is wrong here is that DXVA is shown.

This will be fixed in the next version.

 

 

PS: I can't make any announcements, but I can at least say that support for VAAPI decoding is under consideration ;-)

Link to comment
Share on other sites

Everbrave

This is rather a misunderstanding

 

There's no missing or dropped functionality

 

In the second screenshot you can see the "VAAPI H.264" encoder. That's all VAAPI support that has ever existed. 

 

Emby didn't have VAAPI accelerated decoding before.

 

(Don't believe? Go to the transcoding settings of an older Emby version; select QuickSync or Nvenc and see the decoder checkboxes; select VAAPI => no decoder checkboxes)

 

 

The only thing that is wrong here is that DXVA is shown.

This will be fixed in the next version.

 

 

PS: I can't make any announcements, but I can at least say that support for VAAPI decoding is under consideration ;-)

 

 

Well, that is interesting :)

I, and many others, have been using VA-API for HW-transcoding and there are few threads on that; one is 

 

https://emby.media/community/index.php?/topic/51051-is-ds718-and-ds918-units-supported-yet-for-hw-transcoding/page-3

 

where James also confirmed it.

 

So, there must be some misunderstanding, but which? :)

 

 

Nevertheless, getting back to the original question, Which HW-transcoding method should currently be selected for DS918+?

 

Thanks

Edited by Everbrave
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...