Jump to content

Trouble with images and programdata/metadata/people folder


Positano
 Share

Go to solution Solved by Happy2Play,

Recommended Posts

Positano

Hi there

 

I’ve spent a few hours going through the forum looking for answers but haven’t found a solution that works. What makes it all the more difficult is that due to MediaBroswer/Emby changing so rapidly over the last few years, what was true once is not necessarily true today. Settings you found on one page a couple of years ago have disappeared or moved to other pages making the forum help posts obsolete quite quickly. I looked for a current manual/user-guide/wiki that deals with my issue but had no luck.

 

On to my question – I have limited bandwidth so it’s very costly for me to download people images every time I migrate to a new computer or do a clean install. Moreover, I have tweaked my image library choosing in many cases actor images that I like. In the old days, I simply copied my saved imagesbyname folder over to the new install. That was handy and simple.

 

Unfortunately it seems no longer possible. I have tried to copy my alphabetized folder now into programdata/metadata/people. I have tried both enabling and disabling Library-Folder option ‘Save artwork and metadata into media folders’. But still my old images are not being used nor are the refreshly downloaded images via refresh metadata being stored there. After much investigating, I found that all the new photos were being saved in programdata-cache-images-resized-images with some nonsensical naming structure.

 

In a nutshell:

 

1. How can I get Emby to use my previously saved people images? Currently, it’s not looking for them in programdata/metadata/people.

 

2. How can I get Emby to save new people photos in programdata/metadata/people? This is where I want them for future migrations and fresh installs.

 

I’ve spent hours on this to no avail and would be grateful for a clear comprehensive answer.

 

Thanks to anyone who can help.

 

Windows 10

Emby Server

 

Link to comment
Share on other sites

Happy2Play

I found that all the new photos were being saved in programdata-cache-images-resized-images with some nonsensical naming structure.

 

In a nutshell:

 

1. How can I get Emby to use my previously saved people images? Currently, it’s not looking for them in programdata/metadata/people.

 

2. How can I get Emby to save new people photos in programdata/metadata/people? This is where I want them for future migrations and fresh installs.

 

I’ve spent hours on this to no avail and would be grateful for a clear comprehensive answer.

 

Thanks to anyone who can help.

 

Windows 10

Emby Server

 

"programdata/metadata/people" is the default location unless changed at Dashboard-Library-Advanced.

 

They are processed into the cache location also.

 

Have you run the Refresh People task? 

 

How are you determining "programdata/metadata/people" isn't being used?  Can you provide a specific example?

Link to comment
Share on other sites

Positano

Thanks for responding.

 

I had tried Refresh People several times.

 

I determined that "programdata/metadata/people" wasn’t being used by checking and comparing several actor images shown in the Emby web browser that were different than those saved in the "programdata/metadata/people" folder.

 

I searched for the images that were being shown and found them in the cache. After refreshing metadata for new actors, I then looked for the images again in "programdata/metadata/people" but they were not there. As mentioned earlier, they ended up in the cache.

 

Additionally, actor images I have in programdata/metadata/people are not being shown in the web browser. I see an empty place card. Only when I use Refresh Metadata are the pictures available, and then again they are the versions from the cache and not what is saved in metadata.

 

My Library Advanced Metadata path points accurately to programdata\metadata\People.

I am using a Portable version of Emby.

Link to comment
Share on other sites

  • Solution
Happy2Play

What path is show for "Metadata" on that Dashboard in Path box?
 
If you go to a actor image and select edit metadata what path is shown?
 

 

My Library Advanced Metadata path points accurately to programdata\metadata\People.

There is a slight quirk when adding custom paths to prevent folder overlap if you added that path.

 

If you put in custom path of "programdata\metadata\People" you probably have "programdata\metadata\People\metadata" as subfolder is added for metadata, cache and transcode custom locations.

 

***Portable will default to the proper location also, no need to edit this unless you have a custom location.

Edited by Happy2Play
  • Like 1
Link to comment
Share on other sites

Positano

 

There is a slight quirk when adding custom paths to prevent folder overlap if you added that path.

***Portable will default to the proper location also, no need to edit this unless you have a custom location.

 

Solution

 

I tried your solution of leaving Libraries-Advanced Metadata path empty.

Previously it had contained C:\Users\River\Desktop\programdata\metadata\People

 

I’ve attached two photos showing the fix to make it clear for other users who might have the same problem.

 

Thanks for your solution and your valuable time. Much appreciated!

 

Note: Originally, I had entered the custom path as I am using a portable version of Emby with my programdata folder not in the normal default location. Consequently, I thought it was necessary to specify its location. Other users might do the same thing and find themselves here looking for this solution.

post-344567-0-79601900-1534911268_thumb.jpg

post-344567-0-46081400-1534911277_thumb.jpg

Edited by Positano
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...