Jump to content


Photo
- - - - -

Harmony Ultimate/Elite Remote Not Working Correctly

Harmony Remote Emby

Best Answer ebr , 11 August 2018 - 03:13 PM

So, my best guess is it was some sort of configuration in MPC that had been changed and re-installing set it back to default.

 

Glad you got it going.

 

Thanks.

Go to the full post


  • Please log in to reply
23 replies to this topic

#1 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 04 August 2018 - 09:35 AM

Has anyone had recent issues with Harmony remotes in Emby for Windows Media Center?

 

My Ultimate MCE remote software does not work correctly. It was working fine previously. I tried different devices to see if that worked.

 

OrTek

Hama

MCE SE

 

I have got the IR Blasters for the Harmony and the Hama

The MCE SE will not operate at all. Neither will OrTek

Hama works apart from the play / pause.

I bought another Hama remote to train it but the play / pause do not function correctly for that either. One button restarts the episode and the other stops it.

 

Running Windows 8.1 on a Mini PC NUC 

Running MPC-HC as an external player in Emby WMC

 

I even bought the Harmony Elite thinking it was the Ultimate that was not functioning correctly but it is the same with that too.

 

Update

 

I have just opened up an episode within MPC-HC externally to Emby WMC and the play / pause buttons work fine.

I also tried installing VLC and had issues with play / pause in Emby. No issue with play / pause with VLC outside Emby.

The Emby default player works fine. Play / pause works correctly on all remotes.

 

Is this an Emby issue Guys


Edited by Steverido, 04 August 2018 - 10:34 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126619 posts
  • Local time: 08:39 PM

Posted 04 August 2018 - 10:37 AM

Can you use the remote throughout other parts of wmc besides emby?

#3 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 04 August 2018 - 11:54 AM

Can you use the remote throughout other parts of wmc besides emby?

Hi Luke, I can.

 

It is only the play and pause button that is the issue. Have added server log.

Attached Files



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126619 posts
  • Local time: 08:39 PM

Posted 04 August 2018 - 01:07 PM

Can you play and pause on other areas of wmc?

#5 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 04 August 2018 - 04:23 PM

Can you play and pause on other areas of wmc?

I can Luke. It only seems to be within Emby.



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44118 posts
  • Local time: 08:39 PM

Posted 04 August 2018 - 04:50 PM

I can Luke. It only seems to be within Emby.

 

That seems very strange - unless there is a focus problem of some sort (like EMC is losing focus so it doesn't get the events).

 

We are just using the regular WMC player and it is the one processing the events.



#7 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 06 August 2018 - 03:56 PM

That seems very strange - unless there is a focus problem of some sort (like EMC is losing focus so it doesn't get the events).
 
We are just using the regular WMC player and it is the one processing the events.


What does this mean ebr?

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126619 posts
  • Local time: 08:39 PM

Posted 06 August 2018 - 04:50 PM

What he's saying is that he doesn't think there's an issue here with Emby for WMC and he thinks there may be something going on in your environment that is causing this. That's why at this point we're still asking you questions and not really having many answers.



#9 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 555 posts
  • Local time: 08:39 PM

Posted 06 August 2018 - 07:17 PM

https://www.thegreen...php?f=7&t=11733

I hope that helps confirm your using g the right profile

#10 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 09 August 2018 - 02:27 PM

I have always used the Microsoft Media Center SE profile and still having the same issue.

Hope this answers your questions.

#11 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 10 August 2018 - 12:30 AM

https://www.thegreen...php?f=7&t=11733
I hope that helps confirm your using g the right profile


Device type: Computer -> Media Center PC - This is the only setting that I have not done looking at it.
Manufacturer: Microsoft - Always use this setting
Model: Windows Media Center SE -Always use this setting

I will try again tonight with the device type as a computer - Media Center PC

Report back to let you know if it has worked

#12 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 11 August 2018 - 10:36 AM

Gents,

 

I have tested the remote in WMC and the play/pause works completely fine.

 

I can't get the Harmony profile to work for Microsoft MCE SE at all.

 

I have tried the Hama & OrTek profiles and they work apart from the play/pause button on the Harmony remote. That is my ultimate and elite. Incidently I have the Hama remote too and inside Emby for WMC the play/pause button has the same issue as the Harmony remotes.

 

I understand that you are using WMC player and therefore it should work. 

 

I have also removed the external player and tried the play/pause with the default player and it works fine.

 

But why are all the Harmony profiles not woking correctly? Edited: It can't be the Harmony profiles because the Hama remote does the same thing so it has to be software related.  

 

Strange thing is that the play/pause buttons stopped working correctly suddenly. I had not made any changes to the software.

 

Emby Server - 3.5.20 - Updated 17/07/2018

MB-Classic 3.0.307.0 - Updated 02/06/2018

 

I am convinced that the issue started after the server updated to 3.5.20

 

Gents, could you send me an old version of Emby to try? That we we can try and narrow it down.


Edited by Steverido, 11 August 2018 - 10:55 AM.


#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44118 posts
  • Local time: 08:39 PM

Posted 11 August 2018 - 11:54 AM

I have also removed the external player and tried the play/pause with the default player and it works fine.

 

You are using an external player in EMC...?

 

Sorry, I totally missed that.

 

If that's the case, Emby (or WMC) isn't in control at all.  It is your external player not responding to the keys.



#14 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 11 August 2018 - 02:10 PM

You are using an external player in EMC...?

 

Sorry, I totally missed that.

 

If that's the case, Emby (or WMC) isn't in control at all.  It is your external player not responding to the keys.

But the same player, MPC-HC works fine outside of Emby ebr. I also went into the options and the keys for play/pause is correct.

 

The only one thing I have not checked is the settings for MPC-HC when it is running in Emby.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126619 posts
  • Local time: 08:39 PM

Posted 11 August 2018 - 02:12 PM

Make sure that mpchc has focus and is the top most application.

We're doing our best to help here but remember that we're not the developers of mpchc and therefore will not be able to answer all questions related to it.

#16 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 11 August 2018 - 02:20 PM

Make sure that mpchc has focus and is the top most application.

We're doing our best to help here but remember that we're not the developers of mpchc and therefore will not be able to answer all questions related to it.

Luke, not sure what you mean by your first sentence.

 

Bye the way, if I try VLC player too then it is the same issue. All commands are okay apart from play/pause.

 

Appreciate your help too. Gets a bit frustrating spending loads of time trying to figure it out. :(



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126619 posts
  • Local time: 08:39 PM

Posted 11 August 2018 - 02:26 PM

Maybe mpchc is not the top most window. Try clicking into it with a mouse, then try the remote again.

#18 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44118 posts
  • Local time: 08:39 PM

Posted 11 August 2018 - 02:50 PM

Yes, that is the problem (as I had mentioned previously as well).  The player app probably does not have focus.  Click on the video window with your mouse and I bet your remote will start working.

 

Again, we do our best to make this be the case when launching an external player but cannot always guarantee it.  You may have installed something else on your system which is grabbing focus after we launch the player.



#19 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 11 August 2018 - 02:50 PM

Maybe mpchc is not the top most window. Try clicking into it with a mouse, then try the remote again.

Tried that Luke. No luck I am afraid.



#20 Steverido OFFLINE  

Steverido

    Advanced Member

  • Members
  • 203 posts
  • Local time: 12:39 AM

Posted 11 August 2018 - 02:52 PM

Yes, that is the problem (as I had mentioned previously as well).  The player app probably does not have focus.  Click on the video window with your mouse and I bet your remote will start working.

 

Again, we do our best to make this be the case when launching an external player but cannot always guarantee it.  You may have installed something else on your system which is grabbing focus after we launch the player.

Tried it ebr. This PC is specifically for Emby. I don't have any other programmes on it apart from Chrome. The remote does work. It is just the play/pause. They do work but play restarts the programme and pause stops it.


Edited by Steverido, 11 August 2018 - 02:53 PM.






Also tagged with one or more of these keywords: Harmony, Remote, Emby

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users