Jump to content

How to get logs for the android app?


aptalca
 Share

Go to solution Solved by Luke,

Recommended Posts

I'm testing the emby android app on a chromebook (Samsung Chromebook Plus v1) and there a few issues I encountered. I'd like to troubleshoot further before bringing it up here.

 

How do I get logs from the android app?

 

Thanks

Link to comment
Share on other sites

There aren't any, although i'm planning to add a debug option to activate them. Can you please describe the issue that you're having? Thanks.

Link to comment
Share on other sites

Sure, I'm on the stable chrome os channel and the latest emby android app.

 

If I close emby with the x at the top right, the next time, it does not load. I get the header and the black background, but no spinning circle, nothing loading. At that point, the only way to make it work again is either force stopping the emby app in android app settings, or rebooting chrome os.

 

If I close emby by clicking the back arrow at the top left repeatedly until it goes all the way back end exits, the next time it opens just fine.

 

I tested this many times to confirm the behavior and it's consistent.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hi @@Luke

 

Any news on this? Were you able to reproduce the issue?

 

I'm currently on the beta, which is chrome os 69.0.3497.73, the issue is there and it is 100% consistent. Close it with the "x", next time you get blank screen, no spinner (requires force stopping emby). But if you close with the back button, next time you open, you initially get the blank screen, but shortly after you get the spinner and then everything loads.

 

Let me know if there is any troubleshooting I can do on my end.

Link to comment
Share on other sites

We will look into this, thanks.

 

Luke,

 

I can confirm this exact behavior on a Chromebook running the stable Emby for Android app and on a Chromebook running the beta Emby for Android app.

Edited by blade005
Link to comment
Share on other sites

Sure, I'm on the stable chrome os channel and the latest emby android app.

 

If I close emby with the x at the top right, the next time, it does not load. I get the header and the black background, but no spinning circle, nothing loading. At that point, the only way to make it work again is either force stopping the emby app in android app settings, or rebooting chrome os.

 

If I close emby by clicking the back arrow at the top left repeatedly until it goes all the way back end exits, the next time it opens just fine.

 

I tested this many times to confirm the behavior and it's consistent.

 

Thank you for reporting this and the behavior with the back arrow that will allow a restart of Emby for Android without performing a FORCE STOP or a reboot of Chromebook.

 

I am on Stable Chrome OS and find if I exit with back button as you suggested, I do have to attempt to OPEN the Emby app twice before it opens and the app opens in a non-maximized Portrait mode as if it were opening on a phone screen. Once it opens I can then maximize to get it back to full screen. Are you seeing similar behavior?

Edited by blade005
Link to comment
Share on other sites

  • 4 weeks later...

Thank you for reporting this and the behavior with the back arrow that will allow a restart of Emby for Android without performing a FORCE STOP or a reboot of Chromebook.

 

I am on Stable Chrome OS and find if I exit with back button as you suggested, I do have to attempt to OPEN the Emby app twice before it opens and the app opens in a non-maximized Portrait mode as if it were opening on a phone screen. Once it opens I can then maximize to get it back to full screen. Are you seeing similar behavior?

 

I'm on beta chromeOS now and use the stable emby. If I exit with the back arrow, the next time, it opens just fine, and in fullscreen.

Link to comment
Share on other sites

I'm on beta chromeOS now and use the stable emby. If I exit with the back arrow, the next time, it opens just fine, and in fullscreen.

 

Thanks for the update. I am seeing the same behavior on Stable Chrome OS and Beta Android app now. Using the back arrow or the ESC button on keyboard will close out app and it will open again in fullscreen mode. Use the X (Exit) button in upper right corner and I get a blank screen with the next OPEN and have to do a FORCE STOP on Emby app to get it up and running.

 

@@Luke

Stable CHROME OS and BETA Android app. Back button or ESC button allows exit and restart with no issue. Using the X (Exit) button on Emby app brings up a blank screen on next OPEN and requires a FORCE STOP of app.

Link to comment
Share on other sites

  • 3 months later...
  • 9 months later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...