Jump to content
aahmyu

Shield subtitle problem

Recommended Posts

aahmyu

Hello, I'm not sure if this is intended but when playing something "Anime" that has a styled subtitles the shield ignores all styles and positions of the texts. And sometimes doesn't display it at all. The same files works fine on emby android with styles and without transcoding. Using latest beta of everything and the extract subtitle is turned off in the server.

 

Edit: All subtitles are internal ssa/ass

 

Edit2: just tried playing a file with the external player option "vlc" and the subs worked fine. Not sure why the emby app is not able to display styled subs fine

 

Regards

Edited by aahmyu

Share this post


Link to post
Share on other sites
ebr

Hi.  The Google player on Android TV only has basic support for those types of subtitles.  It doesn't support the styles or positioning at this time.

Share this post


Link to post
Share on other sites
aahmyu

Hi.  The Google player on Android TV only has basic support for those types of subtitles.  It doesn't support the styles or positioning at this time.

 

This is so sad. I don't care much about fonts/colors but the positioning is important. Maybe you guys will implement the mpv player at some point?  because it works fine on android phones.

Share this post


Link to post
Share on other sites
Spaceboy

This is so sad. I don't care much about fonts/colors but the positioning is important. Maybe you guys will implement the mpv player at some point? because it works fine on android phones.

mpv is already available on ATV. But don’t update to Oreo

Share this post


Link to post
Share on other sites
aahmyu

@@ebr do you know if the styles and positions used to work on Android Nougat? I think they did but I'm not sure.

And if they did, what changes in oreo dropped their support?

Share this post


Link to post
Share on other sites
ebr

mpv is already available on ATV. But don’t update to Oreo

 

Only for live TV/recordings because its other shortcomings (lack of audio support and propensity to crash on this platform) make it not a very good choice for main media.

 

 

@@ebr do you know if the styles and positions used to work on Android Nougat? I think they did but I'm not sure.

And if they did, what changes in oreo dropped their support?

 

This has nothing to do with the Android version.  The Google player has never supported these subtitle styles.

Share this post


Link to post
Share on other sites
aahmyu

Only for live TV/recordings because its other shortcomings (lack of audio support and propensity to crash on this platform) make it not a very good choice for main media.

 

 

 

This has nothing to do with the Android version. The Google player has never supported these subtitle styles.

So when you guys switch to mpv for media will styles work?

Share this post


Link to post
Share on other sites
Luke

I would say that regardless of what player we use, we hope to improve our support for embedded subtitle styles in the future.

Share this post


Link to post
Share on other sites
aahmyu

I would say that regardless of what player we use, we hope to improve our support for embedded subtitle styles in the future.

I really hope so. This is a just a thought. But if mpv fix the issue would you guys consider adding it as an option for the client? Like I said before everything is working fine on my phone using oreo.

Share this post


Link to post
Share on other sites
ebr

I really hope so. This is a just a thought. But if mpv fix the issue would you guys consider adding it as an option for the client? Like I said before everything is working fine on my phone using oreo.

 

Do you require anything other than stereo audio?

Share this post


Link to post
Share on other sites
aahmyu

Do you require anything other than stereo audio?

Not really, stereo is fine for me. As long as the video is working fine with its subtitle I'll be happy.

Share this post


Link to post
Share on other sites
maegibbons

Not really, stereo is fine for me. As long as the video is working fine with its subtitle I'll be happy.

 

Hi @@ebr

 

is this not a good reason to "also" have a "prefer mpv" in the normal playback section so that we can choose to try MPV for specific scenarios?

 

You can then choose to use MPV for eithr/or/both Live YV and Normal Media playback

 

Krs

 

Mark

Share this post


Link to post
Share on other sites
aahmyu

If the mpv is already there but is only being used for live TV. I think it's best if we can have an option for this. It's kinda sad that what fixes my problem is there but can't be used by me.

Share this post


Link to post
Share on other sites
Spaceboy

If the mpv is already there but is only being used for live TV. I think it's best if we can have an option for this. It's kinda sad that what fixes my problem is there but can't be used by me.

for now you could add mpv as an external player until this is given more consideration

Share this post


Link to post
Share on other sites
aahmyu

for now you could add mpv as an external player until this is given more consideration

I really don't like the idea of external players. I prefer the Emby app. But yeah I hope ebr/luke find a solution soon enough.

  • Like 1

Share this post


Link to post
Share on other sites
Spaceboy

I really don't like the idea of external players. I prefer the Emby app. But yeah I hope ebr/luke find a solution soon enough.

100% agree

Share this post


Link to post
Share on other sites
ebr

Hi @@ebr

 

is this not a good reason to "also" have a "prefer mpv" in the normal playback section so that we can choose to try MPV for specific scenarios?

 

You can then choose to use MPV for eithr/or/both Live YV and Normal Media playback

 

Krs

 

Mark

 

When it was first implemented I tried using it for normal video playback and was inundated with "why did you screw up the great playback I had before" posts even in beta :).

 

I may try again but it will have to be limited to stereo setups or I will spend too much time explaining to people why they lost their 5.1 surround sound.

 

Gonna have to wait until the current issues with Oreo are figured out though. MPV is just way too unstable at this moment.

Share this post


Link to post
Share on other sites
maegibbons

Well my use case is stereo and I have to say on the FTV MPV is pretty good.- so bring it on!!!

 

On the MI under oreo it sucks.

 

Krs

 

Mark

Share this post


Link to post
Share on other sites
aahmyu

When it was first implemented I tried using it for normal video playback and was inundated with "why did you screw up the great playback I had before" posts even in beta :).

 

I may try again but it will have to be limited to stereo setups or I will spend too much time explaining to people why they lost their 5.1 surround sound.

 

Gonna have to wait until the current issues with Oreo are figured out though. MPV is just way too unstable at this moment.

Can you explain a bit more? My phone is running oreo with emby using mpv just fine. If you add an extra setting disabled by default to use the mpv for people who needs it then you don't need to worry about the 5.1 audio issues. Tbh I don't have faith neither in Google fixing the subtitles nor in the mpv people fixing the audio. I have faith in you though :). Switching on/off the external player option is not fun :(

Share this post


Link to post
Share on other sites
aahmyu

Can you please tell me whats wrong with this file? @@ebr @@Luke

It used to direct play fine, now it says direct play error and exceeded max bitrate and no matter what quality i choose it will transcode to 720x400 or something and refuses to direct play. It still play fine on android oreo phone and like i said it used to play fine on my shield too. Is it also an exoplayer problem?

 

And also while this file is being transcoded the emby web interface stop responding until i stop the the play.

ffmpeg.txt

Edited by aahmyu

Share this post


Link to post
Share on other sites
ebr

Hi.  Please play this item in the app and follow the instructions on sending a log from the app.  Please be sure to follow all the instructions.

 

Thanks.

Share this post


Link to post
Share on other sites
aahmyu

Ok i just sent the logs. the time is 16:55, the name of the episode is: the day a new demon was born. And i already attached the ffmpeg log. The user name is Vay

Edited by aahmyu

Share this post


Link to post
Share on other sites
ebr

Ok i just sent the logs. the time is 16:55, the name of the episode is: the day a new demon was born. And i already attached the ffmpeg log. The user name is Vay

 

 

There are graphic subtitles selected which are being burned in on the server but taking too long.

Share this post


Link to post
Share on other sites
aahmyu

There are graphic subtitles selected which are being burned in on the server but taking too long.

The subtitles format is pgs and and it doenst transcode for me. I was just watching something direct playing with pgs. Hell, even plex played the file directly :). But I'm not sure why the direct playing is failing. Like I said this file used to direct play for me.

Share this post


Link to post
Share on other sites
ebr

The log you posted had dvb subs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...