Jump to content


Photo

Shield subtitle problem

Subtitle Shield

  • Please log in to reply
29 replies to this topic

#1 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 03 July 2018 - 03:20 PM

Hello, I'm not sure if this is intended but when playing something "Anime" that has a styled subtitles the shield ignores all styles and positions of the texts. And sometimes doesn't display it at all. The same files works fine on emby android with styles and without transcoding. Using latest beta of everything and the extract subtitle is turned off in the server.

Edit: All subtitles are internal ssa/ass

Edit2: just tried playing a file with the external player option "vlc" and the subs worked fine. Not sure why the emby app is not able to display styled subs fine

Regards

Edited by aahmyu, 03 July 2018 - 04:16 PM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46018 posts
  • Local time: 12:35 AM

Posted 04 July 2018 - 10:13 AM

Hi.  The Google player on Android TV only has basic support for those types of subtitles.  It doesn't support the styles or positioning at this time.



#3 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 04 July 2018 - 11:49 AM

Hi.  The Google player on Android TV only has basic support for those types of subtitles.  It doesn't support the styles or positioning at this time.

 

This is so sad. I don't care much about fonts/colors but the positioning is important. Maybe you guys will implement the mpv player at some point?  because it works fine on android phones.



#4 Spaceboy OFFLINE  

Spaceboy

    Advanced Member

  • Members
  • 3866 posts
  • Local time: 05:35 AM

Posted 04 July 2018 - 12:34 PM

This is so sad. I don't care much about fonts/colors but the positioning is important. Maybe you guys will implement the mpv player at some point? because it works fine on android phones.

mpv is already available on ATV. But don’t update to Oreo

#5 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 05 July 2018 - 01:29 AM

@ebr do you know if the styles and positions used to work on Android Nougat? I think they did but I'm not sure.
And if they did, what changes in oreo dropped their support?

#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46018 posts
  • Local time: 12:35 AM

Posted 05 July 2018 - 09:07 AM

mpv is already available on ATV. But don’t update to Oreo

 

Only for live TV/recordings because its other shortcomings (lack of audio support and propensity to crash on this platform) make it not a very good choice for main media.

 

 

@ebr do you know if the styles and positions used to work on Android Nougat? I think they did but I'm not sure.
And if they did, what changes in oreo dropped their support?

 

This has nothing to do with the Android version.  The Google player has never supported these subtitle styles.



#7 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 06 July 2018 - 06:25 PM

Only for live TV/recordings because its other shortcomings (lack of audio support and propensity to crash on this platform) make it not a very good choice for main media.



This has nothing to do with the Android version. The Google player has never supported these subtitle styles.


So when you guys switch to mpv for media will styles work?

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134323 posts
  • Local time: 12:35 AM

Posted 06 July 2018 - 07:23 PM

I would say that regardless of what player we use, we hope to improve our support for embedded subtitle styles in the future.



#9 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 07 July 2018 - 03:53 AM

I would say that regardless of what player we use, we hope to improve our support for embedded subtitle styles in the future.


I really hope so. This is a just a thought. But if mpv fix the issue would you guys consider adding it as an option for the client? Like I said before everything is working fine on my phone using oreo.

#10 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46018 posts
  • Local time: 12:35 AM

Posted 07 July 2018 - 09:38 AM

I really hope so. This is a just a thought. But if mpv fix the issue would you guys consider adding it as an option for the client? Like I said before everything is working fine on my phone using oreo.

 

Do you require anything other than stereo audio?



#11 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 07 July 2018 - 09:45 AM

Do you require anything other than stereo audio?


Not really, stereo is fine for me. As long as the video is working fine with its subtitle I'll be happy.

#12 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2324 posts
  • Local time: 05:35 AM
  • LocationLutterworth, England, UK

Posted 07 July 2018 - 01:17 PM

Not really, stereo is fine for me. As long as the video is working fine with its subtitle I'll be happy.

 

Hi @ebr

 

is this not a good reason to "also" have a "prefer mpv" in the normal playback section so that we can choose to try MPV for specific scenarios?

 

You can then choose to use MPV for eithr/or/both Live YV and Normal Media playback

 

Krs

 

Mark



#13 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 07 July 2018 - 04:22 PM

If the mpv is already there but is only being used for live TV. I think it's best if we can have an option for this. It's kinda sad that what fixes my problem is there but can't be used by me.

#14 Spaceboy OFFLINE  

Spaceboy

    Advanced Member

  • Members
  • 3866 posts
  • Local time: 05:35 AM

Posted 07 July 2018 - 05:07 PM

If the mpv is already there but is only being used for live TV. I think it's best if we can have an option for this. It's kinda sad that what fixes my problem is there but can't be used by me.

for now you could add mpv as an external player until this is given more consideration

#15 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 07 July 2018 - 05:18 PM

for now you could add mpv as an external player until this is given more consideration


I really don't like the idea of external players. I prefer the Emby app. But yeah I hope ebr/luke find a solution soon enough.
  • Spaceboy likes this

#16 Spaceboy OFFLINE  

Spaceboy

    Advanced Member

  • Members
  • 3866 posts
  • Local time: 05:35 AM

Posted 07 July 2018 - 05:19 PM

I really don't like the idea of external players. I prefer the Emby app. But yeah I hope ebr/luke find a solution soon enough.

100% agree

#17 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46018 posts
  • Local time: 12:35 AM

Posted 07 July 2018 - 05:29 PM

Hi @ebr

 

is this not a good reason to "also" have a "prefer mpv" in the normal playback section so that we can choose to try MPV for specific scenarios?

 

You can then choose to use MPV for eithr/or/both Live YV and Normal Media playback

 

Krs

 

Mark

 

When it was first implemented I tried using it for normal video playback and was inundated with "why did you screw up the great playback I had before" posts even in beta :).

 

I may try again but it will have to be limited to stereo setups or I will spend too much time explaining to people why they lost their 5.1 surround sound.

 

Gonna have to wait until the current issues with Oreo are figured out though. MPV is just way too unstable at this moment.



#18 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2324 posts
  • Local time: 05:35 AM
  • LocationLutterworth, England, UK

Posted 07 July 2018 - 07:38 PM

Well my use case is stereo and I have to say on the FTV MPV is pretty good.- so bring it on!!!

 

On the MI under oreo it sucks.

 

Krs

 

Mark



#19 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 07 July 2018 - 07:41 PM

When it was first implemented I tried using it for normal video playback and was inundated with "why did you screw up the great playback I had before" posts even in beta :).

I may try again but it will have to be limited to stereo setups or I will spend too much time explaining to people why they lost their 5.1 surround sound.

Gonna have to wait until the current issues with Oreo are figured out though. MPV is just way too unstable at this moment.


Can you explain a bit more? My phone is running oreo with emby using mpv just fine. If you add an extra setting disabled by default to use the mpv for people who needs it then you don't need to worry about the 5.1 audio issues. Tbh I don't have faith neither in Google fixing the subtitles nor in the mpv people fixing the audio. I have faith in you though :). Switching on/off the external player option is not fun :(

#20 aahmyu OFFLINE  

aahmyu

    Advanced Member

  • Members
  • 150 posts
  • Local time: 06:35 AM

Posted 15 July 2018 - 07:01 AM

Can you please tell me whats wrong with this file? @ebr @Luke

It used to direct play fine, now it says direct play error and exceeded max bitrate and no matter what quality i choose it will transcode to 720x400 or something and refuses to direct play. It still play fine on android oreo phone and like i said it used to play fine on my shield too. Is it also an exoplayer problem?

 

And also while this file is being transcoded the emby web interface stop responding until i stop the the play.

Attached Files


Edited by aahmyu, 15 July 2018 - 07:02 AM.






Also tagged with one or more of these keywords: Subtitle, Shield

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users