Jump to content

Library sync thread has excited


kodiak437
 Share

Recommended Posts

kodiak437

Hi,

 

I've been starting to have a lot of sync issues with the Emby client for Kodi.  I'm running all Ras Pi 3 connected to the emby server and NAS.

 

I wiped all the Pi's and started from scratch but still have no luck and keep getting the error Library sync thread has excited.  Not sure if its a server issue or app issue.  I can play fine from the server.  i also installed kodi and the emby app on a windows system and it was able to sync ok

 

Any help would be greatly appreciated 

 

 

EMBY_Kodi.log

Link to comment
Share on other sites

Angelblue05

Yes I am working on the solution atm. Thank you. I should have a build up shortly.

Link to comment
Share on other sites

Angelblue05

You are on Leia... Sorry it's not fully supported atm. Looks like they changed things in the database again. 

Link to comment
Share on other sites

kodiak437

Hi Angelblue 

 

Thanks for the quick update with this.  I just installed on my windows system that started having the same error as well and so for so good.  I will test my other systems later and let you know.  

 

 

  • Like 1
Link to comment
Share on other sites

tosa65

@@kodiak437

 

Can you try this build? Just install from zip over your existing install. Restart Kodi to be safe. Let me know if you still experience your issue, thank you.

 

Kodi has change the DB from 109 to 110

Link to comment
Share on other sites

Angelblue05

Kodi has change the DB from 109 to 110

Kodi Leia is not fully supported. This thread is not regarding Leia but Krypton. Thank you.

  • Like 1
Link to comment
Share on other sites

kodiak437

So far no issues.  All my boxes are back up and running.  Also did a full sync to make sure.  

  • Like 1
Link to comment
Share on other sites

Angelblue05

Perfect, thank you for confirming. I'll post the new build shortly. I have one more thing to fix.

Link to comment
Share on other sites

tosa65

Kodi Leia is not fully supported. This thread is not regarding Leia but Krypton. Thank you.

Yes, but i wrote that only just for Info...

Link to comment
Share on other sites

flatline69

Unfortunately I just ran into this - logging shows it cannot find 'tag' in the database and refuses to sync. Instead of troubleshooting properly, I ended up wiping everything and currently in the process of rebuilding my libraries as it was a convergence of updates for Emby (legacy->3.4.1.0) and Emby for Kodi (3.0.26a->3.0.27a) running on Leia (unsupported, I know...)

10:47:57.387 T:3684680560  NOTICE: EMBY.default -> plugin.video.emby started
10:47:57.405 T:3684680560  NOTICE: EMBY.default -> Parameter string: ?mode=manualsync params: {'mode': ['manualsync']}
10:47:57.430 T:3684680560  NOTICE: EMBY.connectionmanager -> Begin ConnectionManager constructor
10:47:57.481 T:3684680560  NOTICE: Previous line repeats 1 times.
10:47:57.481 T:3684680560  NOTICE: EMBY.utils -> Toggling screensaver:  {u'jsonrpc': u'2.0', u'id': 1, u'result': True}
10:47:57.515 T:3684680560  NOTICE: EMBY.database -> opened: /storage/.kodi/userdata/Database/emby.db - 3664405952
10:47:57.530 T:3684680560  NOTICE: EMBY.database -> Verifying emby DB
10:47:57.555 T:3684680560  NOTICE: EMBY.database -> opened: /storage/.kodi/userdata/Database/MyVideos109.db - 3664250448
10:47:57.741 T:3684680560  NOTICE: EMBY.views -> sorted views: [u'Books', u'Kids Movies', u'Kids TV', u'Movies', u'TV']
10:47:57.756 T:3684680560  NOTICE: EMBY.views -> Clearing nodes properties.
10:47:57.824 T:3684680560  NOTICE: EMBY.views -> creating view Kids Movies: 384bb658bdd82344138c376d0e4945c0
10:47:57.841 T:3684680560  NOTICE: EMBY.database -> ERROR:: Type: <class 'sqlite3.OperationalError'> Value: no such table: tag
10:47:57.856 T:3684680560  NOTICE: EMBY.database -> closing: /storage/.kodi/userdata/Database/MyVideos109.db - 3664250448
10:47:57.872 T:3684680560  NOTICE: EMBY.database -> ERROR:: Type: <class 'sqlite3.OperationalError'> Value: no such table: tag
10:47:57.889 T:3684680560  NOTICE: EMBY.database -> closing: /storage/.kodi/userdata/Database/emby.db - 3664405952
10:47:57.908 T:3684680560  NOTICE: EMBY.default -> ERROR:: no such table: tag
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby/default.py", line 179, in <module>
                                                Main()
                                              File "/storage/.kodi/addons/plugin.video.emby/default.py", line 72, in __init__
                                                self._library_sync(mode)
                                              File "/storage/.kodi/addons/plugin.video.emby/default.py", line 163, in _library_sync
                                                librarysync.ManualSync().sync()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/librarysync.py", line 850, in sync
                                                return self.fullSync(manualrun=True)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/librarysync.py", line 284, in fullSync
                                                views.Views(cursor_emby, cursor_video).maintain()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 109, in maintain
                                                if self.compare_view(media_type, view_id, view_name, view_type):
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 174, in compare_view
                                                self.add_view(media_type, view_id, view_name, view_type)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 148, in add_view
                                                tag_id = self.get_tag(view_name)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 222, in get_tag
                                                self.kodi_cursor.execute(query, (tag,))
                                            OperationalError: no such table: tag
 
Also see there's a DB 109 and 110 which is why before I wiped everything explains why I wasn't seeing new content I was adding via Emby on my Kodi box which led me down this path to begin with (thought something was broken---ended up creating a lot more work for myself in the end...):
 

-rw-r--r--    1 root     root       1810432 Dec 31  2014 Addons27.db
drwxr-xr-x    2 root     root          4096 Dec 31  2014 CDDB
-rw-r--r--    1 root     root         28672 Dec 31  2014 Epg11.db
-rw-r--r--    1 root     root        184320 Dec 31  2014 MyMusic70.db
-rw-r--r--    1 root     root             0 Jun  9 11:23 MyVideos109.db
-rw-r--r--    1 root     root        376832 Dec 31  2014 MyVideos110.db
-rw-r--r--    1 root     root         40960 Dec 31  2014 TV32.db
-rw-r--r--    1 root     root         94208 Jun  9 11:21 Textures13.db
-rw-r--r--    1 root     root         20480 Dec 31  2014 ViewModes6.db
-rw-r--r--    1 root     root         24576 Jun  9 10:42 emby.db
 
EDIT: Should have just changed this file:
EDIT: Fortunately I had the common sense to backup emby-server structure before upgrading to 3.4.1.0 and could restore it... whew.
 
Edited by flatline69
  • Like 1
Link to comment
Share on other sites

Angelblue05

Yea, but as I said I didn't fix Leia. It's not supported because they are still changing things around. Glad you found where to fix it.

Link to comment
Share on other sites

flatline69

Yea, but as I said I didn't fix Leia. It's not supported because they are still changing things around. Glad you found where to fix it.

 

Yup no worries - I blame me because I went for the nuclear option instead of properly troubleshooting.

Link to comment
Share on other sites

Yup no worries - I blame me because I went for the nuclear option instead of properly troubleshooting.

 

Hi!

 

What are the changes that need to be done.... i don´t want to revert back to krypton because leia coreelec build have better HDR support ;)

Edited by b0mb
Link to comment
Share on other sites

flatline69

Hi!

 

What are the changes that need to be done.... i don´t want to revert back to krypton because leia coreelec build have better HDR support ;)

 

Using the same here (8.90.3) - edit ~/.kodi/addons/plugin.video.emby/resources/lib/database.py and change Line #29 from '18':109 to '18':110

 

I ended up uninstall Emby from the device; removing emby.db, MyVideos*.db, MyMusic*.db and Textures*.db and then resynching all my content after reinstalling Emby and editting the file (cancelled setup until all this was done.) I was getting duplicate titles in in videos/music and attempting to clean either would crash Kodi. Took about an hour but it's all good now.

 

Also, I turned off automatic updates to notify me of updates :)

 

EDIT: Coffee, it makes a difference.

Edited by flatline69
  • Like 2
Link to comment
Share on other sites

tosa65

Using the same here (8.90.3) - edit ~/.kodi/addons/plugin.video.emby/resources/lib/database.py and change Line #29 from '18':109 to '18':110

 

 

That worked for me.
Then I did a manual sync. Finished.
 
I did not have to delete files.
 
Thank you Flatline (y)
  • Like 1
Link to comment
Share on other sites

Angelblue05

That worked for me.

Then I did a manual sync. Finished.

 

I did not have to delete files.

 

Thank you Flatline (y)

I increased the Leia database version in the latest build (3.0.28)

  • Like 1
Link to comment
Share on other sites

Kodi_Newcomer

Hm i have the same problem now. I know i use Leia, but Yesterday IT works i have'nt Update Kodi since a View days. But today i have the same error. So Yesterday it works today not, i did nothing. So i dont Unserstand whats happend.

 

Here is my Log https://paste.kodi.tv/ixodilohud

Link to comment
Share on other sites

Angelblue05

Update Leia version.

 

Edit: Also it's quite possible not everything is working with Leia since it's not fully supported, the database is still changing.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

flatline69

Update Leia version.

 

Edit: Also it's quite possible not everything is working with Leia since it's not fully supported, the database is still changing.

 

Agreed - in my case I went from CoreELEC 8.90.2 to 8.90.3 which has a later revision of Kodi 18 (Leia) in which case, the DB ver# increased along with it. If you live on the bleeding edge, be ready to get cut :) I'm just more mad at myself for not looking before I leaped - fortunately I was able to recover in fairly short order.

  • Like 1
Link to comment
Share on other sites

Karajorma

Is it possible to have Emby report the error rather than just spitting out a generic error message? It might be nicer to have it say something like "Emby expected to find video database version 109. Found newer version 110" rather than a generic sync error which could have other causes.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...