Jump to content

Library sync thread has excited


kodiak437
 Share

Recommended Posts

Angelblue05

That being said, I've made a custom version of current stable with the old kodi 109 version.

http://kodi.emby.media/Public%20testing/plugin.video.emby-3.0.30-leia-109.zip

 

I understand that, but there's only one kodi 18 verification. We don't verify kodi 18-buildversion because this may vary from platform to platform. Everything that is associated to Leia is 18, so if the tag changes table and the code say put the tag in this table and you are on db 109 then you'll still get an error.

Link to comment
Share on other sites

Gerrit507

Why should the build version be platform dependent? Explain me what is your plan if kodi ever changes the db version between let's say 18.0 and 18.1, you just change the db value and everybody who still uses 18.0 is screwed.

 

This is just pointless...

Edited by Gerrit507
Link to comment
Share on other sites

flatline69

Only because I criticize something it means that I'm ungrateful?

 

You probably don't know anything about software development and because of that don't understand the critic...

 

Actually I do but I also realize there's real people behind the development who do it for free - a point which you appeared to have overlooked in your comment *shrug*

 

EDIT: Your PR is clever by the way, the idea makes sense.

Edited by flatline69
Link to comment
Share on other sites

Angelblue05

Why should the build version be platform dependent? Explain me what is your plan if kodi ever changes the db version between let's say 18.0 and 18.1, you just change the db value and everybody who still uses 18.0 is screwed.

 

This is just pointless...

Kodi only bumps version when there are database changes. And that never happens in RC. I appreciate your PR but do you understand that it will not solve the primary issue which is table schema changes, not the database number?

Link to comment
Share on other sites

Karajorma

Erm i don´t want to upset anyone but +1 for the problem.

 

How can i manually fix this myself... the devs don´t have to be chasing around kodi changing code all the time... (i can relate to the devs issue).

 

So can someone explain me like a 5 years old what do i have to do to fix this?

 

I understand you downloaded latest nightly... but when i use the android installer i cannot choose, it just downloads and do not let me install (iam on a mibox).

 

which nightly are you talking... emby or kodi? you downloaded from github? repo or what?

 

i cannot read minds or half sentences sorry.

 

 

edit: i think it is broken again i have the 3.03a from beta repo and leia alpha :S

 

I'm in much the same position myself. I use Kodi on Windows and I'm not certain which files I need. If I've got good, clear instructions I can definitely follow them but trying to read through half sentences is really difficult, especially when they say things like using Kodi Leia Alpha 2 and the Kodi site only appears to have downloads for alpha 1. 

 

Just give me links to the versions of Kodi and Emby which work and instructions on anything I have to do beyond just installing them please.

Link to comment
Share on other sites

Angelblue05

Look a few post above, I posted a link to a build that supports leia alpha1. Otherwise update to latest nightly.

Link to comment
Share on other sites

Gerrit507

Ok, I understand and comprehend what you mean now.

 

I made a PR for the music db version bump btw :)

  • Like 1
Link to comment
Share on other sites

abescalamis

Any suggestion to fix the music library? my video library has no issues I only get the exit notification with the music library.

 

 

***Nevermind, I manually fix the music database, all good now

Edited by abescalamis
  • Like 1
Link to comment
Share on other sites

Well i figured why i couldnt install the app on mi box and the install button was not on bold, you have to press power button two times quickly, than i could press the install button.

 

Latest nightly did not fix the issue, as someone said it was broken again.

 

what i did was go back to krypton and all good.

 

Now there is an alpha 2 release... i will miss the android features of kodi on android and google assistant... will wait for oreo or for leia beta i suppose.

Link to comment
Share on other sites

Angelblue05

@@Norin

 

It "should" work with Alpha 2. Maybe something else is causing an issue. Post (or pm) your Kodi log.

  • Like 1
Link to comment
Share on other sites

Gerrit507

I currently use your custom build with the old db versions in alpha2. So it doesn't have the latest db versions already. Only the nightlies that came right after alpha2 have the new db versions.

Edited by Gerrit507
Link to comment
Share on other sites

Angelblue05

I have alpha 2 installed and it's running the new db version. But then again, I'm on windows (that's another reason why supporting unreleased is a bit of a nightmare)... Well the custom version is in the public testing folder if you add kodi.emby.media as a source.

Edited by Angelblue05
Link to comment
Share on other sites

Gerrit507

I haven't even noticed that there is a alpha2 release, it seems to be the latest version that's running fine on my atv... And yes you are right on windows the latest nightlies have alpha2 but on Android they have alpha3 as build number

Edited by Gerrit507
Link to comment
Share on other sites

@@Norin

 

It "should" work with Alpha 2. Maybe something else is causing an issue. Post (or pm) your Kodi log.

 

Oh thanks for letting me know this, i had reverted back to krypton. But know i have oreo on mi box, so installed leia... having some issues, kodi was crashing like crazy, and emby addon did not populated all series, also wasnt updating my scrobbling right and i made some smartplaylists who are not working properly... repairing database and refreshing nodes didn´t do the trick. Also the smart playlists options not working on Oreo, but i must reply on kodi forum for that.

Link to comment
Share on other sites

otispresley

I was having this problem on all my existing Kodi installations no matter what nightly/alpha (Windows, Fire TV, Android TV). The upgrade to Alpha2 hung on all my Fire/Android TV boxes at database migration, so I ended up deleting the app data and starting over on all of them. Since then, the Emby for Kodi addon has been working perfectly.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...