Jump to content
richwphillips@yahoo.com

Slow loading library

Recommended Posts

richwphillips@yahoo.com

I had to uninstall and reinstall my Emby server and since I did that, it has been VERY slow to load my library of TV shows. It never took anywhere near this long before. I have a lot of shows and episodes so I expect it to take a few hours to load from scratch, but it has been loading all day and still only has a small fraction of the shows loaded and most of the shows it has loaded are still only partially complete. I'm on beta version 3.4.1.1 now, but it was just as slow on 3.4.1.0 when it was in beta. It will get to 79.3% complete (which can't be right based on how little of my content is showing up) and stop there for a long time before making incremental progress even though when I go to my library, very little has changed. Any idea what I might be doing wrong? Thanks.

Share this post


Link to post
Share on other sites
richwphillips@yahoo.com

Could it have anything to do with tvdb.com being down? Not sure how long they have been down, but they have posted a message that they are down indefinitely for maintenance. That was my preferred metadata source so I'm temporarily changing this to moviedb.com even though most of what I have are tv show episodes and seasons. Thanks for the quick reply.

Share this post


Link to post
Share on other sites
Happy2Play

Could it have anything to do with tvdb.com being down? Not sure how long they have been down, but they have posted a message that they are down indefinitely for maintenance. That was my preferred metadata source so I'm temporarily changing this to moviedb.com even though most of what I have are tv show episodes and seasons. Thanks for the quick reply.

 

Haven't had any issues process tonight's episode thru TVDB.  Did adding TMDB resolve your issue?

Share this post


Link to post
Share on other sites
Luke

Could it have anything to do with tvdb.com being down? Not sure how long they have been down, but they have posted a message that they are down indefinitely for maintenance. That was my preferred metadata source so I'm temporarily changing this to moviedb.com even though most of what I have are tv show episodes and seasons. Thanks for the quick reply.

 

Yes that would impact the performance of the first library scan.

Share this post


Link to post
Share on other sites
Luke

Is it just the api that is down? The website looks like it is up. I haven't tried the api tonight.

Share this post


Link to post
Share on other sites
richwphillips@yahoo.com

I just went to TVDB.com and this is what I found. The library does seem to be loading, but at a snail's pace. It has never loaded this slowly. I left at 9 PM last night and the scan was 79.3% completed. Now it's almost 5 AM and it's only 79.5% done. I do see progress in terms of some changes since I left, but not many. In the past (prior to version 3.4.0.0), the entire library scan took 2 hours at most. I installed the Media Portal plugin the other day. I never could get the Media Portal download on my computer working right so I uninstalled the plugin and eventually uninstalled the whole app from my computer, but this is when the problem started (before I uninstalled everything). Uninstalling it all hasn't helped with the speed issues. Again, thanks to all who take their time to read and try to help. I appreciate it.

 

Welcome

tvdb.com 
Since 1988

     

Hi Everybody:

After many years of continuous service, we have taken our website off-line for a while, to perform some much needed maintenance and improvements, and to expand our database and related services.

We will be back on-line soon.

Please note that our domain name is not for sale.

Thank you for stopping by!

Good Day!
The Staff at tvdb.com

Share this post


Link to post
Share on other sites
Luke

At this point I would just be patient and allow the scan to finish. Subsequent scans after the first one will be faster. You can also go back to my suggestion in post #2. Thanks.

Share this post


Link to post
Share on other sites
richwphillips@yahoo.com

Thanks, Luke. I'll keep the option of sending the log in reserve for now and see how the scan progresses while I'm at work today. I did try resetting our modem and rebooting the external hard drive where my videos reside to see if that would help. I noticed our network seemed a little slower than normal so I figured it couldn't hurt to try those things. I had to leave before I could really determine if that helped or not. I did notice one tv show folder increased from 62 files to 172 so that might be a sign that things are speeding up. I didn't notice any other changes that would support that opinion though so I'll have to see how it looks when I get home tonight. I know I have a large library (over 4 TB of video files) so I understand it needs time to scan all those files and get the appropriate metadata. It 's just that it loaded the library in only a few hours when I set up Emby the first time. The library may be a little larger now than it was then, but not much so the scan taking days instead of a few hours seemed odd. Anyway, as always, I appreciate your willingness to help the speed with which you reply to try to assist those of us who are less technically savvy.

Edited by richwphillips@yahoo.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...