Jump to content


Photo

"established connection was aborted by host software"

buffering server log error

  • Please log in to reply
4 replies to this topic

#1 newbluesman OFFLINE  

newbluesman

    Newbie

  • Members
  • 3 posts
  • Local time: 01:34 PM

Posted 30 April 2018 - 01:18 PM

Hi.  I'm getting enough buffering to be annoying, both on HD and standard channels. I just checked my server log during the last episode and found this at the time it happened:

  • 2018-04-30 12:22:04.604 Error HttpServer: Error in HttpListenerResponseWrapper: An established connection was aborted by the software in your host machine
        *** Error Report ***
        Version: 3.3.1.0
        Command line: C:\Users\admin\AppData\Roaming\Emby-Server\system\EmbyServer.dll
        Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1
        64-Bit OS: True
        64-Bit Process: True
        User Interactive: True
        Processor count: 2
        Program data path: C:\Users\admin\AppData\Roaming\Emby-Server\programdata
        Application directory: C:\Users\admin\AppData\Roaming\Emby-Server\system
        System.Net.Sockets.SocketException (0x80004005): An established connection was aborted by the software in your host machine
         at SocketHttpListener.SocketStream.Write(Byte[] buffer, Int32 offset, Int32 count)
         at SocketHttpListener.Net.HttpResponseStream.DisposeCore()
         at SocketHttpListener.Net.HttpResponseStream.Dispose(Boolean disposing)
         at System.IO.Stream.Close()
         at Emby.Server.Implementations.HttpServer.SocketSharp.WebSocketSharpResponse.CloseOutputStream(HttpListenerResponse response)
        System.Net.Sockets.SocketException
         at SocketHttpListener.SocketStream.Write(Byte[] buffer, Int32 offset, Int32 count)
         at SocketHttpListener.Net.HttpResponseStream.DisposeCore()
         at SocketHttpListener.Net.HttpResponseStream.Dispose(Boolean disposing)
         at System.IO.Stream.Close()
         at Emby.Server.Implementations.HttpServer.SocketSharp.WebSocketSharpResponse.CloseOutputStream(HttpListenerResponse response)

When we first started using Emby, the buffering was severe to the point at which my wife wouldn't use it.  I optimized everything I could find (I think...), shutting down all non-essential background activity, tuning our Wifi network and using 5 GHz just for the 3 devices on which we watch Emby-sourced live TV.  I've selected the best Wifi channel (no other users on it, -50 db signal at furthest device, -39 at closest one to access point in a 1 floor 2 BR apartment). We release the tuner before turning off each set each time.  And it works much better now - but we still get the above for several seconds at a time several times a day regardless of channel or renderer. It's not a deal breaker, but it's very frustrating for me (and it's driving my wife nuts).

 

The system includes an HDHomeRun Prime with Comcast M-card, Win7 PC (G630 Pentium, 2.7G, 8 gigs of RAM, latest service pack) running Emby 3.3.1.0, Samsung 55" and Samsung 24" "smart TVs" both running Emby app downloaded from the Samsung app store, plus a Raspberry Pi running Kodi into a not-so-smart Toshiba TV/monitor.  Network Monitor shows 100% quality and 93-95% signal strength on all 3 tuners.  My hardware monitor shows all parameters OK, including core temps of 33 to 40 deg C for both.

 

My best guess right now is that the PC isn't up to the task.  I know it's old and a G630's not a killer chip, but I expected it to be able to handle this as the top CPU  process / service at 3 to 5 on Task Manager. But I thought I'd post this to see if there are any other reasonable solutions before building a new PC just to run my Emby server.  Thanks!



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153338 posts
  • Local time: 01:34 PM

Posted 30 April 2018 - 01:37 PM

Hi there, can you please attach the complete emby server log? thanks.



#3 newbluesman OFFLINE  

newbluesman

    Newbie

  • Members
  • 3 posts
  • Local time: 01:34 PM

Posted 30 April 2018 - 02:08 PM

Hi there, can you please attach the complete emby server log? thanks.

 

Sure- thanks!!

 

David

Attached Files


Edited by newbluesman, 30 April 2018 - 02:13 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153338 posts
  • Local time: 01:34 PM

Posted 01 May 2018 - 11:04 AM

This log looks normal to me. We're about to have a new release so I would suggest trying with that and then we can re-evaluate. Thanks.



#5 newbluesman OFFLINE  

newbluesman

    Newbie

  • Members
  • 3 posts
  • Local time: 01:34 PM

Posted 01 May 2018 - 12:22 PM

Thanks, Luke - will do. Am I then correct in assuming that my 2.7G G630 PC is enough? I don’t need a new computer, but I’d build one as a dedicated Emby server host if it’d improve quality & consistency.

Edited by newbluesman, 01 May 2018 - 12:25 PM.






Also tagged with one or more of these keywords: buffering, server log error

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users