Jump to content

Is there a way to enable the analog audio out?


darkassassin07

Recommended Posts

darkassassin07

By default audio comes from the hdmi but not the analog out. This makes my stereo... Well it makes a pretty good art piece i guess :/

 

Maybe a setting or configuration file im missing?

 

 

/edit

 

This only seems to effect videos. Music. Plays from the analog.

 

As a side note, while casting from android to the pi, if you are playing video, and you start a new video before the current one ends, theater refuses to load anything else until you restart it.

It doesn't matter if you pressed stop before you started the next one, you have to let it finish, or click stop and exit the player with the mouse.

Edited by darkassassin07
Link to post
Share on other sites
darkassassin07

The only playback settings at all are:

-Preferred audio language [english]

-Video quality for local/internet streaming [auto]

-Music quality when internet streaming [auto]

-play next epp/ show play next info [enabled]

-subtitle language/mode [english/no subtitles]

 

 

I have spent a couple mins looking through the various files in the emby-theater-pi directory, but haven't found anything relevant so far...

 

Not sure what else to try.

Link to post
Share on other sites
darkassassin07

Exactly as the top two posts:

 

Play music, audio plays from HDMI and analog out (headphone jack)

Play a video, audio only plays from the HDMI

 

I don't have any other issues with playback on any media, just no analog audio with video.

Link to post
Share on other sites
darkassassin07

... :/ ?

 

 

It doesn't matter what format, or library im playing video. Mp4, avi, movies, tv shows, home vids. No video at all has audio from the analog out

Edited by darkassassin07
Link to post
Share on other sites

I had a look at omxplayer settings and to get analogue output you have to pass -o local. I tried it and it works but I can not get it to work in theater. Instead of local you can put both or hdmi.

Link to post
Share on other sites
darkassassin07

@@Luke

 

How could I go about fixing this? Without the analog out, my pi is useless as a emby box. The web app is to slow/buggy on chromium+raspbian and I cant find another option :/

 

Befor switching from plex to emby the pi was my most used device across all my users.

Link to post
Share on other sites

I haven't had a chance to look at this personally. This app is using omx player which I'm not really an expert with. Why not just use HDMI?

Link to post
Share on other sites
darkassassin07

The tv im using has really shitty speakers, i have a separate stereo for audio, but it uses the analog.

 

My only other option is to buy an HDMI audio extractor, but thats kind of an unnecessary cost when the rpi has analog onboard. It works with everything else, just not emby theater playing video.

That seems strange to me, why does it not use the systems audio settings?

Link to post
Share on other sites

That's what I would have expected too, I am just not really an expert with omx player. At some point when we build an install package, then we'll go through all of this. Thanks.

Link to post
Share on other sites

Hi @@Luke I am not sure you have read my post above to get analog out you have to pass the option -o local or -o both but I am haven’t had the time to figure out where you put that option in playbackhandler file

Link to post
Share on other sites
darkassassin07

Thank you @@denz, with that info I did a bit of poking around and fixed my problem :D

 

Open the file 'playbackhandler.js' and directly after:

var args = ["--alpha", "180"];

 

 

Add the lines:

args.push("--adev"); //(or -o, either way)

args.push("both");

 

 

 

Audio now plays from both sources :)

Edited by darkassassin07
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...