Jump to content

Can't play anything using MPC-HC?


sleepy
 Share

Recommended Posts

sleepy

Hi, no idea what changed but suddenly nothing will play using MPC-HC as an external player. I've removed it from the Emby for WMC Configurator, removed and reinstalled MPC-HC, Added it again in the configurator but to no avail. If I use the internal player everything plays fine. If I could turn subtitles on or off on the fly then I would leave the internal player set.

 

Anyone any idea? It's probably something really simple I am missing! Oh, I've reinstalled Server and Emby WMC apps too.

 

Kind regards,

Cog.

Link to comment
Share on other sites

Hi.  That's a configurator log.  We need the emc log from when you tried to play something that didn't play.  And, while you're at it, please explain exactly what  "nothing will play" means.

 

Thanks.

Link to comment
Share on other sites

sleepy

Well that's weird because I checked to make sure it isn't running in the background and it's definitely not there?

 

Sent from my 5080X using Tapatalk

Link to comment
Share on other sites

Yep, its playing:

2018-03-03 20:16:29.1352,Debug,,Response received from MPC-HC web interface: OnStatus('Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv - MPC-BE x64 - v1.5.2 (build 3148) beta',, 'Playing',, 261159,, '00:04:21',, 2679594,, '00:44:39',, 0,, 100,, 'D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv'),40,
2018-03-03 20:16:29.1357,Debug,,File: D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv Position 2611590000 Status playing,40,
2018-03-03 20:16:29.1357,Debug,,Sending Http Post to http://192.168.1.71:8096/emby/Sessions/Playing/Progress?positionTicks=2611590000&isPaused=False&isMuted=False&CanSeek=True&ItemId=220c0e0ef3e65d9be12838b7ac9bc2e8&PlayMethod=DirectPlay&VolumeLevel=100&format=Json,27,Worker thread for Common
2018-03-03 20:16:34.1412,Debug,,Response received from MPC-HC web interface: OnStatus('Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv - MPC-BE x64 - v1.5.2 (build 3148) beta',, 'Playing',, 266174,, '00:04:26',, 2679594,, '00:44:39',, 0,, 100,, 'D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv'),53,
2018-03-03 20:16:34.1418,Debug,,File: D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv Position 2661740000 Status playing,53,
2018-03-03 20:16:34.1418,Debug,,Sending Http Post to http://192.168.1.71:8096/emby/Sessions/Playing/Progress?positionTicks=2661740000&isPaused=False&isMuted=False&CanSeek=True&ItemId=220c0e0ef3e65d9be12838b7ac9bc2e8&PlayMethod=DirectPlay&VolumeLevel=100&format=Json,28,Worker thread for Common
2018-03-03 20:16:39.1449,Debug,,Response received from MPC-HC web interface: OnStatus('Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv - MPC-BE x64 - v1.5.2 (build 3148) beta',, 'Playing',, 271185,, '00:04:31',, 2679594,, '00:44:39',, 0,, 100,, 'D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv'),40,
2018-03-03 20:16:39.1454,Debug,,File: D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv Position 2711850000 Status playing,40,
2018-03-03 20:16:39.1460,Debug,,Sending Http Post to http://192.168.1.71:8096/emby/Sessions/Playing/Progress?positionTicks=2711850000&isPaused=False&isMuted=False&CanSeek=True&ItemId=220c0e0ef3e65d9be12838b7ac9bc2e8&PlayMethod=DirectPlay&VolumeLevel=100&format=Json,25,Worker thread for Common
2018-03-03 20:16:44.1493,Debug,,Response received from MPC-HC web interface: OnStatus('Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv - MPC-BE x64 - v1.5.2 (build 3148) beta',, 'Playing',, 276203,, '00:04:36',, 2679594,, '00:44:39',, 0,, 100,, 'D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv'),6,
2018-03-03 20:16:44.1493,Debug,,File: D:\TV Shows\TV Shows\Lethal Weapon\Season 1\Lethal Weapon - S01E17 - A Problem Like Maria [720p] [2017-03-08].mkv Position 2762030000 Status playing,6,
2018-03-03 20:16:44.1498,Debug,,Sending Http Post to http://192.168.1.71:8096/emby/Sessions/Playing/Progress?positionTicks=2762030000&isPaused=False&isMuted=False&CanSeek=True&ItemId=220c0e0ef3e65d9be12838b7ac9bc2e8&PlayMethod=DirectPlay&VolumeLevel=100&format=Json,22,Worker thread for Common

Perhaps you've accidentally got MPC running on a non-attached monitor or something?

 

I do see a couple of unrelated things in your log that you should address:

 

1) Your Server IP has changed.  You should set the option in the app to find the server automatically and log in.  After that, if you want to set it to log in to a specific user you can.  This will speed up the app startup significantly.

 

2) You are running an old beta version of the server.  You should update it either to the current stable or beta release.

 

Finally, there is a new beta of EMC as well if you would like to update to it (you are on an old beta of that too).

Link to comment
Share on other sites

sleepy

I've set the app to find server automatically and it starts up fine now. I wondered why it was taking awhile, I guessed it was updating the database at the time. Both Server and WMC App updated to latest beta releases now. Updated MPC to latest build too but still nothing playing. I immediately pulled the latest log file so hopefully that will show I tried to play an episode of Blindspot.

MBClassic-293201821289f3e48654adfbf17f205e073441c.log

Link to comment
Share on other sites

And it works fine if you don't use the external player?

 

Can we see a log of you doing that?

Link to comment
Share on other sites

Okay, both methods are throwing an error on the start and progress reporting but, perhaps, that only causes playback to not start with the external player.

 

It looks like we're getting a poorly formatted response from the server - or, at least, something it isn't expecting.  Luke, have the responses to playback progress reports changed in recent server versions?

Link to comment
Share on other sites

Okay, both methods are throwing an error on the start and progress reporting but, perhaps, that only causes playback to not start with the external player.

 

It looks like we're getting a poorly formatted response from the server - or, at least, something it isn't expecting.  Luke, have the responses to playback progress reports changed in recent server versions?

No, this will have to be debugged.

Link to comment
Share on other sites

Hi, is there any update for this one please?

 

TIA

Not yet, we thank you for your patience.

  • Like 1
Link to comment
Share on other sites

d00zah

MPC-BE (w/ Shark007 codecs/madVR) continues to work fine for me. Just got done watching a few movies.

Edited by d00zah
Link to comment
Share on other sites

It will be resolved two beta servers from now, thanks.

 

Thank you for being a part of the beta testing team.

Link to comment
Share on other sites

d00zah

Thank you for keeping up with WMC!! You guys can't get enough graditude in my book!!

 

what him say

Link to comment
Share on other sites

sleepy

Thank you for keeping up with WMC!! You guys can't get enough graditude in my book!!

Yep, what he said. I still think WMC is better than Theatre!

 

Sent from my 5080X using Tapatalk

Link to comment
Share on other sites

sleepy

Server updated and now I can confirm that it is all working as normal.

 

Thank you so much for the fix, much appreciated indeed.

 

Sent from my 5080X using Tapatalk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...