Jump to content


Photo

Unable to connect to server on Apple tv


  • Please log in to reply
28 replies to this topic

#1 Saleel77 OFFLINE  

Saleel77

    Newbie

  • Members
  • 8 posts

Posted 15 March 2018 - 05:44 AM

Hi there. I can connect to the server on my iPhone. But despite using Emby connect and entering the pin, the server does not show on Apple TV. Any help please? This start d only yesterday.
Many thanks
S

#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45381 posts
  • Local time: 03:39 AM

Posted 15 March 2018 - 09:04 AM

Hi. Can you please tell us exactly what you did and what is happening?

 

If the server is not in the list of servers after entering a Connect PIN that would suggest that maybe that server is not properly hooked up to the Connect account you used.



#3 Saleel77 OFFLINE  

Saleel77

    Newbie

  • Members
  • 8 posts

Posted 15 March 2018 - 10:52 AM

Hi ebr. As of yesterday when connecting to Emby on Apple
Tv, I get a starting up symbol. Then it shows me the option for conn caring th server either with Emby connect or by entering server address. I selected Emby connect with pin. Entered my pin on iPhone. Pin was then confirmed. When clicking next on Apple TV, I get a blank screen with Emby logo on left, and options on the right upper corner including forget server, logout of connect. I have no server details or channels. I am however able to use the server on my iPhone.
Many thanks

#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45381 posts
  • Local time: 03:39 AM

Posted 15 March 2018 - 04:05 PM

Okay, that sounds like you haven't setup connect and, for some reason, your Apple TV is not able to automatically discover your server - either that or it cannot contact it at all.

 

What happens if you use the manual entry method and enter your server IP address?  If it says it cannot find it then there must be a connectivity issue between the Apple TV and the server.



#5 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 16 March 2018 - 04:34 PM

Also here, ip-address, dns name, nothing works (NetFlix works from my AppleTV, so it can be a network connection). Browser connection to emby works though.

 

I've tried "Login With Connect" and "Enter Server Address" ... nothing, nada... zilch...



#6 Senna OFFLINE  

Senna

    Advanced Member

  • Members
  • 959 posts
  • Local time: 09:39 AM

Posted 16 March 2018 - 06:18 PM

Seems like a problem we had before, with some previous server releases.

 

Could you please test to fill in the ip address of your Apple TV in advanced settings >> Lan networks on the Emby server ?

 

5aac41e0e0988_AdvancedSettingsLanNetwork

 

If this works and you can log in on your Apple TV, than you can clear out this field again and see if the problem still exist.


Edited by Senna, 16 March 2018 - 06:20 PM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131524 posts
  • Local time: 03:39 AM

Posted 16 March 2018 - 10:42 PM

What exactly happens when you enter the server address?



#8 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 06:47 AM

What exactly happens when you enter the server address?

 

 

It will go back asking for "Login With Connect" and "Enter Server Address" again.

 

 

Seems like a problem we had before, with some previous server releases.

 

Could you please test to fill in the ip address of your Apple TV in advanced settings >> Lan networks on the Emby server ?

 

5aac41e0e0988_AdvancedSettingsLanNetwork

 

If this works and you can log in on your Apple TV, than you can clear out this field again and see if the problem still exist.

 

And now I no longer can access my emby (at all), how do I remove that again?



#9 andyblac644 OFFLINE  

andyblac644

    Advanced Member

  • Members
  • 736 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 07:10 AM

did you enter the details correctly ?

 

5aacf7774f342_ScreenShot20180317at110901

 

you need to set a subnet range for the ip.



#10 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 07:16 AM

did you enter the details correctly ?

 

5aacf7774f342_ScreenShot20180317at110901

 

you need to set a subnet range for the ip.

 

 

 

That is a CIDR netmaks, when you write "netmask" then it's a aaa.bbb.ccc.ddd netmask.

 

Where do I remove this this from the database?



#11 andyblac644 OFFLINE  

andyblac644

    Advanced Member

  • Members
  • 736 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 07:19 AM

That is a CIDR netmaks, when you write "netmask" then it's a aaa.bbb.ccc.ddd netmask.

 

Where do I remove this this from the database?

you will need to manually edit in config file in config/system.xml

  <LocalNetworkSubnets>
    <string>192.168.2.0/24</string>
    <string>192.168.1.0/24</string>
  </LocalNetworkSubnets>
  <LocalNetworkAddresses>
    <string>192.168.2.1</string>
  </LocalNetworkAddresses>



#12 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 07:32 AM

 

you will need to manually edit in config file in config/system.xml

  <LocalNetworkSubnets>
    <string>192.168.2.0/24</string>
    <string>192.168.1.0/24</string>
  </LocalNetworkSubnets>
  <LocalNetworkAddresses>
    <string>192.168.2.1</string>
  </LocalNetworkAddresses>

 

 

Thanks, adding this I am able to login. 



#13 Senna OFFLINE  

Senna

    Advanced Member

  • Members
  • 959 posts
  • Local time: 09:39 AM

Posted 17 March 2018 - 11:10 AM

And now I no longer can access my emby (at all), how do I remove that again?

You can always access Emby server on the server itself, without the need to edit config files...

 

Thanks, adding this I am able to login. 

On the Apple TV or your Emby server ?



#14 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 12:26 PM

You can always access Emby server on the server itself, without the need to edit config files...

 

On the Apple TV or your Emby server ?

 

 

Well yes, connect to, see anything no - it was an very empty emby I got.

 

 

My AppleTV login now works again.



#15 Senna OFFLINE  

Senna

    Advanced Member

  • Members
  • 959 posts
  • Local time: 09:39 AM

Posted 17 March 2018 - 01:40 PM

Which version number of Emby server are you using ?

Because the problem you had with the Apple TV login was already fixed, in the latest revisions of Emby server

#16 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 01:42 PM

Which version number of Emby server are you using ?

Because the problem you had with the Apple TV login was already fixed, in the latest revisions of Emby server

 

 

It says "Version 3.3.1.0", and looking at emby.media/download no newer version exist.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131524 posts
  • Local time: 03:39 AM

Posted 17 March 2018 - 02:04 PM

You're saying that when you enter the address manually that you don't get any error message?

#18 casperghst42 OFFLINE  

casperghst42

    Advanced Member

  • Members
  • 42 posts
  • Local time: 08:39 AM

Posted 17 March 2018 - 02:08 PM

You're saying that when you enter the address manually that you don't get any error message?

 

 

Prior to adding the localNetwork, I would either enter the ipaddress/dns name, and it would just return to the same place, the same would happen if I used the pin option. And there would be no error.

 

If I would see an error, I would let people know.

 

After adding localNetwork, I am able to connect using ipaddress/dns name.



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131524 posts
  • Local time: 03:39 AM

Posted 17 March 2018 - 02:11 PM

Do you have remote connections disabled on the server?

#20 Senna OFFLINE  

Senna

    Advanced Member

  • Members
  • 959 posts
  • Local time: 09:39 AM

Posted 17 March 2018 - 02:54 PM

@Luke, with server 3.2.70.7 we had identical problem, with Apple TV login and by inputting ip's in settings LAN Network, the Apple TV got access again.

 

casperghst42 should clear that Lan Network settings again, to test if it is indeed the same problem with 3.3.1.0 as what happened with 3.2.70.7.

https://emby.media/c...onnect-locally/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users