Jump to content

Trakt Plugin: Unauthorized


Recommended Posts


Hello everyone,

     I've seen some rumblings on the forums regarding errors when syncing with Trakt.  Some are saying it is resolved and some aren't.


My situation is that the Sync library to trakt.tv is failing with an Unauthorized return.
Import playstates from Trakt.tv appears to be working as expected.


Here is what I have done:

  • Uninstalled / Reinstalled Plugin
  • Uninstalled Plugin, then removed Trakt.xml
  • Uninstalled Plugin, removed Trakt.xml, revoked token with Trakt, reinstalled plugin, re-authorized with Trakt.
  • Created entirely new instance of Emby on secondary hardware (different OS, even).

...all to no avail.  I've attached what I think is the appropriate log.  I did mask user names and IP addresses.


Any assistance is greatly appreciated!

Link to comment
Share on other sites

I would try it again tomorrow just in case there was some kind of network blip on the trakt side. If not then we'll go from there. Thanks.

Link to comment
Share on other sites


@@Luke - Thank you for the response!  Unfortunately, this has been going on for a little while, and is constant so I don't think we can blame a network blip.  I wish it were that easy.
I've attached the latest log from my server, just a minute or so after I attempted a Sync (the latest entry is very recent), but you can see it happening over and over throughout the day.

​I've also attached the log from a second server (trakt-alternate) (different OS, different ISP, different users) to see if the commonalities will help isolate the issue.

​Please let me know if I can provide any further information.

Thank you again for your assistance!



Edited by mpearon
Link to comment
Share on other sites

  • 1 month later...

I just wanted to chime in and say that I've been having the exact same problem for a few weeks now. I have tried refreshing the trakt token numerous times, but no dice! I have attached my log file with debug mode enabled. And here is the extracted error message.


2018-04-25 21:52:12.127 Error TaskManager: Error
    *** Error Report ***
    Command line: C:\Users\STiFU\AppData\Roaming\Emby-Server\system\EmbyServer.dll C:\Users\STiFU\AppData\Roaming\Emby-Server\system\EmbyServer.dll -noautorunwebapp
    Operating system: Microsoft Windows NT 6.2.9200.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: True
    Processor count: 12
    Program data path: C:\Users\STiFU\AppData\Roaming\Emby-Server
    Application directory: C:\Users\STiFU\AppData\Roaming\Emby-Server\system
    MediaBrowser.Model.Net.HttpException: Unauthorized
     at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsyncInternal>d__20.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
     at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
     at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsync>d__17.MoveNext()

Link to comment
Share on other sites

Hi, occasionally the trakt token may expire and you need to clear out your authentication and add it again. We're looking into improving this so that you won't need to do this, but for now it's necessary. Thanks.

Link to comment
Share on other sites

Hey Luke, thanks for your reply. As I said, I have tried reauthenticating with trakt numerous times. However, I now realized that I also had another account setup with a trakt token by accident. Removing that token fixed my issue.


As a suggestion to avoid this problem, it would be good if the log said for which user the trakt-sync failed. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...