Jump to content
lai

LG Smart TV Emby client does not play FLAC

Recommended Posts

lai

FLAC not playing on LG SMART TV  OLED65E7P

FLAC files that play when on the TV USB stick do not play when using EMBY LG Smart TV client.

Tries, gives up, tries next track on album, gives up again, until end of album.

Server Log attached

Emby Server 3.3.0 (nor on 3.2.70)

Thanks

 

server-63655440376.txt

Share this post


Link to post
Share on other sites
Luke

@@SamES are you able to reproduce this? Thanks.

Share this post


Link to post
Share on other sites
Brudertac

Happens here too... It is an 65B7D

Share this post


Link to post
Share on other sites
Luke

Emby for LG 1.06 has just been released. Please try it out. Thanks !

Share this post


Link to post
Share on other sites
lai

Luke,

Thanks.  I tested. On TV it seems better - no error loop thru all albuns (Error screen stops on OK/Done button ---Playback Error: No compatiple Streams found). On Server - no direct play stream found for flac. Enclosed server log.

 

server-63657323436.txt

Share this post


Link to post
Share on other sites
Luke

Hi @@lai, on server, what do you mean? Are you referring to using the web app? Thanks.

Share this post


Link to post
Share on other sites
lai

Hi Luke,

 

Just peeked at the server log I enclosed and saw the Direct Play messages ...

on Dashboard - Recent Activity just messages like those below (timestamps below differ from those on log):

 

dvr
boss has stopped playing Miguel Proença - Gnatalli: Alma Brasileira
3/22/2018, 3:05:26 pm
App: Emby Theater, Device: LG Smart TV
dvr
boss has started playing Miguel Proença - Gnatalli: Alma Brasileira
3/22/2018, 3:05:26 pm
App: Emby Theater, Device: LG Smart TV

Share this post


Link to post
Share on other sites
Luke

I don't quite understand. Is there a problem, or no?

Share this post


Link to post
Share on other sites
lai

Yes...  flac files still do no play on the LG webos app.

 

After the LG app update now the symptom on TV is different -- after selecting a flac file to play, TV tries to load, does not play and display a modal error message  on tv screen  PLAYBACK ERROR: NO Compatible streams found and a DONE button which if pressed repeats the this cycle tries to play, display the error message stops-- 

 

(before the app update, the app on TV would loop thru all flac files without playing, and sometimes the app would crash after a certain number of files).

Share this post


Link to post
Share on other sites
Luke

Ok, we'll retest this, thanks.

Share this post


Link to post
Share on other sites
Kramadana

I can con confirm latest wont play flac files back.

Share this post


Link to post
Share on other sites
Luke

It's resolved for the next release of the app, thanks.

Share this post


Link to post
Share on other sites
Kramadana

Hi,

 

When is the next release due?

 

Ta

Share this post


Link to post
Share on other sites
Luke

As soon as LG approves it.

Share this post


Link to post
Share on other sites
andyblac644

As soon as LG approves it.

 

 around June / July then :P

Share this post


Link to post
Share on other sites
lai

New version of Emby LG App is out (V 1.0.7 09/04/2018).  Tested and it is playing flac files now.. No problems noticed.

Thanks to the great dev/support team at Emby

Edited by lai

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites
medric

okay i still can not play a mkv with flac audio with not subtitle ( i thought it was subtitle base) i have the latest version of emby app 1.0.15  emby server 4.0.3.0 synology 6.2

lg webos tv UH8500 software version 5.30.30

 

i have a lot of videos with mkv and flac that have all stream and kills the server.

 

if there is anything i can do to add to profile would be greatly appreciated or is an webos fault

Share this post


Link to post
Share on other sites
Luke

okay i still can not play a mkv with flac audio with not subtitle ( i thought it was subtitle base) i have the latest version of emby app 1.0.15  emby server 4.0.3.0 synology 6.2

lg webos tv UH8500 software version 5.30.30

 

i have a lot of videos with mkv and flac that have all stream and kills the server.

 

if there is anything i can do to add to profile would be greatly appreciated or is an webos fault

Is it trying to direct play it?

Share this post


Link to post
Share on other sites
medric

the logs are so big let me try and pull it and upload it.

Share this post


Link to post
Share on other sites
CarlosLima

I have a large collection of FLAC songs and to not transcode, just change the extension of the files to MP4.
The file does not lose size and does not lose quality and reproduces in Emby, LG TV, without transcoding and with excellent audio quality.

Share this post


Link to post
Share on other sites
Luke

Here is my log when i play Flac files it always transcode 

 

@@medric, we did what we had to do, because previously they were failing with the LG audio player when direct playing. 

 

@@SamES can provide more information. Thanks.

Share this post


Link to post
Share on other sites
SamES

Here is my log when i play Flac files it always transcode 

 

 

It's transcoding as it's failing during playback so we fallback to transcoding rather than giving a 'No playable streams' error.

 

The problem is that the maximum supported profile level for H.264 @ 1920x1080@60P is 4.2.  Your video is Level 5.0 (50).  I don't think 10-bit 1080 content is supported.

 

{"Codec":"h264","Language":"eng","ColorSpace":"bt709","TimeBase":"1/1000","CodecTimeBase":"1001/48000","VideoRange":"SDR","DisplayTitle":"1080p H264","NalLengthSize":"4","IsInterlaced":false,"IsAVC":true,"BitRate":7357647,"BitDepth":10,"RefFrames":1,"IsDefault":true,"IsForced":false,"Height":1080,"Width":1920,"AverageFrameRate":23.9760246,"RealFrameRate":23.9760246,"Profile":"High 10","Type":"Video","AspectRatio":"16:9","Index":0,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"PixelFormat":"yuv420p10le","Level":50,"IsAnamorphic":false}

 

http://webostv.developer.lge.com/discover/specifications/supported-media-formats/webos-40/

 

It is not the audio that is the problem, it is the video.  

 

To confirm this I disabled FLAC support which should cause it to only convert the audio (DirectStream) instead of a full transcode.  It does attempt this, but still throws an error on the video stream which causes it to transcode.

 

Sorry, there is nothing we can do to prevent this as it is outside the LG spec for this type of video.  But I can confirm that in your case, the video is the problem, not the audio.

 

@@Luke, ideally we need to be able to limit the profile/level based on resolution and codec as the LG spec is 4.2 for 1080/h.264 and 4.1 for 1080/hevc but 5.1 for 2160 content.  On Samsung this also transcodes with transcode reason 'Video profile not supported'.  Not sure why this is being detected differently.

 

This is my test sample which is similar to yours

 

 

 

http://192.168.1.222:8096/emby/videos/288204/hls1/main/0.ts?DeviceId=2da01462cc276ae31f8b967de7e274e60eb5767a&MediaSourceId=1a05065b1324e21de775a5bea6af5d8a&PlaySessionId=d75dfb2c63d445e5ab96e3e536121832&api_key=b26c77e8df77485eaa7b2eaa15fa2b8f&VideoCodec=h264,h265,hevc&AudioCodec=ac3,eac3,aac,mp3&VideoBitrate=139808000&AudioBitrate=192000&AudioStreamIndex=1&SubtitleMethod=Encode&TranscodingMaxAudioChannels=6&SegmentContainer=ts&MinSegments=1&BreakOnNonKeyFrames=False&h264-profile=high,main,baseline,constrainedbaseline,high10&h264-level=51&TranscodeReasons=ContainerBitrateExceedsLimit&allowVideoStreamCopy=false

 

{"Protocol":"File","Id":"1a05065b1324e21de775a5bea6af5d8a","Path":"\\\\10.55.1.2\\Media\\Demos\\Test Files\\flac_mkv\\[MK-Pn8] Sword Art Online II - 07v2 [bD 1080p][Hi10][Dual][E3858ED0].mkv","Type":"Default","Container":"mkv","Size":0,"Name":"[MK-Pn8] Sword Art Online II - 07v2 [bD 1080p][Hi10][Dual][E3858ED0]","IsRemote":false,"RunTimeTicks":14232970240,"SupportsTranscoding":true,"SupportsDirectStream":true,"SupportsDirectPlay":true,"IsInfiniteStream":false,"RequiresOpening":false,"RequiresClosing":false,"RequiresLooping":false,"SupportsProbing":false,"MediaStreams":[{"Codec":"h264","ColorTransfer":"bt709","ColorPrimaries":"bt709","ColorSpace":"bt709","TimeBase":"1/1000","CodecTimeBase":"1001/48000","Title":"[sS] h264 Hi10 1080p","VideoRange":"SDR","DisplayTitle":"1080p H264","NalLengthSize":"4","IsInterlaced":false,"IsAVC":true,"BitRate":6621111,"BitDepth":10,"RefFrames":1,"IsDefault":true,"IsForced":false,"Height":1080,"Width":1920,"AverageFrameRate":23.9760246,"RealFrameRate":23.9760246,"Profile":"High 10","Type":"Video","AspectRatio":"16:9","Index":0,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"PixelFormat":"yuv420p10le","Level":51,"IsAnamorphic":false},{"Codec":"flac","Language":"eng","TimeBase":"1/1000","CodecTimeBase":"1/48000","Title":"[MK] FLAC 2.0ch","DisplayTitle":"English FLAC stereo (Default)","DisplayLanguage":"English","IsInterlaced":false,"ChannelLayout":"stereo","BitDepth":24,"Channels":2,"SampleRate":48000,"IsDefault":true,"IsForced":false,"Type":"Audio","Index":1,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Level":0},{"Codec":"flac","Language":"jpn","TimeBase":"1/1000","CodecTimeBase":"1/48000","Title":"[sS] FLAC 2.0ch","DisplayTitle":"Japanese FLAC stereo","DisplayLanguage":"Japanese","IsInterlaced":false,"ChannelLayout":"stereo","BitDepth":16,"Channels":2,"SampleRate":48000,"IsDefault":false,"IsForced":false,"Type":"Audio","Index":2,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Level":0},{"Codec":"ass","Language":"eng","TimeBase":"1/1000","CodecTimeBase":"0/1","Title":"[MK] Signs","DisplayTitle":"English (Default ASS)","DisplayLanguage":"English","IsInterlaced":false,"IsDefault":true,"IsForced":false,"Type":"Subtitle","Index":3,"IsExternal":false,"IsTextSubtitleStream":true,"SupportsExternalStream":true,"Level":0},{"Codec":"ass","Language":"jpn","TimeBase":"1/1000","CodecTimeBase":"0/1","Title":"[MK] Full Subtitles","DisplayTitle":"Japanese (ASS)","DisplayLanguage":"Japanese","IsInterlaced":false,"IsDefault":false,"IsForced":false,"Type":"Subtitle","Index":4,"IsExternal":false,"IsTextSubtitleStream":true,"SupportsExternalStream":true,"Level":0},{"Codec":"mjpeg","ColorSpace":"bt470bg","TimeBase":"1/90000","CodecTimeBase":"0/1","IsInterlaced":false,"BitDepth":8,"RefFrames":1,"IsDefault":false,"IsForced":false,"Height":900,"Width":900,"RealFrameRate":90000,"Profile":"192","Type":"EmbeddedImage","AspectRatio":"1:1","Index":6,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"PixelFormat":"yuvj444p","Level":-99,"IsAnamorphic":false}],"Formats":[],"Bitrate":6621111,"RequiredHttpHeaders":{},"ReadAtNativeFramerate":false}

Share this post


Link to post
Share on other sites
SamES

@@Luke, web0s also detects as browser.chrome so '|high 10' is being added when it shouldn't be.  This doesn't stop transcoding, but it explains why it attempts to DirectPlay. 

Edited by SamES

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...