Jump to content
KidNamedCudi

Parental Controls not working for Next Up and Latest

Recommended Posts

KidNamedCudi

I set up a new account for my nephew and I am trying to get the parental controls right. I have excluded some shows via the tags method which removed them if I go under all shows however they are still showing under the the Next Up and Latest and allow me to click in and watch them regardless of the parental controls.
 
To me it looks like the rating parental control is working for Next Up and Latest but it is not also taking into account tags for this section.

Edited by KidNamedCudi

Share this post


Link to post
Share on other sites
ebr

Hi.  Try running a library scan.

Share this post


Link to post
Share on other sites
Happy2Play

This is reproducible, but partially works.  Applied PG/TV-PG, worked in All Series, but next up and latest had TV-14 mixed episodes that allow whole series navigation with a couple clicks.
 
But checking TV Shows in "Block items with no or unrecognized rating information:" removed the ones that slipped through.

 

Library scan has no effect at least in my test.

Share this post


Link to post
Share on other sites
Happy2Play

My issue could be my xml metadata, but the issue is mis-matched or lack of rating at episode level allows media to be displayed unless you enable "Block items with no or unrecognized rating information:" on required libraries.

 

 

Example I had one episode of The Big Bang Theory that had a rating of Not Rated so it was visible when I had a limitation of PG/TV-PG, the Series was removed as it was TV-14.  But Lasted allowed the Not Rated through the restriction.

 

 

 

 

The "Block items with no or unrecognized rating information:" options is the easiest fix, or you have to ensure episode ratings are correct.

Edited by Happy2Play

Share this post


Link to post
Share on other sites
Luke

@@KidNamedCudi, please let us know if the library scan has resolved your issue. thanks !

Share this post


Link to post
Share on other sites
flogl

Hi,

 

i have the same problem. I usually manage my media library with tinymediamanager. It writes Kodi compatible .nfo files with adjustable <mpaa> and <certification> values. It can set it to: "Germany: FSK 18" or "FSK 18" or "DE: FSK 18" or  ... but emby wants FSK-18 or DE-18, otherwise it can not recognize it i think. Can you help emby to understand strings from tinymediamanager?

Share this post


Link to post
Share on other sites
Happy2Play

Hi,

 

i have the same problem. I usually manage my media library with tinymediamanager. It writes Kodi compatible .nfo files with adjustable <mpaa> and <certification> values. It can set it to: "Germany: FSK 18" or "FSK 18" or "DE: FSK 18" or  ... but emby wants FSK-18 or DE-18, otherwise it can not recognize it i think. Can you help emby to understand strings from tinymediamanager?

 

Not sure how the server maintains these files by you can add your format to your localization file and test.

 

​C:\Users\username\AppData\Roaming\Emby-Server\localization

Share this post


Link to post
Share on other sites
Luke

Those are pretty simple. We can probably add some handling to parse those.

Share this post


Link to post
Share on other sites
flogl

Unfortunately in LocalzationManager.cs around line 100 after loading localization files, the list for german localization (de) is replaced by a build in one. As for some other countries too. I think, the best would be to make localization files from the in-code ones.

Share this post


Link to post
Share on other sites
Luke

We plan to expose them in the web UI in a future update.

 

For now I will handle splitting by colon : and the spaces.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...