Jump to content


Photo

Smart remote no longer works, et al. et al.


  • Please log in to reply
16 replies to this topic

#1 mmmann OFFLINE  

mmmann

    Advanced Member

  • Members
  • 37 posts
  • Local time: 01:37 PM
  • LocationMichigan, USA

Posted 12 February 2018 - 03:44 PM

I'd like to report that my smart remote no longer works (has not worked for a few months, actually) with the Samsung Emby application. I cannot click on letters in the search window, I cannot click on a movie's timeline in order to skip forward. When I cover the pointer button on my smart remote and cause the motion-activated cursor to appear in Emby, the cursor is always the circle-with-slash "cannot do that" cursor. I've been forced back to arrow keys for a long time.

 

Also, chapter skipping no longer works. Last night I watched 80% of a movie and now there's no way to finish it, because I can't hover and click on the timeline, and neither does chapter forward work.

 

Emby server: Version 3.2.36.0

Samsung Emby: the latest, as of 2/12/2018, verified with the TV's "update apps" functionality

 

Sorry, I don't know how to get to the Emby App's settings anymore to give you the version. No button on either remote (smart and normal) brings up the version and there's nothing that I can find under settings, just General/Display and Playback/General&Subtitles. If there's a way to get at additional settings, including a printout of the version #, it's not obvious to me.

 

Also, it looks like enabling subtitles causes movies to transcode, even if they're built into the MKV. I wanted to put on English subs, yesterday, and the 4K movie was unwatchable due to stuttering; the Emby server page no longer read, "Direct Playing." While I'm at it (I only bother to post once in a blue moon), if you go to Folders and select a folder, Emby lists a "Collection" instead of the movie. For instance, when I go to my "4K" folder where I keep a few high-res movies, it'll list the "Mad Max Collection" instead of the single movie in that directory structure, "Fury Road." Very bothersome, because you're then dropped into a sub-select screen where you have to cursor through ALL the movies in the collection to find the 4K version. And how do you know if it's the 4K one (assuming that you have, say, 3-4 copies of the movie)? You'd have to enter into each movie and see if it's 2160p, OR you can edit the *.nfo file and change the title to '<movie> 4K'.

 

I'll be honest: I don't find the Samsung Emby app very usable, at all. Since I'm in my once-a-year post, I'll list a couple other things that are bothersome. What's with the huge square on the home screen? It takes up more than 1/4 of the screen, displaying some random movie's random backdrop (that I don't recognize), and often it prints the movie by-line (that I don't recognize) instead of the movie name, so I can't even tell what movie it is. This has no value to me and it's a waste of screen real estate, for my usage. What is Emby trying to do, give me a pleasant surprise? How about using that space for a list of most recent movies, sorted by directory modification date or main file mod date? THAT would be useful, because 80% of my usage is #1 download movie(s) to the hard drive, then #2 plop down in front of TV to watch new movie.

 

Also, the groupings of movies ("because you watched," "because you liked," etc.) includes trailers masquerading as movies: there are green-outlined posters that are not actually movies on my hard drives, but that look like they are. I can't tell; how can I remember if I kept Starship Troopers among my 3000 movies? If you click on Starship Troopers (an actual example, right now), up comes the description and a [PLAY] button with NO indication that it's a trailer. It looks like I must have it in my collection, but no, it's a trailer. This, to me, is a serious WTF issue. What if I don't want trailers at all? Or they could be under a "trailers" group. And how does Emby determine what trailers I'd want to watch? But the real insanity is dolling up trailers to look like movies you own and mixing them into the groups.

 

There are a lot of issues I could list. The Emby app is awesome...because it has the entire market cornered for Samsung apps that stream from Emby. But it sure has a lot of bugs and inconsistencies and usability issues. We need Steve Jobs to work on it and make it "insanely great."

 

Cheers.

 

Oh yeah, I own a 85JU645D which is a JU7100, basically.


Edited by mmmann, 12 February 2018 - 03:46 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 03:48 PM

Hi, we've disabled mouse pointer support for the app if that's what you're referring to. Just use the regular arrow directionals on your remote control and that should work fine.

 

Please let us know if this helps. Thanks.



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 03:54 PM

 

Also, chapter skipping no longer works. Last night I watched 80% of a movie and now there's no way to finish it, because I can't hover and click on the timeline, and neither does chapter forward work.

 

The buttons you're referring to are for next/previous track in your now playing queue.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 03:55 PM

 

 

Also, it looks like enabling subtitles causes movies to transcode, even if they're built into the MKV. I wanted to put on English subs, yesterday, and the 4K movie was unwatchable due to stuttering; the Emby server page no longer read, "Direct Playing." 

We'd have to look at an example. Please see how to report a media playback issue. Thanks.



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 03:55 PM

 

 

if you go to Folders and select a folder, Emby lists a "Collection" instead of the movie. For instance, when I go to my "4K" folder where I keep a few high-res movies, it'll list the "Mad Max Collection" instead of the single movie in that directory structure, "Fury Road." Very bothersome

 

Because you asked for this by enabling "Group movies into Collections" in server display settings. Which is off by default. The system is doing exactly what you asked it to do.



#6 mmmann OFFLINE  

mmmann

    Advanced Member

  • Members
  • 37 posts
  • Local time: 01:37 PM
  • LocationMichigan, USA

Posted 12 February 2018 - 04:12 PM

> we've disabled mouse pointer support

 

Luke, that explains the "bug" but it does not help. We disabled point and click? Why the bleep would we do that? Why take away usability from a program that's already struggling to be usable?

 

How, then, do you point at a place on the movie's timeline and jump forward or backward? No wonder I can't watch the remainder of last night's movie. There's no way to navigate out to the end and watch the last 10 or 15 minutes, or move forward or back to rewatch a great scene. Chapter forward doesn't work, either. And a great many of my movies don't have chapter markers, anyway. And even if chaptering worked, you'd have to painfully and step-by-step grind out to the nearest chapter and then, excruciatingly, move forward or backward 30 seconds at a time trying to find the place you want. I can't think of any use for the timeline now. Since you cannot use it for input, it's nothing but eye candy and could be replaced with a %<number> that shows how far into the media you are.

 

I'm really flabbergasted at the design and UI decisions being made on this program. I'm really confused. No point and click. Random movies taking up the home screen. Random trailers injected into the UI. Am I the only one struggling with this program? I can't be.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 04:24 PM

The samsung review process gave us several rejections over mouse support that finally we just had to remove the feature altogether in order to be able to release app updates. There wasn't anything wrong with our mouse support before, the problem is the app reviewers won't spend more than a minute getting to know your software, and they're very quick to reject if they don't understand something or don't agree with how it works.

 

Right now we have a current release in progress, and while that goes on I'm not able to review our defect history, but once this review process completes and I can access the defect history, then I can provide specific examples of the kinds of things they were rejecting the app over. It was causing delays with our ability to release new updates that finally we just had to say enough's enough and remove it so that we could pass.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 12 February 2018 - 04:27 PM

 

 

Random trailers injected into the UI. 

Again, there is also a setting for this in the server, therefore we can conclude that the software is doing what you've told it to do.



#9 mmmann OFFLINE  

mmmann

    Advanced Member

  • Members
  • 37 posts
  • Local time: 01:37 PM
  • LocationMichigan, USA

Posted 12 February 2018 - 04:48 PM

> Because you asked for this by enabling "Group movies into Collections"

 

If you select FOLDERS, It's because you want to enter a folder and search for FILES. The way it is, now, we're displaying media that does NOT live inside the folder the user selected. A quick poll to the users: who thinks it makes sense to go directly to a specific folder and then be presented with media scattered all over your hard drives? Ok, then. Sanity wins out. It's a bug.

 

I'd guess that this is a side effect of some common code being called. The code needs another parameter, like AllowCollections=true that receives the default, global group-by-collections parameter but a FALSE when attempting to explore by folder.

 

It's a bug. Own it. Fix it. And please, I beg of each and every user, please do not take the easy way out by conflating an expert explanation of software behavior to be proof of an intended feature.



#10 mmmann OFFLINE  

mmmann

    Advanced Member

  • Members
  • 37 posts
  • Local time: 01:37 PM
  • LocationMichigan, USA

Posted 12 February 2018 - 05:30 PM

> ...we can conclude that the [random, indistiguishable trailers injected into the UI [SIC]] is doing what you've told it to do.

 

User poll: if somewhere on the server we say, "Okay, I like trailers," does that mean that trailers should be intermixed with media with absolutely no differentiation, masquerading as movies and leaving the user no recourse to discover which are which, sitting in the UI like landmines and cowpies? No. How about putting trailers under a group called, "Trailers?" Or how about instead of a green circumference, a trailer is a bright orange? Or how about a mouse-over that reads, 'Trailer'? How about ignoring trailers if the UI is not ready to handle them elegantly? Something...anything.

 

Friends and readers, do not make excuses by explaining behavior. Do not be DEFENSIVE when dealing with problems, be DELIGHTED that things have been exposed. Be a hero: take ownership of it, fix it, rinse and repeat.

 

p.s. My brother-in-law is an addict, that's why he beats on his family. It has to do with a configuration error when he was born. Therefore, it's expected and acceptable behavior.  :-|



#11 Chizzer666 OFFLINE  

Chizzer666

    Newbie

  • Members
  • 2 posts

Posted 18 October 2019 - 08:44 AM

Is there any ypdate as to why the smart remote mouse function still doesnt work please..... its really frustrating

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 18 October 2019 - 02:22 PM

Is there any ypdate as to why the smart remote mouse function still doesnt work please..... its really frustrating

 

Hi there @Chizzer666 can you please describe the issue that you're having? thanks.



#13 FrostByte ONLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 4378 posts
  • Local time: 12:37 PM
  • LocationThe UP

Posted 18 October 2019 - 03:05 PM

Is there any ypdate as to why the smart remote mouse function still doesnt work please..... its really frustrating

 

 

I think it's explained in posts 2 and 7 above on why this functionality no longer works.


  • Czarus likes this

#14 Czarus OFFLINE  

Czarus

    Newbie

  • Members
  • 1 posts
  • Local time: 06:37 PM

Posted 18 November 2019 - 07:40 AM

Outside of US, for example in Europe, we need to install Emby manually using usb stick like in 90's. Why not turn on mouse pointer function for non US users since obviously we are already installing app thats not officially supported by Samsung TV's anyway.

 

On Plex which looks very simmilar, mouse pointer works and i can install Plex normally without stick so i would argue about reason we are gettin lesser product (Samsung reviewers doesnt know how to operate mouse on Emby but know how to do it on Plex, really?).

 

Considering Plex and Emby got exact same price, Emby devs should at least offer simmilar tv support.


Edited by Czarus, 18 November 2019 - 07:54 AM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 18 November 2019 - 11:31 AM

Thanks for the feedback.

#16 stevensp OFFLINE  

stevensp

    Newbie

  • Members
  • 3 posts
  • Local time: 01:37 AM

Posted 01 December 2019 - 12:44 PM

 

Also, chapter skipping no longer works. Last night I watched 80% of a movie and now there's no way to finish it, because I can't hover and click on the timeline, and neither does chapter forward work.

 

 Yes, I'm actually looking for an answer to this.

 

Instead of forwarding 30 secs each time, is there a function like "go to xx minutes" etc.

Or am I missing out something?



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142515 posts
  • Local time: 12:37 PM

Posted 01 December 2019 - 01:00 PM

We are working on improving this. Thanks for the feedback.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users