Jump to content

metadata not showing with wdtv live xml


braddles69
 Share

Go to solution Solved by braddles69,

Recommended Posts

Hi, I have just got a WDTV lIve SMP, and have been creating backdrops and covers and xmls for all my movies but have found that for the ones I have done, MB3 is now not showing the movie.xml metadata that I had previously.

 

see as follows my folder info now...532611f3742df_2gunsmetadata.png

 

as you can see it has new info and xml tagged as same as the movie file plus cover, fanart,sheet and another cover jpg tagged same as movie file.

 

What shows in MB server (latest beta build) using MB Classic is the cover (folder) discart, backdrop and media info but nothing else, no synopsis or genre etc from the xml, nor studio icons.

 

Is there someway I can have both xmls inside my folders, and have the  metadata showing?

 

I hope it's just a setting somewhere I can manage as I have gotten 3/4 of the way through my movie collection and would hate to have to go back and delete all the wdtv info...(would make using the wd live a bit cumbersome as well;)

 

Thanks for any advice and help!

Edited by braddles69
Link to comment
Share on other sites

For the xml file, we support a xml file with the exact same name as the movie, and we also support movie.xml. The file with the same name takes priority. Keep in mind, we support reading media browser format xml files. We don't officially support reading xml files that were designed for wdtv.

 

What makes you think it's using movie.xml instead?

 

For the image files, some of those are just not using names we support and that's why we're not seeing them.

Link to comment
Share on other sites

Thanks for the reply Luke, sorry I wasn't clear in my first post, before adding the wdtv live info (xmls and fanart etc) MB3 was showing all my metadata fine, now it only shows, the cover, discart and backdrop ...there is no text at all being imported from any xmls see below

 

53262254aac4b_2gunsjpg.png

 

 

As you can see art is ok but no studio icons or text.

 

Is there something else I need to do, I have manually refreshed the folder but nothing changes?

Any ideas?

 

Thanks in advance

Link to comment
Share on other sites

What's happening is it is reading the xml file but not finding very much because it's in wdtv live format

  • Like 1
Link to comment
Share on other sites

Okay Luke just to update you,

 

I have found that movies that have wdtv live compatible xmls, MB3 reads those and then fails to display the info,

 

however, for TV Shows, I can use MCM to scrape both series.xml, and episode xml (within the metadata folder in the season) and also WDTV Live xml (in the same folder as the filename.mkv) and both devices will display the xml data...

 

JoeySmith @ WDTV forum has been helping me narrow it down and I still can't get movies to show across both platforms but the TV shows approach seems possible?....

 

 

see the forum thread here   ...http://community.wd.com/t5/WD-TV-Live-Streaming/WD-Live-SMP-double-metadata-with-Mojo/m-p/700816#M29413

 

thanks again for your help

Link to comment
Share on other sites

  • Solution

I have found a way around this editing a few spare tags in the xml (Synopsis, Director,Genre, Runtime, OriginalTitle) to all lowercase allows the "filename".xml to be read by both MB3 and WDTV, I get all my studio icons and clearart etc on the HTPC, and I at least get the above info with a cover on the WDTV.  

 

From the above posted forum thread

 

(Thanks Joey, You've been a great help in narrowing this down, I tried to batch file change "Synopsis" to overview...but the textrep fails about 80% of the time (going to the NAS it gets an access error violation)

 But no matter, I have found I can manually change Runtime to runtime, Director to lowercase, Genre as well and synopsis and then rename movie.xml to "filename".xml and I get it showing across both platforms

 

It will be time consuming (for about 500 movies), but once it's done...every new movie I will edit before I transfer to the NAS.

 

Thanks for this it's been a huge help in getting my WDTV Live looking similair to my HTPC.)

 

Hope this helps anyone who may share a similair problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...