Jump to content

Cinema Mode not working on Roku TV


bundito
 Share

Recommended Posts

I bought an Emby Premiere subscription expressly for the Cinema Mode & Trailers feature on my Roku TV (a TCL).

 

The app plays my media just fine, but I don’t get any trailers or “related video” when queuing up a movie.

 

Any suggestions?

Link to comment
Share on other sites

Hi, this needs to be enabled in Emby Roku app settings. Can you check and make sure that you've enabled it? It should be on by default though. Thanks.

Link to comment
Share on other sites

  • 11 months later...
Diginous

I have this issue, but the Roku App justs closes and you go back to the home screen.  Cinema Mode is enabled.  and is enabled on the server.  I can play trailers fine from the emby Roku app, but when Cinema mode is enabled and I try to access a movie from my server, the App starts to try and load, then closes.  if I disable Cinema mode, I can then play the movie from the server..  This looks like some sort of bug..  It's set up on the server to play two trailers, then a custom splash, then the movie should start.  who knows..  

Link to comment
Share on other sites

Diginous

Also of note, the cinema mode works fine from a windows machine, or the emby for windows app.  I know it's working there.  I originally suspected some sort of transcoding issue, but when I re-installed emby on the roku, and left cinema mode off, the movie played, so I know the server can successfully transcode to the Roku.  same movie was used to stream..  I then also wondered if the trailer streams were an issue, but trailers will play if you launch a trailer from the roku app alone.  is only in Cinema mode that this occurs..  I have read some sort of issue with the IPTV App causing issues with DRM.  I do not have the IPTV App on the emby server..  so I am not sure where to go from here..  don't see any log entries pertaining to what's happening.  not sure if the Roku app even gets to requesting content form the server before crashing, but I will look deeper into that idea..  see if I can see an entry..

Link to comment
Share on other sites

Are you using the Emby Beta app for Roku?

 

Pretty sure this is the same issue related to the IPTV crashing we previously solved. It happens because I incorrectly assumed we would always get metadata for the height of the item so we could properly display the OSD qualities. This would leave the height null and crash the app with some items. This is now since corrected in the Beta by prepopulating the height as 1080. So if no height is found it will default to 1080 bitrate qualities in the OSD.

 

Let us know if the Beta works for you properly. Thanks. :)

Edited by speechles
Link to comment
Share on other sites

Nosferatu

I have same issue.  

 

Cinema mode does not work on Roku.

 

Works on PC and other devices fine.  Roku it either

 

1) Will force close back to home screen when trying to launch any movie (with Cinema Mode ON)

2)  Will force close if trying to play any trailers from the trailers plug in

 

Basically need to disable cinema mode on the Roku.  

 

The fix, installing that beta version.  Whatever changes are on that beta version need to be pushed to the official app.  :)

 

Figured I report back after reading this thread.

Edited by Nosferatu
Link to comment
Share on other sites

Nosferatu

Thanks for reporting back !

 

Can you report back when the fix is pushed to the official app?  I hate seeing "beta" on the Roku screen but on the flip side my wife likes the load bars being purple instead of green.   :lol:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...