Jump to content

Remote Control lost after a few seconds


Recommended Posts




I have recently installed Emby Server on my Windows 10 machine.

Works fine except for remote playback on DLNA devices.

- When I play an album on my device (app or browser), all goes well as far as I know. 

- When I play an album in a remote browser that is also connected to my server, all goes well as far as I know.

- When I try to play an album on my Pioneer VSX-921 using DLNA, it starts fine with the first song but after a few seconds I loose my remote control and the playback device stops after the first song finishes.

See attached logfile (search for VSX-921)

- When I try to play an album on my Samsung Smart TV, it only plays the first song, doesn't know about the rest of the playlist and doesn't accept previous and next requests. Pauze and volume work fine but again, playback stops after the first song finishes as the tv doesn't know about the rest of the songs.

See attached logfile (search for UE40D5700)


I don't have these issues using other DLNA players (tried several from google play store over the past years) so I suppose it could work.

To me this is a very important feature and one of the reasons I paid for premiere so I hope you can help me out.


Kind regards,





Link to comment
Share on other sites

  • 9 months later...

Just upgraded to the latest Docker image, and the remote DLNA playing/control has also gone awry for me.




I used to be able to simply control the volume, skip to the next track on my remote DLNA audio device - which is a QED uplay stream.


Now when choosing to cast to the device, I get the tune, but have no control over volume etc.  And after one song it cuts out.  This is when playing from the album tab thing.


There is a new option to me when pressing the cast button on the selected cast device of remote control (may have always been there{, but that seldom works.  I have no remote control.  Or if I get the control up it isn't populated.


This was the greatest attraction of emby for me, as I can use a web browser from any device to control my media player.


Having just said that, I've managed to get up an album in list view, and the controller popup at the bottom emerged, but then I lost it.  Perhaps that's the issue.  I keep loosing the player dash thing from the bottom of the screen, so have no control over what is playing.


I tried Kodi as the remote DLNA cast device, that mostly works, though the remote dash at the bottom doesn't always appear.  My main issue is that I can't control my QED uplay stream.  Bugger!  The Android DLNA software that comes with the uPlay feels a bit limited.  Plus I don't currently own an Android device - so my music playing is up the Suwannee for now.

Edited by Tuner
Link to comment
Share on other sites

  • 7 months later...

Apologies for butting in on this post again, there might be something in the following that is helpful to someone.


I have been around the houses since the last time I tried emby server.  It is somewhat difficult trying to get a grasp of all the different home networing casting technologies.


I discovered that my QED uplay stream is a DLNA renderer.  And I'd somewhat assumed that there would be many clients that I could use to 'send' audio over to it.  As I was having some remote control issues through the web interface of Emby, I tried a few other server apps - similarish to Emby, the Subsonics.  But I couldn't get these to cast and ultimately gave up.


One interesting project I did find was pulseaudio-dlna for Linux, that basically lets you stream to your DLNA audio device your computer's sound output (delayed slightly).  I think this is transcoded (to mp3), but it's rather useful, as with pulse you can mix inputs to outputs etc.  I was kind of hoping to passthrough raw FLAC, and it's probably possible if I pick the software to pieces.


I also picked up a Chromecast audio speaker.  Pulseaudio-dlna can use chromecast devices for output also.  I kidded myself that the Google eco-system might be more mature and a little more plug and play.  But as others are probably aware just sending audio from say an Android tablet/phone to a Chromecast is a bit tricky.  Google's own Play Music software won't let you cast to a device without first beaming your audio files into the cloud.


Just when I thought I could be bothered to read through the technical docs for the Chromecast and even bodge something of my own together, they seem to have pulled the audio device.  Youtube Music appears to be the replacement for Google Play Music, but that doesn't have cast options.  I'm not sure what Google are playing at, perhaps they are abandoning casting for bluetooth?


We've now a Chromecast video, and controlling that seems to be a bit hit and miss (with standard apps and the browser), the remote control aspect is also difficult with it.  Winding on through a video, controling volume etc.  Connecting disconnecting.  Seems a shame really, as I quite like the idea of streaming nodes.  I'm having some success with the Emby web interface and the Chromecast video saying that, but remote control seems confined to the web player that initiated play.


I probably haven't got a complete grasp on how the tech works.  It's a difficult landscape for the end user; to say the least.


I've also gotten hold of a couple of Android phones.  One premiumish one running Oreo 8.0 and one cheapish one running Oreo Go 8.1.  I'd given up trying to control my DLNA renderer with Emby Server/Web interface, because of the remote control issues.


However, the QED uplay stream app is a little temperamental. I think Oreo has some energy saving settings, and when it sleeps it upsets the network settings and that screws with what you are playing.  It works if the machine is plugged into the mains.  I have tried to use minidlna as a DLNA media server, and that's okay.


Today I tried embyserver again with the latest Docker image.  I had to shift to host networking for the docker container and open the ports for DLNA, to get that up and running with the DLNA renderer and Emby's in-built server.


As a DLNA server it appears more fully fledged than Minidlna.  I assume it's pulling in artwork and the like.


However the web interface still seems to have odd remote control issues for the DLNA renderer, I can go to an album and pick a song, and listen to it.  But I can't seem to run them sequentially, and getting the remote control up seems to seldom work.  I was also strugging with my Chromecast device today on Chrome 72 on Debian.


When I first tried Emby the DLNA playing seemed fine, but I had some library issues.  Today my library scanned well, but I'm having some playback issues!


The QED uplay stream is abandonware.  I wish they'd open up sourcecode for these old hardwares.  I'm not that comfortable having it as a network node.


Walking across the room and thumbing through CDs has become the easiet way to play music.  And sneaker net and a USB stick for the TV.


I'm just after bulk dumping all my audio (and perhaps video) on a low powered network device.  That I can easily scan, select, play and control


Embyserver is so nearly there, it's rather frustrating.  The strange thing is that I've tried loads of software and hardware but most has warts.


In my brain I imagine my players should be able to just get a play queue, and then I should be able to remote control them: seek, skip, pause, volume control, mute, bookmark etc.  From multiple devices.


I'm sorry if this is just a wall of nonsense, if I can help clarify any issues do ask.

Edited by Tuner
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Came back to this after the summer, as I'm now back indoors thinking about listening to music and watching TV on colder wetter days (UK).


I totally forgot where I was and what I'd figured out previously!


Since; I have picked up a low powered network device that is running linux and docker.  I have also tried the emby android app.  All upto date.


Anyway small correction on previous comment about launching emby for dlna use, if I run the container with the --network host, option, I don't need to specify ports for forwarding.


If emby is launched via docker this way I have the option to play to the dlna renderer in both the web interface and with the app.


However the remote control issues still exist for when playing to my dlna device.  I just selected 'play all' on an album in the web interface, and the remote came up from the bottom, and it initially looked to work, I tried seek then skip, at which point the remote vanished, and playback ceased at the end of the song.


The Android app seems to be limited to one play at a time too for dlna, I can control volume, but I don't have much in the way of feedback or remote control.  Chromecast support seems better.

Edited by Tuner
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...