Jump to content

Alle Filme in Liste ohne Auflistung von Ordnern von A-Z anzeigen


Mediaservero
 Share

Recommended Posts

Mediaservero

Hallo liebe Forenmitglieder,

ich möchte in Emby nur eine Gesamt-A-Z-Liste aller meiner Filme ohne Auflistung der Ordnerstrukturen in dieser Liste erstellen.

Mein Problem dabe ist, daß meine Filmdateien über mehrere Festplatten verteilt sind und dort dann zudem in unterschiedlichen Ordnerstrukturen liegen.

Auf Metadaten aus dem Internet kann ich aber grundätzlich verzichten. In der Liste reicht daher lediglich der Original-Dateiname und evtl. ein Bild aus der Video-Datei. Die Struktur der Original-Verzeichnisse sollen grundsätzlich erhalten bleiben. Es soll möglichst auch nichts in die Original-Verzeichnisse geschrieben werden. Die Daten solllen dort daher lediglich zur Erstellung die Emby-Bibliothek insofern nur ausgelesen werden.

Der Aufruf des Films könnte dann über das Webinterface entweder unter der Rubrik "Filme/Alle" über die A-Z- Navigation rechts daneben oder alternativ über die Suche erfolgen.

 

Zur Veranschaulichung des Problems hier ein Beispiel:
 

Die Datenstruktur auf den Festplatten:

D:\Media\Filme\Video 2.mp4
E:\Daten\Videos\Video 1.mp4
F:\Meinedaten\Video 3.mp4
F:\Meinedaten\Video 4.mp4


Die Scan-EInstellungen in der Emby-Bibliothek bzw. Filmdatenbank:

Name: Filme

Medientyp: Filme

Datei-Verzeichnisse zum Scannen:

D:\Media\Filme
E:\Daten\Videos
F:\Meinedaten


Die derzeitige Anzeige im Webinterface unter "Filme/Alle" (Sortierung A-Z):

Filme (als Ordner mit Inhalt "Video 2")
Meinedaten (als Ordner mit Inhalt "Video 1" und "Video 4")
Videos (als Ordner mit Inhalt "Video 3")

Die Filme können so natürlich nur über das Öffnen des jeweilgen Ordners gestartet werden und die A-Z-Sortierung folgt den Ordnernamen.

 

Die gewünschte Anzeige im Webinterface ohne Ordneranzeige unter "Filme/Alle" (Sortierung A-Z):

Video 1
Video 2
Video 3
Video 4

 

 

 

Wie kann dies technisch erreicht werden?

Für Eure Hilfe schon mal vielen Dank im Voraus.

Link to comment
Share on other sites

Mediaservero

Erst mal Danke für die schnelle Rückmeldung.

 

Ich bin inzwischen möglicherweise der Sache schon selbst wenigstens etwas auf den Grund gegangen. Ich teste das aber nochmal ausgiebig in der nächsten Zeit.

 

Ich vermute inzwischen nämlich zweierlei:

 

 

1. Einstellungen zu den Metadaten

 

Die Bibliothekseinstellungen waren bei mir evtl. doch nicht ganz korrekt eingestellt. Wahrscheinlich muß in der Bibliothek die immer automatisch voreingstellte Einstellung "Lade Bildmaterial und Metadaten aus dem Internet" auch noch abgewählt werden (siehe Screenshot), damit nachher im Webinterface nur die reinen Videodateinamen ohne eine evtl. Zusammenfassung in Ordnern aufgelistet werden. Ansonsten werden die Videos scheinbar im Webinterface aufgrund der Metadaten und der Ordnerstruktur, die ja nach den Emby-Bibliotheks-Regeln auch immer die Metadaten beeinflusst, evtl. auch nur in den entsprechenden Ordnern aufgelistet.

 

 

5a4f82c2a4f36_Screenshot1a.jpg

 

2. Die original Ordner- bzw. Dateistruktur

 

Sofern sich in der Ordnerstruktur auf der Festplatte ein Ordner mit Unterordnern befindet tritt scheinbar der folgende Effekt auf

 

a) Nur ein Datei im Original-Ordner

 

Wenn der Original-Unterordner nur ein Video enthält wird hierfür in der Bibliothek scheinbar die Datei unter dem mit dem Namen des Orignal-Unterordners angzeigt und nicht unter dem orignalen Video-Dateinamen.

 

 

2. Mehrere Dateien im Original-Ordner

 

Befinden sich hingegen mehrere Videos in Original-Unterordner werden an Stelle des Original-Ordners dann die jeweiligen Videos einzeln mit Ihrem originalen Video-Dateinamen in der Liste angezeigt..

 

 

 

Zur Veranschaulichung des Problems hier Screenshots des Web-Interfaces zum o.g. Beispiel:

 

Dazu habe ich das in oben in meiner Frage dargestellte Beispiel mal genau so als Test-Fall angelegt. Im o.g. Beispiel sind ja nur das "Video 3" und "Video 4" zusammen ein und dem selben Original-Ordner auf der Festplatte (F:\Meindaten). Ansonsten enthält der Original-Ordner ja nur jeweils ein Datei, die dann nämlich hier anstatt als "Video 1" und "Video 2" nur mit dem Ordernamen "Filme" und "Videos" insofen also einem andern Namen als dem Original-Dateinamen angezeigt wird.

 

 

5a4f82fe93f1e_Screenshot2a.jpg

 

 

 

Hier ein Screenshot des Metadaten-Managers, der ja scheinbar das Anzeige- bzw. Zuordungs-Problem in der Bibliothek verursacht.

 

5a4f831358421_Screenshot3a.jpg

 

 

Genau diese insofern unterschiedliche Darstellung der Video-Dateien im Web-Interface ist ja nun mein Problem.

 

Wie kann dies umgangen werden, ohne in die Original-Verzeichnisstruktur einzugreifen oder die Daten im Metadatenmanager aufwendig manuell zu ändern, was bei größeren Video-Sammlungen ja recht umfangreich sein kann ? Kann der Metadatenmanager evl. sogar ganz abgeschaltet oder irgendwie anderweitig umgangen werden ?

Edited by Mediaservero
Link to comment
Share on other sites

Mediaservero

Möglicherweise ist das hier wenigsten ein Teil bzw. ein erster Zwischenstand der Lösung meines Problems ?!?:

 

 

Regeln zum Hinzufügen von Verzeichnissen in Bibliotheken (sofern nur eine Gesamtauflistung von Videodateien von A-Z in einer Liste ohne Unterverzeichnisse bzw. Unterrubriken gewünscht ist):

 

1. Die Verzeichnisse der Bibliothek sollten nur eine Ebene von Unterverzeichnissen enthalten. Die Unterverzeichnisse selbst sollten also insofern keine weiteren Unterverzeichnisse enthalten.

 

2. Evtl. Verzeichnisse mit nur einer Datei sollten immer separat der Bibliothek als Scan-Verzeichnis hinzugefügt werden, sofern sie Teil einer Unterverzeichnisstruktur sind.

 

Hier der Screenshot vom Web-Interface:

 

5a4f987532c14_Screenshot4.jpg

 

 

Vielleicht gibt es aber auch noch andere Lösungen, um dieses Ergbnis leichter zu erreichen. Das Hinzufügen vieler (Unter-)Verzeichnisse zur Bibliothek ist ja auch je nach Umfang doch relativ umständlich.

Link to comment
Share on other sites

Mediaservero

Meine o.g. Regel muß wohl sogar noch etwas strenger gefaßt bzw. nachträglich ergänzt werden:

 

 

...

 

3. Sofern eine Verzeichnisstruktur mit nur einer Unterverzeichnisebene vorliegt und in den jeweiligen Unterverzeichnissen einerseits nur eine Datei und anderseits mehrere Dateien enthalten sind (also eine gemischter Inhalt der Unterverzeichnisse), dann muß jedes Unterverzeichnis der Bibliothek separt hinzugefügt werden, egal ob dieses nur eine oder mehrere Video-Dateien enthält. Das zugehörige Oberverzeichnis darf dann in keinem Fall auch noch zustätzlich der Bibliothek als Scan-Verzeichnis hinzugefügt werden, da dies scheinbar die separte Angabe der Unterverzeichnise "übersteuert" und so das gewollte Ergebnis zunichte macht bzw. verfälscht.

 

 

Wie kann dies aber nun bei sehr vielen Unterverzeichnissen leichter erreicht werden?

Link to comment
Share on other sites

Mediaservero

Danke für die Hilfe, aber der andere Medientyp löst das Problem scheinbar leider auch nicht. Die Verzeichnisse müssen trotzdem weiterhin alle einzeln angeben werden um eine korrekte Gesamtliste zu erhalten.

 

Vielleicht wäre in einer neueren Programmversion eine neue Einstellung in der Bibliothek "nur Unterverzeichnisse jeweils separat scannen" evtl. sinnvoll ? Voraussetzung dabei wäre dann natürlich, daß es im Oberverzeichnis nur eine Unterverzeichnisebene gibt.

 

Nur zur Information für evtl weitere Lösungsvorschläge: Ich nutze derzeit die aktuellste Version 3.2.60.0.

Link to comment
Share on other sites

pünktchen

Also in meinem Test hat es funktioniert.

Zumindest so wie ich es laut deiner Erklärung verstanden hab, was aber ziemlich schwierig ist, somit wird es für Luke und den Google Übersetzer erst recht schwer. Vielleicht kannst ja auch mal ein paar Bilder vom Explorer machen, damit man es besser nachvollziehen kann.

Link to comment
Share on other sites

Wenn Sie die ursprüngliche Ordnerstruktur möchten, wird dies bei Heimvideos beibehalten. Vielen Dank !

Link to comment
Share on other sites

pünktchen

Problem erkannt: es sind die verschiedenen Laufwerksbuchstaben! In meinem Test hatte ich natürlich nur die Ordner auf ein und der selben Platte angelegt.

Das Problem lässt sich aber lösen mit einem "Symbolischem Link". Du öffnest die Windows Eingabeaufforderung mit Administrator-Rechten und gibst folgendes ein:

mklink /j D:\Daten E:\Daten\Videos
mklink /j D:\MeineDaten F:\Meinedaten

Dann wie ich vorgeschlagen hatte, alle Verzeichnisse von Laufwerk D bei Emby als "Home videos & photos" eintragen:

D:\Media\Filme
D:\Videos
D:\Meinedaten
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...