Jump to content

Local and Remote Access


Moleburt
 Share

Recommended Posts

Moleburt

I have a question I'm curious if anyone knows the answer to. I currently use Emby for home use, because for some reason Plex doesn't work on my local network, but I have people that use my Plex for remote access. So yesterday I finally decided to figure and set up Emby for remote access, I added the port forwarding to my router and tested it out, it worked. Then I went to use Emby at home and it wouldn't work on the local network, kept getting errors, but as soon as I deleted the port forwarding I had added to my router it worked like normal again. Ideally I would like to be able to use just one program for both local and remote access, and I believe if I deleted the port forwarding I had setup for plex it would likely fix the issue with that as well on my local network. Does anyone have any ideas of what the issue I am having is and possible solutions? Any help would be greatly appreciated.

 

Nick

Link to comment
Share on other sites

Moleburt

I could open emby and it would look like everything loaded, but then when I tried to play something I would get an error about playback, as soon as I got rid of the port forwarding I had setup everything worked fine again. The only other thing I noticed was Emby seemed to load everything very slowly. That really all I can think of that explains it, I wish there was more that I could say, but that really was the entirety of the issue. Maybe I set something up wrong in the Port Forwarding, not really sure. It seemed to be working remotely, but local wasn't.

 

Nick

Link to comment
Share on other sites

legallink

A couple of things:

 

Do you have separate networks? Aka are you double nat’d?

 

Other questions, do you have clans? Or possibly isolated IP addresses? It sounds like when you are port forwarding you are isolating that device.

  • Like 1
Link to comment
Share on other sites

I could open emby and it would look like everything loaded, but then when I tried to play something I would get an error about playback, as soon as I got rid of the port forwarding I had setup everything worked fine again. The only other thing I noticed was Emby seemed to load everything very slowly. That really all I can think of that explains it, I wish there was more that I could say, but that really was the entirety of the issue. Maybe I set something up wrong in the Port Forwarding, not really sure. It seemed to be working remotely, but local wasn't.

 

Nick

 

To me this all sounds unrelated. What exactly do you mean by opening Emby? How are you doing that?

Link to comment
Share on other sites

Yea, a port forward is a rule that would apply to traffic coming into your network from the public Internet. This should not apply or disallow traffic from your internal network to your internal Emby server.

 

When you are remote do you use a public DDNS domain that points to your public IP address? If so are you trying to use the same DDNS domain when you are on your internal network? If both of the above are true do you have a feature called NAT reflection (aka NAT loopback) available on the home router?

 

 

Sent from my iPhone using Tapatalk

Edited by Tur0k
Link to comment
Share on other sites

Moleburt

Sorry I should have specified, this is happening using the Roku Empy app. Everything on the server/pc side seems to be fine, but when I added the port forwarding it caused the issues when connecting via Roku App on my local network. As for having seperate networks or any of that stuff, I don't have anything like that. All I know is I used this tutorial when I first set up Plex the way it is. Then when I was trying to make Emby work remotely I just followed the instructions that is linked next to where it says "Remote (WAN) Access" on my Emby Dashboard, it has a help button that takes you here. I followed those instructions, as well as used the first link underneath the "Set Up Port Forwarding" section. Here is a screen shot of my port forwarding page on my router, the emby one is gone, but was setup the same, just a different port. Hopefully I gave better detail this time, I'm not sure what else to add. I'm not the best with the networking side of this.5a440fef00c86_ScreenShot.png

Edited by Moleburt
Link to comment
Share on other sites

What URL do you use when you connect a client on the public Internet to your Emby server? If you use a DDNS it would look like:

Http://<myddnsdomain>:8096

Or

Http://<myddnsdomain>:8920

 

when you connect a client to Emby on your internal LAN you should use something like:

Http://192.168.1.###:8096

 

If you attempt to use:

Http://<myddnsdomain>:8096

 

While connected to your internal network you would need NAT reflection (AKA NAT loopback) enable on your router.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Moleburt

I think that the NAT loopback is the issue, and I did some research and unfortunately for me, it appears that Linksys routers with the Smart Wifi cannot do NAT Loopback, but from everything I've read, that appears to likely be why port forwarding messes with the server on the local network, but it works fine remotely.

 

Nick

Link to comment
Share on other sites

I think that the NAT loopback is the issue, and I did some research and unfortunately for me, it appears that Linksys routers with the Smart Wifi cannot do NAT Loopback, but from everything I've read, that appears to likely be why port forwarding messes with the server on the local network, but it works fine remotely.

 

Nick

 

The system should still work.

 

How, exactly, are you connecting to the server when on the local network?  If you are using the standard server discovery and just clicking on the server then it should use the local address for your server and the port forwarding would have no effect.

 

It sounds like you are using the external address for your server from within your network.  You don't want to do that.

Link to comment
Share on other sites

mastrmind11

What @@Tur0k said is basically describing what happens when you try to use a domain address on your local network with no NAT loopback enabled.  You confirmed it by stating that your router cannot do loopbacks.  @@ebr elaborated further and said you need to use your internal server IP when using Emby on your local network.  So try opening a browser and typing your Emby server IP and specify port 8096.  I bet that will work.  Port forwarding should have zero effect on a basic internal network.

Link to comment
Share on other sites

I think that the NAT loopback is the issue, and I did some research and unfortunately for me, it appears that Linksys routers with the Smart Wifi cannot do NAT Loopback, but from everything I've read, that appears to likely be why port forwarding messes with the server on the local network, but it works fine remotely.

 

Nick

Have you tested to confirm whether you can access your Emby install from

 

http://192.168.1.###:8096

 

(Where "192.168.1.###" is the local SUBNET static ip or dhcp reserved IP address of your Emby server.)

 

If the above works then there isn't anything wrong with your Emby install.

 

If the above works then, you need to plan to either:

1. access locally this way and use your DDNS when public.

2. Find a router that has NAT loopback in order to use the same domain internally or externally.

3. Host a local DNS server that allows you to explicitly direct internal DNS requests for your public domain to a local IP address instead of your public IP address.

 

If the above didn't work you likely have a firewall (windows defender firewall) problem on the host server.

 

I often see people set their computer to not be discoverable on their local LAN or the LAN gets tied to the public network type. This stops all communication with the local LAN including Emby.

 

To resolve set the Emby server to to be in the private network type.

 

https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private#fix-for-wired-network-connections

 

The. Check that you have an advanced firewall rule to explicitly allow inbound port 8096 and 8920 for the private network type.

 

Sent from my iPhone using Tapatalk

Edited by Tur0k
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...