Jump to content

kodi plugin - Force transcode x265 is not working


tomimc
 Share

Recommended Posts

From Versión 3.2.40.1 beta Force Transcode x265 is ignoring and using direct .

I just test with old version Versión 3.2.36.10 and is working ok.

 

Dont know if a server issue or kodi plugin.

Link to comment
Share on other sites

Angelblue05

Someone else reported an issue regarding this, I'll be putting out a new build to fix it... I'm guessing it's the same issue.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Hi @@Angelblue05 , i just checked the last kodi plugin version 2.3.58 and is not fixed.

 

In addon settings, i set Force Transcode x265 (480p and higher) but not work. The hevc/x265 movie start as direct play stream

Tested with lastest emby Server Beta Version 3.2.40.6

With old emby server version 3.2.36.10 is working ok.

kodi_log.txt

Edited by tomimc
Link to comment
Share on other sites

Hi i was checking logs, and i did some tests:

 

In emby version 3.2.36.10 the var in kodi addon videotrack = self.item['MediaSources'][0]['Name'] is getting "1080P/HEVC/AC3"

in newer emby server versions the same var is getting the name of the movie so never is entering in  if transcodeH265 conditional sentence.

 

In the new server versions the "item playback info is":

{"MediaSources":[{"Protocol":"File","Id":"db47966a20130295841e4774635c65f5","Path":"/var/plex/x265/La Torre oscura (2017) [Rip 1080p x265 Dual Subs].mkv","Type":"Default","Container":"mkv,webm","Name":"La Torre oscura (2017) [Rip 1080p x265 Dual Subs].mkv","IsRemote":false,"ETag":"817a96c9b8e56a37f18485fbaf257828","RunTimeTicks":56847360000,"ReadAtNativeFramerate":false,"IgnoreDts":false,"IgnoreIndex":false,"GenPtsInput":false,"SupportsTranscoding":true,"SupportsDirectStream":true,"SupportsDirectPlay":true,"IsInfiniteStream":false,"RequiresOpening":false,"RequiresClosing":false,"SupportsProbing":true,"RequiresLooping":false,"VideoType":"VideoFile","MediaStreams":[{"Codec":"ac3","Language":"spa","TimeBase":"1/1000","CodecTimeBase":"1/48000","Title":"AC3 5.1 @ 640 kbps","DisplayTitle":"Spa Dolby Digital 5.1 
Edited by tomimc
Link to comment
Share on other sites

Angelblue05

Thanks. I guess it wasn't the same error as the other person reported. Hum. @@Luke so how do we know the file is h265? Does it not return the value that contains the video/audio codec/resolution anymore?

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

Thanks. I guess it wasn't the same error as the other person reported. Hum. @@Luke so how do we know the file is h265? Does it not return the value that contains the video/audio codec/resolution anymore?

 

 

Sent from my iPhone using Tapatalk

 

Well the mediaSource.Name property is something that should only be used for display purposes. What you would need to do is look at mediaSource.MediaStreams, find the first video stream and check the Codec property of that stream.

  • Like 1
Link to comment
Share on other sites

Sounds good. Make sure to handle the situation of the info being unknown, for example, you may not find any video stream at all.

Link to comment
Share on other sites

  • 4 weeks later...
Sunabouzu

The same seems to be happening with Hi10P. On my Kodi addon I have enabled only Hi10P force transcode (H265 is disabled) and in the last week or so it stopped transcoding (keeps direct playing).

 

My server version is 3.2.60.0

My addon version is 2.3.61

Link to comment
Share on other sites

Angelblue05

Sorry as you can see by checking the changelog posted in the kodi forums, I haven't updated this yet. But I am currently working to update the playback aspect of the add-on. Thank you for your patience.

Link to comment
Share on other sites

  • 5 weeks later...
Sunabouzu

Sorry as you can see by checking the changelog posted in the kodi forums, I haven't updated this yet. But I am currently working to update the playback aspect of the add-on. Thank you for your patience.

Any news on this? Couldn't find anything on the Kodi forums. Perhaps I didn't look hard enough though.

Link to comment
Share on other sites

Sunabouzu

Installed the beta add-on and confirm it is transcoding again.

 

However subtitle selection is not working -- playback starts without allowing to choose which subtitle to burn into the transcoding, which was the previous behavior. Tested on several files with the same result.

Link to comment
Share on other sites

  • 2 weeks later...
Angelblue05

@@Sunabouzu

 

Sorry for the delay. It should work correctly with beta. I totally forgot to let you know about it. I fixed audio/subtitles selection.

 

Report back  :)

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

Please provide your Kodi log. I don't have that issue anymore, thank you.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Angelblue05

I don't know what could be the problem, it's an add-on provided by Team Kodi so it should work.

 

I've tested force transcode and it works fine here. It also let's me select audio/sub track. Make sure this setting is enabled, in the add-on settings > video playback > Enable audio/subtitle selection under Transcode.

Edited by Angelblue05
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...