Jump to content


Photo

Trakt sync authorization error?


  • Please log in to reply
115 replies to this topic

#1 BEis OFFLINE  

BEis

    Advanced Member

  • Members
  • 124 posts
  • Local time: 02:06 AM

Posted 29 November 2017 - 07:40 PM

As of this afternoon, when I run a "Sync library to trakt.tv" operation, I get the following error:

 

Sync library to trakt.tv failed. Unauthorized.

 

This just started happening today. Nothing has changed on my server. I've double checked to make sure my login information is correct. I've rebooted the machine, uninstalled and reinstalled the Trakt plugin, and it's still happening.

 

Anyone have any ideas? Not sure what else to try here.

 

Incidentally, the "Import playstates from trakt.tv" operation works fine. It's just the sync library that fails.

 

Help please! Thank you..


  • MrLinford and Zodler like this

#2 hstamas OFFLINE  

hstamas

    Advanced Member

  • Members
  • 609 posts
  • Local time: 03:06 AM

Posted 29 November 2017 - 08:44 PM

I’m getting the same error.

#3 manicpanic OFFLINE  

manicpanic

    Member

  • Members
  • 12 posts
  • Local time: 02:06 AM

Posted 29 November 2017 - 09:09 PM

+1



#4 dranderson402 OFFLINE  

dranderson402

    Advanced Member

  • Members
  • 227 posts
  • Local time: 02:06 AM

Posted 29 November 2017 - 09:58 PM

Here also

Sent from my SM-G955U using Tapatalk

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152351 posts
  • Local time: 03:06 AM

Posted 29 November 2017 - 10:02 PM

Thanks for the report. The plugin needs to be updated to support newer trakt api requirements. While we are here I would just like to point out that the trakt plugin is a community addition and contributions are welcome. The source code for it can be found here:

 
 
Thanks !


#6 paulsalter OFFLINE  

paulsalter

    Advanced Member

  • Members
  • 396 posts
  • Local time: 07:06 AM

Posted 30 November 2017 - 04:58 AM

Noticed the same on mine

 

Nothing i watched last night got sent to Trakt, though yesterday morning was ok



#7 alext41 OFFLINE  

alext41

    Member

  • Members
  • 17 posts
  • Local time: 08:06 AM

Posted 30 November 2017 - 05:08 AM

Noticed it today, yesterday in the morning it was working :(



#8 BEis OFFLINE  

BEis

    Advanced Member

  • Members
  • 124 posts
  • Local time: 02:06 AM

Posted 30 November 2017 - 09:42 AM

Thanks for the info about the plugin @Luke. Unfortunately this is above my level of expertise... does anyone know who was originally involved in creating the Trakt plugin? It sounds like we need to get someone involved that is capable of updating the code to support the new requirements.



#9 BEis OFFLINE  

BEis

    Advanced Member

  • Members
  • 124 posts
  • Local time: 02:06 AM

Posted 30 November 2017 - 09:44 AM

I'm tagging @J2ghz because he's listed on the GitHub as a contributor to the plugin. Maybe he can help?



#10 hstamas OFFLINE  

hstamas

    Advanced Member

  • Members
  • 609 posts
  • Local time: 03:06 AM

Posted 30 November 2017 - 09:46 AM

Im noticing that the straight up Trakt plugin for Kodi was not scrobbling last night either - just and FYI if it matters.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152351 posts
  • Local time: 03:06 AM

Posted 30 November 2017 - 12:02 PM

Thanks for the info.

#12 heula OFFLINE  

heula

    Advanced Member

  • Members
  • 958 posts
  • Local time: 08:06 AM
  • LocationSpijkenisse, The Netherlands

Posted 30 November 2017 - 12:14 PM

Having also problems with trakt. Not synchronising.

#13 esk1 OFFLINE  

esk1

    Newbie

  • Members
  • 2 posts
  • Local time: 01:06 AM

Posted 30 November 2017 - 12:39 PM

Also seeing this issue



#14 paulsalter OFFLINE  

paulsalter

    Advanced Member

  • Members
  • 396 posts
  • Local time: 07:06 AM

Posted 30 November 2017 - 02:14 PM

Just guessing but wondering if Trakt has disabled the ability to scrobble/sync when using username/password

 

Been a while since i used the plugin for Kodi, anyone know if that is using username/password, as above that stopped yesterday

 

I am still subscribed to get emails about Trakt for Plex, just had the following update, looks like it's requesting oAuth instead of user/pswd

 

I'm using a very old version of the plug-in thats been working forever without issue, until yesterday.

 Now i'm getting the 401 oAuth must be provided error.

 I'm able to login to trakt.tv just fine. Anyone else having this issue?

 



#15 hstamas OFFLINE  

hstamas

    Advanced Member

  • Members
  • 609 posts
  • Local time: 03:06 AM

Posted 30 November 2017 - 05:28 PM

Just guessing but wondering if Trakt has disabled the ability to scrobble/sync when using username/password

 

Been a while since i used the plugin for Kodi, anyone know if that is using username/password, as above that stopped yesterday

 

I am still subscribed to get emails about Trakt for Plex, just had the following update, looks like it's requesting oAuth instead of user/pswd

When I tried the Trakt Kodi add-on the other day I authorized via the web link it gives you. I never inputted a user name/password. I only watched 2 shows with the plugin installed (and the Emby server plugin uninstalled) and it did not scrobble.



#16 Zodler OFFLINE  

Zodler

    Advanced Member

  • Members
  • 146 posts
  • Local time: 08:06 AM

Posted 30 November 2017 - 07:07 PM

Me too. Since yesterday when I watch videos, they do not sync to Trakt.

 

I have

Emby Server Version 3.2.36.0 and

Trakt plugin 3.1.1.0
 
It uses username and password and since yesterday things I watch with my Emby Server, do not sync.


#17 FluffMe OFFLINE  

FluffMe

    Newbie

  • Members
  • 5 posts
  • Local time: 08:06 AM

Posted 30 November 2017 - 08:14 PM

Same here.



#18 jbuyense OFFLINE  

jbuyense

    Member

  • Members
  • 16 posts
  • Local time: 01:06 AM
  • LocationWhite Bear Lake, MN

Posted 30 November 2017 - 09:37 PM

For what ever it's worth, same problem here!



#19 overdox OFFLINE  

overdox

    Newbie

  • Members
  • 4 posts
  • Local time: 08:06 AM

Posted 01 December 2017 - 05:31 AM

noticed this is happening the last couple of days allso.



#20 BEis OFFLINE  

BEis

    Advanced Member

  • Members
  • 124 posts
  • Local time: 02:06 AM

Posted 01 December 2017 - 09:16 AM

So the question now is, what do we do to fix this? Apparently since the Trakt plugin is not officially part of Emby, it is up to the community to update it to be in compliance with the new requirements of Trakt. Does anyone have programming experience to be able to fix this?


  • overdox likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users