Jump to content

Music library not displaying correctly after v3.0.5171.19958


berrick
 Share

Recommended Posts

Hi all,

 

I have been quiet here for a while but I have been trying to keep an eye on developments of the excellent work being under taken and upgrading when newer version are released.

 

After installation the most recent version of the server my music library doesn't display correctly (ebr will be cringing now). It may just be a config issue, I note lots of new settings. I have briefly checked these but it does appear that this version of MB server is doing something differently? Below is an example of how the folders use to display prior to upgrade

 

5316dc58870ad_MB3002.png

 

And the next image is how the same folder is now displaying after the upgrade

 

5316dcb9a0323_MB3001.png

 

Would anyone have idea's of things I can check?

 

I have looked at the library with library explorer (imo I much preferred the look of the old library explorer) and can't see any obvious differences.

 

TIA

Link to comment
Share on other sites

I can't get that "new" view on mine (in Firefox). All I get is the one in the first screenshot. Plus, my tab says Media Browser, not X-Z like your's does, and my address bar, after dashboard simply has /musicartists.html, not the long string that your's does. Whether I click on the block of music covers or the text. So perhaps it's something to do with your browser?

Link to comment
Share on other sites

Berrick, I'm sure this has to do with that structure you have of letter folders.  We are probably now identifying them as Artists.

Link to comment
Share on other sites

Thanks for the replies.

I tried using both IE11 and Chrome prior to posting so its not the browser.

 

Hi ebr, The parent folder x - z is identified as "musicartist" and the folders it contains are identified as "folders". This is identical to how they where identified in v3.0.5115.35703 where they displayed correctly.

 

The only other difference between the versions, other than the version upgrade is the fact I installed the latest version from new on a different computer.

 

Are there steps I can take to correct this issue? If need be I can easily revert to a previous version. Would I need to delete all the artist.xml files to do that?

Link to comment
Share on other sites

Gonna need to pull @@Luke into the discussion.  I'm sure it has something to do with how we are now interpreting your unusual folder structure.

 

Luke - for background, he has a folder structure where all his music is broken into sub-folders by groups of letters like:

 

music\a-c\artist\album

music\d-f\artist\album

...

Link to comment
Share on other sites

In case it clarifies the folder structure see the image below

 

531760f313aa7_FolderIssue.jpg

 

It is structured this way as the music library is quite large and has to accessible by other programs and apps. 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Luke/ebr,

 

Hope you are both well. This may be of help.

 

I have found a little time to spend using MB3 and have noted that whilst MB Classic displays the problem shown above MB theater doesn't. It displays correctly.

 

Could the .xml files have an impact? I have seen that some .xml files in other folders have a different structure. 

Edited by berrick
Link to comment
Share on other sites

That's because MBC shows you your items in the structure you define but MBT (for the most part) uses type-based views so it ignores that structure.

Link to comment
Share on other sites

Actually MBT doesn't do that yet, but it will. Really the web client is the best place to debug.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...