Jump to content

4K content from Chrome and IOS Emby app show as 1080p on a Vizio TV M70-E3


benoitdansereau
 Share

Recommended Posts

benoitdansereau

Hi all,

 

I've been playing with Emby for a few weeks since I've gotten a new TV that has 4K capability.  So far, I am unable to stream 4K content through Emby with an output above 1080p (as shown by pressing the "Info" button on the TV remote control).

 

I am using the Free Emby Server version as of now, not sure if that makes a difference for what I am trying to achieve?

 

I am doing the test without WiFi for now to put all chances on my side.

 

If I stream YouTube 4K video through Chromecast, the TV does show 2160.

 

Emby is running on a recent iMac (i5, 3.4Ghz, 8 GB of RAM DDR4 2400, Radeon Pro 560 4096 Mo) which is also attached with an Ethernet cable on the same switch as the TV.

 

I tried multiple ways, one of them is with Chrome browser and sending to Chromecast and having the Playback in the browser set to 4K - 80 Mbps.

 

I tried the same with my iPhone 6 Plus, IOS 11.0.3 with the Emby client.  Again, the Playback set to 4K - 80 Mbps, also tried 4k - 120 Mbps.

 

I tried without and with Transcoding (Intel Quick Sync) with always the same result.  Videos plays but shows 1080p.

 

Anyone has any clue as what to do to make it happen?

 

Regards,

 

 

 

 

Link to comment
Share on other sites

benoitdansereau

Hi Luke,

 

ok, I just notice that there were a new version of the Emby server so I updated it - 3.2.36.0.  I was able to locate the log folder on the Mac which are attached (the Emby server was restarted at 9:20 so, I am only providing the newer ones).  Previous ones are still available if required.

 

I did a test with Transcoding set to None and played a 4K file. When I click on this movie in a Chrome browser, it shows :

4K - HEVC - 7.1 TRUEHD - and then the added date.  I am trusting that this format is ok for the tests!  The Playback seeting was set at: 4K - 80 Mbps

 

Still, the "Info" on the TV still shows 1080p.  I left everything wire (no Wi-Fi) on the TV and on the Emby server, both are on the same 1Gb switch.

 

Looking forward to read your finding!

 

Regards,

ffmpeg-transcode-a3c5bb5d-9fa3-43d1-a95c-4023a89d9f88.txt

server-63645297140.txt

server-63645297668.txt

Link to comment
Share on other sites

Ok the issue here is that it advertises itself like a chromecast gen 1 device, which we cap at 11mbps and that's why it won't direct play the video. We'll need to think about how to handle this.

Link to comment
Share on other sites

benoitdansereau

Hi Luke,

 

All right, is there any settings I can try on my side?  Modifying a config file or something?

 

Otherwise, can I expect a fix in a timely matter?  Just trying to understand and set the expectation!

 

Regards,

Link to comment
Share on other sites

benoitdansereau

Ok,

 

Just as a FYI, I’ve informed Vizio about the version of Chromecast that the tv advertise. I’ll update if I hear something back!

 

Regards,

 

Benoit

 

 

Envoyé de mon iPhone en utilisant Tapatalk

Link to comment
Share on other sites

benoitdansereau

Hi Luke,

 

I have some updates.  I was having non-productive emails with Vizio support so I ask to engage with level 2 support and to my surprise, I received a call back.  The person I was speaking with was not aware of the Chromecast Gen 1 and he will bring this to Dev team.  But, as he was mentioning, other streaming services do work, YouTube as an example.  He got me thinking.  So, for curiosity purposes only, I tested one of your competitor, four letters starting with "P" not to name it.  Using exactly the same test files, it worked, TV was showing 2160p.  I have since ordered parts to build a decent HTPC from which I will be conducting more testing.

 

So, not sure why it works with them and not with Emby.  I do have a preference for Emby, otherwise, I wouldn't be writing this post.  Looking forward to hear your ideas!

 

Regards,

 

Benoit

Link to comment
Share on other sites

benoitdansereau

Hi Luke,

 

Not sure I understand your reply, it might be a language barrier since English is not my primary one!  I hope my previous post is not perceived as an offense to you or the product or what not!  My only goal was to provide the fact.

 

Was I was trying to say is that, given the same setup (streaming server, TV, network, ...), I had success with the other.  So, how is this translate in me asking you to adjust?

 

If you have a solution in light, I'd be happy to run some more testing.

 

Regards,

Link to comment
Share on other sites

dannygp87

I'm planning to buy a Vizio M/P series too, so being able to cast a 4k video directly from emby to it would be an appreciated feature  :) 

Link to comment
Share on other sites

  • 2 months later...
Sizzlebox

Not sure if it was expected to be fixed or not -- but using the newest firmware on my Vizio M, all ethernet, newest Emby server software -- still shows as 1080p instead of 4k.

 

I'd love to help however I can. Thanks!

 

edit -- I should clarify, seems like I have the identical vizio model as OP.

Edited by Sizzlebox
Link to comment
Share on other sites

Not sure what you mean. It does transcode down to 1080p. It will not display as 4k.

 

You're doing this with vizeo's built in chromecast?

Link to comment
Share on other sites

  • 2 weeks later...
dannygp87

Can you please provide an ffmpeg log from an example? thanks.

 

Hi Luke, I have the same problem described here with a 2017 Vizio M, same model as @ has.

According to this reddit thread, it should work: https://www.reddit.com/r/Chromecast/comments/5vdldk/any_difference_between_chromecast_ultra_and_vizio/

Also, with P**x it works, so it should be possible. I attach a ffpmeg log.

Thanks in advance! :)

ffmpeg-transcode-783b5b70-aacb-4396-9a4c-28127379ef4e.txt

Edited by dannygp87
Link to comment
Share on other sites

Guest asrequested

I remember testing that, and not getting the desired playback. I haven't checked it, recently. It's the smartcast app. It has full 4k and HDR support. I'm not sure if it has to be used in conjunction with the smartcast app on your mobile device?

Link to comment
Share on other sites

Sizzlebox

I remember testing that, and not getting the desired playback. I haven't checked it, recently. It's the smartcast app. It has full 4k and HDR support. I'm not sure if it has to be used in conjunction with the smartcast app on your mobile device?

No, you dont have to use the Vizio SmartCast app to use its Chromecast 4K playback.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Sizzlebox

I tried to stream 4k HEVC to my Vizio Chromecast --- it transcoded down to 1080p and buffered. I'm trying to find the attach file option...

 

EDIT: I see... needed to use "full editor"

Edited by Sizzlebox
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...