Jump to content

OSX Emby crash when starting


scouty
 Share

Recommended Posts

Hi,

 

I'm trying to use emby on OSX Sierra. I've downloaded the latest release, installed it on the App folder, When I try to start the emby server,

it seems to crash. I've attached the log file.

 

I've tried on two different OSX system ( iMac and Macbook Pro 2016 ) both running Sierra, I have the same issue.

 

Thanks for your help.

Benjamin,

EmbyServer_2017-10-23-073416_iMac-de-Benjamin.txt

Link to comment
Share on other sites

Thanks for you replies :

Good news : 

1/  sorry to say that : I'm not alone !!!  :D

2/ A legend takes our issue into account  ;)

 

regards,

Benjamin,

Link to comment
Share on other sites

I haven't' gotten to the bottom of this yet. Can you check for system updates and ensure that your Mac is fully up to date? thanks.

Link to comment
Share on other sites

I'm running Sierra ( not High Sierra ) and I've just checked, there is no system update proposed by the AppStore. I may have missed something, is there any other components required to run emby ?

 

regards,

Benjamin,

Link to comment
Share on other sites

Then if the issue persist, can you please attach the contents of this folder:

/Users/{user}/.config/emby-server/logs

Thanks.

Link to comment
Share on other sites

I don't have any .config folder under my home directory. With 'ls -ali',  I have some others hidden folders  but nothing related to emby.

Thanks.

Link to comment
Share on other sites

vangeliis

Downloaded 3.2.35.0 => unzip the file => move emby-server to the Application folder 

I have the same result : connection to localhost:8096 impossible, no ~/.config folder.

 

The system report is attached.

 

Thanks for your support.

regards,

 

Hi @@scouty

 

Can you create a new user account (System Preferences --> Users & Groups) then log out from your current account, login into the newly created account and try to run EmbyServer from there. Does it still crash?

Link to comment
Share on other sites

Hi,

 

I've just tried your proposal. Different behavior :

new admin account ( TestEmby ), logout from my session, then log to TestEmby.

When I try starting emby-server, I have a message : unable to start application.

 

here is the system log :

Oct 29 11:15:15 MacBook-Pro-de-benjamin com.apple.xpc.launchd[1] (com.embyapp.embymediaserver.1172[4567]): Could not find and/or execute program specified by service: 13: Permission denied: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer

Oct 29 11:15:15 MacBook-Pro-de-benjamin com.apple.xpc.launchd[1] (com.embyapp.embymediaserver.1172[4567]): Service setup event to handle failure and will not launch until it fires.

 

 

I've checked in the emby-server app packet, the EmbyServer is present. Permission are read-only ( using Finder, read information ). I've tried to change to read-write, same result. No crash because not launched.

 

Regards,

Benjamin

Link to comment
Share on other sites

vangeliis

Hi,

 

I've just tried your proposal. Different behavior :

new admin account ( TestEmby ), logout from my session, then log to TestEmby.

When I try starting emby-server, I have a message : unable to start application.

 

here is the system log :

Oct 29 11:15:15 MacBook-Pro-de-benjamin com.apple.xpc.launchd[1] (com.embyapp.embymediaserver.1172[4567]): Could not find and/or execute program specified by service: 13: Permission denied: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer

Oct 29 11:15:15 MacBook-Pro-de-benjamin com.apple.xpc.launchd[1] (com.embyapp.embymediaserver.1172[4567]): Service setup event to handle failure and will not launch until it fires.

 

 

I've checked in the emby-server app packet, the EmbyServer is present. Permission are read-only ( using Finder, read information ). I've tried to change to read-write, same result. No crash because not launched.

 

Regards,

Benjamin

 

Hi @@scouty

 

I agree with you it's something to do with your permissions. I have attached mine for your information although I'm running high sierra.

Can you delete EmbyServer.app from within the new account (TestEmby), re-download it, unzip it and cross check permissions with the ones I have attached?

 

post-244638-0-75619200-1509275967_thumb.png

post-244638-0-87560400-1509275974_thumb.png

Link to comment
Share on other sites

So, big improvements  :D

I have two admin sessions : Benjamin and TestAdmin accounts.

 

On both, after re downloading the zip and installing the EmbyServer.app in the App folder I have the same issue ( see attached file report2.txt ) when trying to open the EmbyServer.app

 

But :

If I take a look inside the app package (.app )

-> on the Benjamin account EmbyServer is associated with the textedit application,

-> on the TestEmby account, Emby server is associated with the terminal application.

 

In fact, after some installation/uninstallation it depends on which account has installed the application.

 

The good news is : If I start the EmbyServer by entering inside the packet, and open /Applications/EmbyServer.app/Contents/MacOS/EmbyServer, it launches a terminal session, and the EmbyServer

is started. I'm able to connect to localhost:8096  :)

 

So , something goes wrong between the EmbyServer.app and the EmbyServer binary itself.

 

I hope it will help.

 

Benjamin, 

report2.rtf

Link to comment
Share on other sites

vangeliis

So, big improvements  :D

I have two admin sessions : Benjamin and TestAdmin accounts.

 

On both, after re downloading the zip and installing the EmbyServer.app in the App folder I have the same issue ( see attached file report2.txt ) when trying to open the EmbyServer.app

 

But :

If I take a look inside the app package (.app )

-> on the Benjamin account EmbyServer is associated with the textedit application,

-> on the TestEmby account, Emby server is associated with the terminal application.

 

In fact, after some installation/uninstallation it depends on which account has installed the application.

 

The good news is : If I start the EmbyServer by entering inside the packet, and open /Applications/EmbyServer.app/Contents/MacOS/EmbyServer, it launches a terminal session, and the EmbyServer

is started. I'm able to connect to localhost:8096  :)

 

So , something goes wrong between the EmbyServer.app and the EmbyServer binary itself.

 

I hope it will help.

 

Benjamin, 

 

Hi @@scouty

 

Can you run the following in the terminal.app:

 

ls -asl /Applications/EmbyServer.app/Contents/MacOS/

 

and scroll down util you find EmbyServer. It should look like -rwxrw-rw-@

The x means it's a unix executable and should be there for the binary to run.

 

If I understand correctly you will need to make EmbyServer an unix executable. Try to run the following command again in terminal:

 

chmod 766 /Applications/EmbyServer.app/Contents/MacOS/EmbyServer

Edited by vangeliis
Link to comment
Share on other sites

hi

 

ls -asl /Applications/EmbyServer.app/Contents/MacOS/ returns this :

 

264 -rwxrw-rw-@   1 Benjamin  staff    134016 29 oct 02:08 EmbyServer

 

After EmbyServer re installation on my session ( Benjamin ), it's a Unix excitable. -rwxrw-rw-@ is the same as chmod 766

 

When starting EmbyServer with a terminal command line /Applications/EmbyServer.app/Contents/MacOS/EmbYServer, I can connect to localhost:8096 but Emby Server doesn't run correctly. For example impossible to manage the médiathèque. I've attached

the output of the CLI when the  emby server starts. There are many errors.

 

 

regards,

report3.rtf

Link to comment
Share on other sites

vangeliis

hi

 

ls -asl /Applications/EmbyServer.app/Contents/MacOS/ returns this :

 

264 -rwxrw-rw-@   1 Benjamin  staff    134016 29 oct 02:08 EmbyServer

 

After EmbyServer re installation on my session ( Benjamin ), it's a Unix excitable. -rwxrw-rw-@ is the same as chmod 766

 

When starting EmbyServer with a terminal command line /Applications/EmbyServer.app/Contents/MacOS/EmbYServer, I can connect to localhost:8096 but Emby Server doesn't run correctly. For example impossible to manage the médiathèque. I've attached

the output of the CLI when the  emby server starts. There are many errors.

 

 

regards,

 

Hi @@scouty

 

Perhaps the Emby admins would like to see your log files then.

https://emby.media/c...port-a-problem/

Link to comment
Share on other sites

vangeliis

Can you try deleting this folder:

/Users/benjamin/emby-server

Then run again? thanks.

 

@@Luke

 

Do you mean /Users/banjamin/.config/emby-server

Link to comment
Share on other sites

Well something is strange with the first part of the log reporting a program data path of only

emby-server
Link to comment
Share on other sites

vangeliis

 

Well something is strange with the first part of the log reporting a program data path of only

emby-server

 

 

Perhaps for some reason @@scouty can not write into a ~/.config folder?

Edited by vangeliis
Link to comment
Share on other sites

Can you try deleting this folder:

/Users/benjamin/emby-server

Then run again? thanks.

 

 

Done, but the result remains the same.

I've deleted the emby-server folder under my home folder :

First try : I start the EmbyServer by opening the EmbyServer.app => crash. No new folder under ~/benjamin

Second try : I start the EmbyServer using the /Applications/EmbyServer.app/Contents/MacOS/EmbyServer command => the EmbyServer starts running, able to connect to localhost but it doesn't work correctly ( same as report3.rtf) .

At this stage, no folder created in my home folder. Even after making some setup on the web interface, I still don't have any folder related to embyserver under my home folder. the ~/benjamin/.config folder doesn't exist.

 

regards,

Link to comment
Share on other sites

Really good news !!!

 

I've created manually the folder ~/.config and everything works fine !!!

I can launch EmbyServer.app directly from Applications's folder.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...