Jump to content

Unable to connect over https on AppleTV/iOS


pinhead_dclxvi
 Share

Go to solution Solved by pinhead_dclxvi,

Recommended Posts

pinhead_dclxvi

Greetings,

 

I've been unable to get emby to work over https on AppleTV. There doesn't appear to be anything wrong with the certificate or the ports on my router as it works over Android connected externally through 4G and also when connected through local WiFi, both through computer desktops and Android devices.

 

Externally open ports redirect traffic to internal (http) port 8096 and (https) port 8920 respectively, nothing special there. Changing these to be the same ports does not alleviate the situation so I have reverted to my original (standard) settings.

 

Host is running emby server version 3.2.33.0.

 

Tested on Client(s):

tvOS version 1.1.04 - http works, https unable to connect - "Oops, something went wrong!" or timeout/splash screen with enter IP/use emby connect.

Emby for iOS version 1.4.4 - same deal, http works and https does not.

 

Desktop via Chrome and Firefox works both over http and https, same with Crome and Chromecast on Android.

 

Am I missing something here, or is there a known issue with iOS devices over https?

 

Best regards,

Chris

Link to comment
Share on other sites

pinhead_dclxvi

More specifically this is an issue when accessing emby externally. I have not been able to test the Apple devices over https locally.

Link to comment
Share on other sites

The apple devices must be rejecting the cert for whatever reason. That's really the only explanation if it's working on non-apple devices.

Link to comment
Share on other sites

pinhead_dclxvi

Asked a friend to log in from a different location with their iPhone which worked, so I guess it must be the Apple devices at the one location that are rejecting the certificate.

 

Thanks for helping me verify the issue isn't with emby, I'll have to look elsewhere for the solution.

Edited by pinhead_dclxvi
Link to comment
Share on other sites

I am also not able to use my Apple TV Get 4 or 3 with emby externally.. :( Same issue... I hope this can be fixed.

hi @@coyoteshawn, what fix are you looking for? did you read this thread?

Link to comment
Share on other sites

  • Solution
pinhead_dclxvi

This issue was solved for me after using the in-app software restart, I made no other changes to either emby or the SSL certificate.

 

I noticed that this specific AppleTV device was being throttled at 1.5Mbps (and was transcoding content that it should have been direct streaming), and everything returned to normal after the software restart. It connected to emby over https with no issues after that.

Edited by pinhead_dclxvi
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...