Jump to content

Audio Transcoding as MP3


Nisten
Go to solution Solved by Jdiesel,

Recommended Posts

This is more of a general question than an issue report

 

Is there any specific factors/thresholds that would cause audio to transcode to mp3?

Most of my media is direct mkv copies of physical discs with the original audio tracks in tact - The only changes i've made is setting the CRF factor of the x264 encoder to a lower value and setting de-interlacing to "bop & weave" , for testing

 

Update - Added logs

ffmpeg transcode - 10-13-2017 (1252pm).txt

ffmpeg transcode - 10-13-2017 (1254pm).txt

ffmpeg transcode - 10-13-2017 (1258pm).txt

Edited by Nisten
Link to post
Share on other sites

If your Roku isn't hooked up to a device that does AC3 or DTS passthrough it will transcode to 2ch mp3. The Roku can passthrough AC3 and DTS but not decode it. How is your Roku hooked up in your system?

Link to post
Share on other sites

roku is hooked up to TV via HDMI

 

2.1 soundbar is connected to the TV via optical 

 

Before i made the CRF and de-interlacing changes, transcoded audio was always ac3

Link to post
Share on other sites

Looks like your Roku is only reporting a maximum of two channels

 

"TranscodingMaxAudioChannels=2"

 

Did your Roku audio settings happen to change?

Link to post
Share on other sites

The initial ffmpeg logs are using the Emby Web app via Chrome (external/remote stream) - I'll double check the roku settings when I get home

 

The logs in post #7 are using the Emby Roku app (internal/in-network stream) [before the CRF & de-interlacing changes]

Link to post
Share on other sites
Happy2Play

Which app are we referring to?  Since Blue Neon has a option to change this behavior.

Link to post
Share on other sites
Happy2Play

I don't think it is related at all but you have a issue with quick sync also

[h264_qsv @ 0000000002218320] No device available for decoder (device type qsv for codec h264_qsv).
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (h264_qsv) -> h264 (h264_qsv))
  Stream #0:1 -> #0:1 (dts (dca) -> mp3 (libmp3lame))
Link to post
Share on other sites

So what is the problem? I don't quite understand. The roku is set to stereo and you're getting 2-channel audio, right?

Link to post
Share on other sites

So what is the problem? I don't quite understand. The roku is set to stereo and you're getting 2-channel audio, right?

 

Yeah, this is what I heard too... so I'm confused.

 

 

Roku is still set to PCM Stereo, has been for a month - this issue just started yesterday though

Link to post
Share on other sites
Waldonnis

I'm confused too.  It's doing exactly what it should be, which is taking a 6-channel AC3 source and transcoding it to 2-channel (using mp3) since the Roku is configured to only output 2-channel audio....

 

Let's see if we can figure out why the OP may not have expected this, though.  Does the soundbar supposedly have a decoder for AC3 built-in even though it's only a 2.1 system?  If so, then perhaps an other configuration of your soundbar/television would allow AC3 to pass through untouched (ARC, maybe...if supported).  If not, then you're limited to what the Roku can decode codec-wise onboard, which is a rather short list that does not include common surround codecs like ac3 and dts.  If the query is more like "why mp3 instead of aac?", then that's a whole other debate...

 

As for the QuickSync warning, disabling QuickSync h.264 decoding will make that go away and probably improve hardware encoding performance.  It's a bug that the upstream ffmpeg folks won't acknowledge as a bug (see this trac report) and can cause ffmpeg to use software encoding when it can't establish the context for hardware decoding on some systems (highly dependent on the system configuration).  It's really annoying and working around it is a real pain.

Link to post
Share on other sites

I wanted to know what caused this change since the mp3 audio transcoding change only started Last Wednesday/Thursday

 

The PCM configuration has been in place for at least a month so if it was supposed to be converting to mp3 based on my configuration by design, why it only went into effect 4 or 5 days ago?

 

-Soundbar has a AC3 and LPCM decoder

Edited by Nisten
Link to post
Share on other sites

I'm expecting it do what its done before, transcoding audio to ac3 - since it was working this way quite a while after i made the PCM changes until last Wednesday/Thursday

 

When it stopped doing what its done before, I wanted to know why it only recently started to take effect

 

-If its supposed to be mp3 based on my setup, then I can start expecting for that to happen instead but just want to know why that change only went into effect only recently even though the PCM changes were made much earlier 

Link to post
Share on other sites
  • Solution

I wanted to know what caused this change since the mp3 audio transcoding change only started Last Wednesday/Thursday

 

The PCM configuration has been in place for at least a month so if it was supposed to be converting to mp3 based on my configuration by design, why it only went into effect 4 or 5 days ago?

 

-Soundbar has a AC3 and LPCM decoder

 

Why it was working that way before I'm not sure but it seems like it may have been a bug that had a positive effect rather than a negative effect. If your soundbar supports ac3 you will want to change your Roku audio settings from "Stereo" to "DD". This way your soundbar will downmix to stereo rather then your server. Was your thinking that because your soundbar was 2 channel you should set your Roku's audio settings to stereo? Just curious.

 

On a side note I noticed some strange things with ac3 a few versions back that seems to have since been fixed, maybe it is related.

 

https://emby.media/community/index.php?/topic/50946-3048-ac3-being-copied/

Edited by Jdiesel
  • Like 1
Link to post
Share on other sites

Changed it to PCM since i don't have the additional audio channels for my soundbar and there's no compression with PCM so DD didn't seem to have any advantages for my setup 

 

Out of curiosity @@Jdiesel, what's your sound setup like (both on the hardware and software side)

Link to post
Share on other sites

 

As for the QuickSync warning, disabling QuickSync h.264 decoding will make that go away and probably improve hardware encoding performance.  It's a bug that the upstream ffmpeg folks won't acknowledge as a bug (see this trac report) and can cause ffmpeg to use software encoding when it can't establish the context for hardware decoding on some systems (highly dependent on the system configuration).  It's really annoying and working around it is a real pain.

 

Thanks for the info, i'll turn that off 

Link to post
Share on other sites

Changed it to PCM since i don't have the additional audio channels for my soundbar and there's no compression with PCM so DD didn't seem to have any advantages for my setup 

 

Out of curiosity @@Jdiesel, what's your sound setup like (both on the hardware and software side)

 

Mine is likely very similar but instead of a soundbar I have a small 2.1 channel amplifier (http://www.teac.com/product/ai-101da/). The amp does not decode DD or DTS but my TV does. My Roku audio settings are set to (DD, DD+, DTS), My TV is set to output PCM over the optical port, and my amp receives the 2-channel signal.

 

In your case it sounds like your soundbar accepts DD (maybe DTS as well) so you should be able to set the Roku settings to DD, DTS (or whatever your soundbar supports) and have your TV set to passthrough the audio over optical rather then transfer it as PCM. You will need to check your TV's audio settings as every TV is different.  

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...