Jump to content


Photo

m3u Channels not playing

m3u Freebox live tv tcp udp

  • Please log in to reply
30 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 21 November 2018 - 11:54 PM

I guess we have have to find what command line changes are needed, and then more importantly we have to figure out how to determine that we should apply them.

Our docker container is based on arch Linux, if that helps.

#22 kro OFFLINE  

kro

    Member

  • Members
  • 26 posts
  • Local time: 02:51 AM

Posted 22 November 2018 - 12:14 AM

from the container

/bin/ffmpeg -analyzeduration 3000000 -rtsp_transport tcp -rtsp_transport udp -rtsp_flags prefer_tcp -fflags +igndts -i "rtsp://mafreebox.freebox.fr/fbxtv_pub/stream?namespace=1&service=201&flavour=ld"

returns this could not find codec parameters error.

 

but no error with the same ffmpeg command from the host machine (except I'm supposed to specify an output file)

with ffmpeg version 3.2.10-1~deb9u1~bpo8+1

 

So I guess it must be a ffmpeg version / compilation / configuration issue ?

works (debian jessie) :

configuration: --prefix=/usr --extra-version='1~deb9u1~bpo8+1' --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --disable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared

doesn't work (emby docker, this one is very long :/ ) :

configuration: --cc=x86_64-pc-linux-gnu-gcc --arch=x86_64 --prefix=/home/embybuilder/Buildbot/x64/ffmpeg-x64/staging --pkg-config=pkg-config --disable-doc --disable-ffplay --disable-vdpau --disable-xlib --enable-fontconfig --enable-gnutls --enable-gpl --enable-iconv --enable-libass --enable-libfreetype --enable-libfribidi --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libwebp --enable-libx264 --enable-libzvbi --enable-version3 --disable-decoders --disable-encoders --enable-decoder=aac --enable-decoder=aac_fixed --enable-decoder=aac_latm --enable-decoder=ac3 --enable-decoder=ac3_fixed --enable-decoder=alac --enable-decoder=apng --enable-decoder=ass --enable-decoder=ayuv --enable-decoder=bmp --enable-decoder=dca --enable-decoder=dirac --enable-decoder=dvbsub --enable-decoder=dvdsub --enable-decoder=eac3 --enable-decoder=flac --enable-decoder=gif --enable-decoder=h264 --enable-decoder=hevc --enable-decoder=huffyuv --enable-decoder=mjpeg --enable-decoder=mlp --enable-decoder=mov_text --enable-decoder=mp3 --enable-decoder=mp3float --enable-decoder=mpeg4 --enable-decoder=opus --enable-decoder=pcm_alaw --enable-decoder=pcm_bluray --enable-decoder=pcm_dvd --enable-decoder=pcm_f16le --enable-decoder=pcm_f24le --enable-decoder=pcm_f32be --enable-decoder=pcm_f32le --enable-decoder=pcm_f64be --enable-decoder=pcm_f64le --enable-decoder=pcm_lxf --enable-decoder=pcm_mulaw --enable-decoder=pcm_s16be --enable-decoder=pcm_s16be_planar --enable-decoder=pcm_s16le --enable-decoder=pcm_s16le_planar --enable-decoder=pcm_s24be --enable-decoder=pcm_s24daud --enable-decoder=pcm_s24le --enable-decoder=pcm_s24le_planar --enable-decoder=pcm_s32be --enable-decoder=pcm_s32le --enable-decoder=pcm_s32le_planar --enable-decoder=pcm_s64be --enable-decoder=pcm_s64le --enable-decoder=pcm_s8 --enable-decoder=pcm_s8_planar --enable-decoder=pcm_u16be --enable-decoder=pcm_u16le --enable-decoder=pcm_u24be --enable-decoder=pcm_u24le --enable-decoder=pcm_u32be --enable-decoder=pcm_u32le --enable-decoder=pcm_u8 --enable-decoder=pcm_zork --enable-decoder=pgssub --enable-decoder=png --enable-decoder=r210 --enable-decoder=rawvideo --enable-decoder=ssa --enable-decoder=subrip --enable-decoder=srt --enable-decoder=text --enable-decoder=theora --enable-decoder=truehd --enable-decoder=v210 --enable-decoder=v210x --enable-decoder=v308 --enable-decoder=v408 --enable-decoder=v410 --enable-decoder=vorbis --enable-decoder=vp8 --enable-decoder=vp9 --enable-decoder=webp --enable-decoder=webvtt --enable-decoder=wmalossless --enable-decoder=wmapro --enable-decoder=wmav1 --enable-decoder=wmav2 --enable-decoder=wmavoice --enable-decoder=wmv1 --enable-decoder=wmv2 --enable-decoder=wmv3 --enable-decoder=wmv3image --enable-decoder=y41p --enable-decoder=yuv4 --enable-decoder=zero12v --enable-encoder=aac --enable-encoder=ac3 --enable-encoder=ac3_fixed --enable-encoder=ass --enable-encoder=dvbsub --enable-encoder=dvdsub --enable-encoder=flac --enable-encoder=libmp3lame --enable-encoder=libopus --enable-encoder=libtheora --enable-encoder=libvorbis --enable-encoder=libwebp --enable-encoder=libx264 --enable-encoder=mjpeg --enable-encoder=mov_text --enable-encoder=png --enable-encoder=srt --enable-encoder=ssa --enable-encoder=subrip --enable-encoder=text --enable-encoder=webvtt --enable-libsmbclient --enable-decoder=mp1 --enable-decoder=mp2 --enable-decoder=mpegvideo --enable-decoder=mpeg1video --enable-decoder=mpeg2video --enable-decoder=vc1 --enable-cuda --enable-cuvid --enable-nvenc --enable-vaapi --enable-decoder=h264_cuvid --enable-decoder=hevc_cuvid --enable-decoder=mjpeg_cuvid --enable-decoder=mpeg1_cuvid --enable-decoder=mpeg2_cuvid --enable-decoder=mpeg4_cuvid --enable-decoder=vc1_cuvid --enable-decoder=vp8_cuvid --enable-decoder=vp9_cuvid --enable-encoder=h264_nvenc --enable-encoder=h264_vaapi --enable-encoder=hevc_nvenc --enable-encoder=hevc_vaapi --enable-encoder=mjpeg_vaapi --enable-cross-compile --cross-prefix=x86_64-pc-linux-gnu- --extra-libs='-ldl -lexpat -lfreetype -lfribidi -lfontconfig -liconv -lpng -luuid -lz -lvorbis -logg -lnettle -lhogweed -lgmp -laddns-samba4 -lasn1util-samba4 -lauthkrb5-samba4 -lCHARSET3-samba4 -lcliauth-samba4 -lcli-cldap-samba4 -lcli-ldap-common-samba4 -lcli-nbt-samba4 -lcli-smb-common-samba4 -lcom_err -lcommon-auth-samba4 -ldbwrap-samba4 -ldcerpc-binding -ldcerpc-samba-samba4 -lflag-mapping-samba4 -lgenrand-samba4 -lgensec-samba4 -lgse-samba4 -lgssapi_krb5 -llibcli-lsa3-samba4 -llibsmb-samba4 -linterfaces-samba4 -liov-buf-samba4 -lk5crypto -lkrb5 -lkrb5samba-samba4 -lkrb5support -lldb -lldbsamba-samba4 -lmessages-dgm-samba4 -lmessages-util-samba4 -lmsghdr-samba4 -lmsrpc3-samba4 -lndr -lndr-krb5pac -lndr-nbt -lndr-samba-samba4 -lndr-standard -lreplace-samba4 -lsamba-cluster-support-samba4 -lsamba-credentials -lsamba-debug-samba4 -lsamba-errors -lsamba-hostconfig -lsamba-modules-samba4 -lsamba-security-samba4 -lsamba-sockets-samba4 -lsamba-util -lsamba3-util-samba4 -lsamdb -lsamdb-common-samba4 -lsecrets3-samba4 -lserver-id-db-samba4 -lserver-role-samba4 -lsmbconf -lsmbd-shim-samba4 -lsmb-transport-samba4 -lsocket-blocking-samba4 -lsys-rw-samba4 -ltalloc -ltalloc-report-samba4 -ltdb -ltdb-wrap-samba4 -ltevent -ltevent-util -ltime-basic-samba4 -lutil-cmdline-samba4 -lutil-reg-samba4 -lutil-setid-samba4 -lutil-tdb-samba4 -lwbclient -lwinbind-client-samba4 -ldrm' --target-os=linux --enable-shared --disable-static


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 22 November 2018 - 12:16 AM

If you'd like to try the beta channel that would be helpful. There are some libs missing from the ffmpeg build in the stable release. They've been added back on the beta channel.



#24 kro OFFLINE  

kro

    Member

  • Members
  • 26 posts
  • Local time: 02:51 AM

Posted 22 November 2018 - 12:37 AM

...after a few backups

emby/embyserver:beta (3.6.0.66) gives another error :

 

Playback Error
No compatible streams are currently available. Please try again later or contact your system administrator for details.

 

This happens as soon as I click on play, while with the stable version the player shows sthing a full black video with no sound (and the spinner keeps spinning).

 

I can't find anything related to this error in the log, just antoher reccurent one (every 10 sec) :

2018-11-22 04:30:43.041 Error UserDataManager: Error in event handler
	*** Error Report ***
	Version: 3.6.0.66
	Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3
	Operating system: Unix 3.16.0.7
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /config
	Application directory: /system
	System.MissingMethodException: System.MissingMethodException: Method not found: 'System.Guid MediaBrowser.Controller.Library.UserDataSaveEventArgs.get_UserId()'.
	   at Emby.Kodi.SyncQueue.EntryPoints.UserSyncNotification._userDataManager_UserDataSaved(Object sender, UserDataSaveEventArgs e)
	   at MediaBrowser.Common.Events.EventHelper.FireEventIfNotNull[T](EventHandler`1 handler, Object sender, T args, ILogger logger)
	Source: Emby.Kodi.SyncQueue
	TargetSite: Void _userDataManager_UserDataSaved(System.Object, MediaBrowser.Controller.Library.UserDataSaveEventArgs)
	   at Emby.Kodi.SyncQueue.EntryPoints.UserSyncNotification._userDataManager_UserDataSaved(Object sender, UserDataSaveEventArgs e)
	   at MediaBrowser.Common.Events.EventHelper.FireEventIfNotNull[T](EventHandler`1 handler, Object sender, T args, ILogger logger)

/system/EmbyServer.dll sounds like a weird command



#25 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 22 November 2018 - 12:43 AM

Remove the kodi sync plugin.



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 22 November 2018 - 12:43 AM

and then attach the complete log. thanks.



#27 kro OFFLINE  

kro

    Member

  • Members
  • 26 posts
  • Local time: 02:51 AM

Posted 22 November 2018 - 12:59 AM

here it is (no ffmpeg log)

 

I clicked 5 times on the play button

Attached Files


Edited by kro, 22 November 2018 - 12:59 AM.


#28 kro OFFLINE  

kro

    Member

  • Members
  • 26 posts
  • Local time: 02:51 AM

Posted 22 November 2018 - 01:01 AM

Live TV requires an active Emby Premiere subscription.

 

Is that a new policy ?



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 22 November 2018 - 01:14 AM

On the beta channel yes. We will have an announcement about that soon.



#30 kro OFFLINE  

kro

    Member

  • Members
  • 26 posts
  • Local time: 02:51 AM

Posted 26 November 2018 - 01:32 PM

I guess a policy on a beta channel is a policy to come on the stable channel...

 

Since I will most likely not benefit this functionality anymore in a near future I'm done helping to debug, sorry (not that I can anyway technically).



#31 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138261 posts
  • Local time: 10:51 PM

Posted 26 November 2018 - 02:00 PM

In case it helps convince you:

https://emby.media/c...webcam-rtsp-url







Also tagged with one or more of these keywords: m3u, Freebox, live tv, tcp, udp

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users