Jump to content

Theater Playback High Memory Usage Compared to Edge


UnderMiner
 Share

Recommended Posts

UnderMiner

Hello,

 

For a few weeks we cannot use Emby Theater on Windows 10 due to high memory use and high network traffic.

The system works well using Microsoft Edge.

I attached two screen captures playing the same file on the same system for reference (Microsoft Surface Pro 3, Core i5, 4GB RAM).

 

59cb059a4b614_EmbyTheaterPlaybackMemorya

 

59cb05a96ecb3_MicrosoftEdgePlaybackMemor

Edited by UnderMiner
Link to comment
Share on other sites

UnderMiner

If you left the computer untouched, it essentially played back normally.  That it not much headroom to use other apps or to skip forward it was a little sluggish.

Link to comment
Share on other sites

  • 2 months later...
UnderMiner

Hello,

On Windows 10, the Emby Theater app will not properly play video and the main symptom is an issue with Network use at 100%.  In my previous post high memory was the concern but on the latest version the issue is network communications.  As before, there are no issues playing back with Edge.  For the last couple of weeks I use Edge as a work around.  The hardware remains the same as my previous post (Microsoft Surface Pro 3, Core i5, 4GB RAM).

5a26137adc435_EmbyTheater.jpg

Link to comment
Share on other sites

UnderMiner

Hello,

 

I am using wireless but I routinely exceed 33 Mbps in a variety of use cases and tests.  When using Emby Theater there is no other activity.  The symptom seems to be how ET uses the network and not necessarily the bandwidth.  I am not an expert but perhaps the method of communication or the frequency of the requests for information is unique for ET?  I am willing to provide more information but I'm not certain what to provide other than the task manager screen capture and the symptom that the video is not playable (essentially stop motion/stuttering with horrible audio).  The good news is that Edge works well.

Link to comment
Share on other sites

Guest asrequested

It doesn't have any way to affect your network bandwidth, other than to use what is available. In your screenshot we can see that it's only using 33Mb/s, so if there is nothing else using your network, then it would appear that you may have a network issue. I was recently having some issues that I initially thought was emby related, only to feel foolish to discover that my NIC was starting to fail. And the only way it showed was by having intermittent bandwidth size. No errors. And it was a 10Gb NIC. An easy way to prove me wrong would be to temporarily hook up with a hard line.

Link to comment
Share on other sites

UnderMiner

Thanks for the advice regarding the NIC and your experience.

In my case, the Surface Pro 3 does not have wired LAN adapter, I would have to purchase one for testing.

We will use Microsoft Edge for the moment unless there are other utilities or methods to diagnose the unique behavior of ET.

For reference, I tested the internet bandwidth while playing a video with VLC and with Edge paused on recorded TV from the Emby Server.  I attached a snap shot of the results.

 

5a275db933012_EmbyTheaterBandwidth.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...