Jump to content

Hidden TempSWMC and TempRec folders?


oldschool

Recommended Posts

I'm still having problems with LiveTV. I get the following error inside the newest version of MB3 server:

 

Status: Unavailable (Recorded TV folder ‘\\SPARE1\Public\Recorded TV\’ not accessible. Please make sure the Recorded TV folder used by WMC for new recordings is a shared folder. Once done, the network path to this folder must be set in ServerWMC (see ‘Folders’ tab in ServerWMC).)

 

I've navigated to that folder from the server and multiple clients, so I know that folder is accessible. The problem might be that the TempSWMC and TempRec folders seem to be hidden folders on that machine. Could this be why I'm getting this error? I still can't figure out why I can't use Live TV.

Link to post
Share on other sites
krustyreturns

The new version of the plugin does a test to see if the folder exists, if it doesn't it throws that error.  If live tv still is not working that's probably why.  Is mbs being run under a different account that the one you are using to test if the directory is accessible?

 

I doesn't matter that the folders are hidden, but if you want you can un-hide them - it doesn't require them to be hidden.

Link to post
Share on other sites

I changed the user for the service from local logon to an actual user on the system, and that resolved the error message. On the other hand, live TV still isn't working. It gives me the same error on the iphone: Operation could not be completed.

 

I'll post logs tomorrow.

Link to post
Share on other sites

Here's the relevant log info:

2014-02-27 06:40:48.4178 Error - DtoUtils: ServiceBase2014-02-27 08:26:13.6869 Info - App: Opening channel stream from ServerWMC, external channel Id: 15909682
2014-02-27 08:26:19.5681 Info - App: C:\Users\eb\AppData\Roaming\MediaBrowser-Server\ffmpeg\20140105\ffmpeg.exe -fflags genpts -re -i -  -vcodec libx264 -force_key_frames expr:if(isnan(prev_forced_t),gte(t,.1),gte(t,prev_forced_t+5)) -vf "yadif=0:-1:0,scale=min(iw\,1280):trunc(ow/a/2)*2" -preset ultrafast -crf 23 -maxrate 1372000 -bufsize 2744000 -vsync vfr -profile:v baseline -level 3 -map_metadata -1 -threads 2  -f mp4 -movflags frag_keyframe+empty_moov "C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\84e9b8bb-6e05-ee89-2607-da042cc097cc.mp4"
2014-02-27 08:26:19.9113 Info - App: FFMpeg exited with code 1 for C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\84e9b8bb-6e05-ee89-2607-da042cc097cc.mp4
2014-02-27 08:26:19.9113 Info - App: Closing live stream from ServerWMC, stream Id: 8
2014-02-27 08:26:19.9113 Error - App: Error writing to standard input
2014-02-27 08:26:23.0157 Info - App: Opening channel stream from ServerWMC, external channel Id: 15909682
2014-02-27 08:26:23.3277 Info - App: Deleting partial stream file(s) C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\84e9b8bb-6e05-ee89-2607-da042cc097cc.mp4
2014-02-27 08:26:28.9593 Info - App: C:\Users\eb\AppData\Roaming\MediaBrowser-Server\ffmpeg\20140105\ffmpeg.exe -fflags genpts -re -i -  -vcodec libvpx -force_key_frames expr:if(isnan(prev_forced_t),gte(t,.1),gte(t,prev_forced_t+5)) -vf "yadif=0:-1:0,scale=min(iw\,1280):-1" -speed 16 -quality good -profile:v 0 -slices 8 -crf 18 -b:v 1372000 -vsync vfr -map_metadata -1 -threads 2  "C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\2063ba22-a00e-2e48-0484-088c6ef8fdd8.webm"
2014-02-27 08:26:37.1805 Info - App: Killing ffmpeg process for C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\2063ba22-a00e-2e48-0484-088c6ef8fdd8.webm
2014-02-27 08:26:37.1961 Error - App: Error writing to standard input
2014-02-27 08:26:37.1961 Info - App: FFMpeg exited with code -1 for C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\2063ba22-a00e-2e48-0484-088c6ef8fdd8.webm
2014-02-27 08:26:37.1961 Info - App: Closing live stream from ServerWMC, stream Id: 9
2014-02-27 08:26:37.1961 Info - App: Deleting partial stream file(s) C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\2063ba22-a00e-2e48-0484-088c6ef8fdd8.webm
2014-02-27 08:26:37.4613 Info - App: FFMpeg exited with an error for C:\Users\eb\AppData\Roaming\MediaBrowser-Server\transcoding-temp\2063ba22-a00e-2e48-0484-088c6ef8fdd8.webm
2014-02-27 08:26:37.5861 Info - App: Closing live stream from ServerWMC, stream Id: 9

Link to post
Share on other sites
krustyreturns

Good progress.  Can you post the serverwmc log too after a failed stream attempt?  I'd like the whole file too.  

Link to post
Share on other sites
saitoh183

i got this similar problem till i changed the Transcode folder in MBs to a UNC path and i made sure the UNC folder i set in ServerWMC had the Everyone Full access in the share permissions and Advanced sharing

Edited by saitoh183
Link to post
Share on other sites

I updated my server to the latest and tried to play a live tv stream. I received the box inside the browser and I saw a still screen (like a screenshot) from the channel, but nothing happened after that. Here's the latest part of the log:

 

2014/02/27 20:26:37.344    Received client request: MediaBrowser^@MYSERVER-FILESERVE@0|OpenLiveStream|15909459
2014/02/27 20:26:37.344    OpenLiveStream> -----------------start------------------------
2014/02/27 20:26:37.344    OpenLiveStream> client: MediaBrowser^ requesting live stream
2014/02/27 20:26:37.349    StreamProc> live-tv started
2014/02/27 20:26:37.353    SetChannel> Tuner: HDHomeRun Prime Tuner 13125DD3-2 / f659b868-820e-422f-9808-9e17cab9f369
2014/02/27 20:26:37.353    SetChannel> > Digital: True
2014/02/27 20:26:37.353    SetChannel> > Encrypted: False
2014/02/27 20:26:37.355    SetChannel> > RecorderInfo found: True
2014/02/27 20:26:37.356    SetChannel > busy: False, client: none
2014/02/27 20:26:37.356    SetChannel> > tuner is available  => stopping search
2014/02/27 20:26:37.356    SetChannel> Recorder Content Protection: PROT_COPY_FREE
2014/02/27 20:26:37.358    SetChannel> Recorder acquired: True
2014/02/27 20:26:37.361    SetChannel> TuneRequest set
2014/02/27 20:26:37.390    StreamProc> wtv recording started in 0.04 sec
2014/02/27 20:26:37.393    StreamProc> stream output file: LiveTV_MediaBrowser^0_Digital Cable_1009_2014_02_27_20_26_37.ts
2014/02/27 20:26:37.406    Remux::FindDescriptors> Scanning wtv for streams...
2014/02/27 20:26:37.412    StreamProc> started remux thread: 'KETVDT-1009: 15909459'
2014/02/27 20:26:39.471    Parse> Guid: 0 took 2.06 sec, it was attempted 693 times
2014/02/27 20:26:40.623    Parse> Descriptor pass done, using 500 guids in 1.15 sec
2014/02/27 20:26:40.623    Parse> Unknown Guid summary: 1 instances of 1 unique unknown guids encountered
2014/02/27 20:26:40.625     >  F7 10 02 B9 EE 7C ED 4E BD 7F 05 40 35 86 18 A1 {b90210f7-7cee-4eed-bd7f-0540358618a1}
2014/02/27 20:26:40.626    Parse> Total Descriptor parse time: 3.22 sec
2014/02/27 20:26:40.626    Pass 'Descriptor':
2014/02/27 20:26:40.626     >  WtvToPesDemuxer::Parse> total guid headers processed: 500
2014/02/27 20:26:40.626     >  WtvToPesDemuxer::Parse> total data packets processed: 81
2014/02/27 20:26:40.656    Remux::FindDescriptors> wtv scanned (3.25 sec), Streams found:
2014/02/27 20:26:40.656     >  Audio: ID:92 AC3 5.1 48000 Hz 384 kb/s
2014/02/27 20:26:40.656     >  Audio: ID:93 AC3 2.0 48000 Hz 192 kb/s
2014/02/27 20:26:40.656     >  Video: ID:94 MPEG-2 MP-HL 1920x1080i fps: 30000/1001 AR: 16:9
2014/02/27 20:26:40.656     >  Other: ID:95 MS TV Caption
2014/02/27 20:26:40.656    Remux::FindDescriptors> Output streams:
2014/02/27 20:26:40.656     >  Audio: ID:92 AC3 5.1 48000 Hz 384 kb/s
2014/02/27 20:26:40.656     >  Audio: ID:93 AC3 2.0 48000 Hz 192 kb/s
2014/02/27 20:26:40.656     >  Video: ID:94 MPEG-2 MP-HL 1920x1080i fps: 30000/1001 AR: 16:9
2014/02/27 20:26:40.901    StreamProc> 'ts' file created, size: 65,536 in 3.51 sec
2014/02/27 20:26:40.902    StreamProc> total time: 3.55 sec
2014/02/27 20:26:40.932    OpenLiveStream> stream path returned to client: \\SPARE1\Public\Recorded TV\TempSWMC\LiveTV_MediaBrowser^0_Digital Cable_1009_2014_02_27_20_26_37.ts
2014/02/27 20:26:40.932    OpenLiveStream> -----------------done-------------------------
2014/02/27 20:26:40.935    Finished request OpenLiveStream in 3.59s
2014/02/27 20:26:42.114    Received client request: MediaBrowser^@MYSERVER-FILESERVE@0|CloseLiveStream
2014/02/27 20:26:42.114    CloseStream> -----------------start------------------------
2014/02/27 20:26:42.115    WtvToPesDemuxer::Parse> Guid header detects stream end
2014/02/27 20:26:42.117    Pass 'mux2ts':
2014/02/27 20:26:42.117     >  WtvToPesDemuxer::Parse> total guid headers processed: 1,398
2014/02/27 20:26:42.117     >  WtvToPesDemuxer::Parse> total data packets processed: 208
2014/02/27 20:26:42.211    Remux> ENDED, >>>>>>>>>> Run Time: 0.03 min <<<<<<<<<<
2014/02/27 20:26:42.219    StreamProc::Close> remux stopped successfully
2014/02/27 20:26:42.219    RecordToWTV::Close> isPassive is False => COM recorder will be stopped
2014/02/27 20:26:42.500    StreamProc::Close> wtv closed successfully
2014/02/27 20:26:42.552    StreamProc::Close> wtv file size: 5,242,880
2014/02/27 20:26:42.568    StreamProc::Close> file deleted: C:\Users\Public\Recorded TV\TempSWMC\LiveTV_MediaBrowser^0_Digital Cable_1009_2014_02_27_20_26_37.wtv
2014/02/27 20:26:42.619    StreamProc::Close> ts file size: 4,521,984
2014/02/27 20:26:42.941    StreamProc::Close> file deleted: C:\Users\Public\Recorded TV\TempSWMC\LiveTV_MediaBrowser^0_Digital Cable_1009_2014_02_27_20_26_37.ts
2014/02/27 20:26:42.941    StreamProc::Close> closed in 0.83 sec
2014/02/27 20:26:42.941    Close> closed stream for client: MediaBrowser^0
2014/02/27 20:26:42.942    CloseStream> -----------------done-------------------------
2014/02/27 20:26:42.942    Finished request CloseLiveStream in 0.83s
2014/02/27 20:26:44.497    Received client request: MediaBrowser^@MYSERVER-FILESERVE@1|OpenLiveStream|15909459
2014/02/27 20:26:44.497    OpenLiveStream> -----------------start------------------------
2014/02/27 20:26:44.497    OpenLiveStream> client: MediaBrowser^ requesting live stream
2014/02/27 20:26:44.498    StreamProc> live-tv started
2014/02/27 20:26:44.664    SetChannel> Tuner: HDHomeRun Prime Tuner 13125DD3-2 / f659b868-820e-422f-9808-9e17cab9f369
2014/02/27 20:26:44.664    SetChannel> > Digital: True
2014/02/27 20:26:44.664    SetChannel> > Encrypted: False
2014/02/27 20:26:44.666    SetChannel> > RecorderInfo found: True
2014/02/27 20:26:44.667    SetChannel > busy: False, client: none
2014/02/27 20:26:44.667    SetChannel> > tuner is available  => stopping search
2014/02/27 20:26:44.668    SetChannel> Recorder Content Protection: PROT_COPY_FREE
2014/02/27 20:26:44.669    SetChannel> Recorder acquired: True
2014/02/27 20:26:44.671    SetChannel> TuneRequest set
2014/02/27 20:26:44.693    StreamProc> wtv recording started in 0.19 sec
2014/02/27 20:26:44.693    StreamProc> stream output file: LiveTV_MediaBrowser^1_Digital Cable_1009_2014_02_27_20_26_44.ts
2014/02/27 20:26:44.747    StreamProc> started remux thread: 'KETVDT-1009: 15909459'
2014/02/27 20:26:44.759    Remux::FindDescriptors> Scanning wtv for streams...
2014/02/27 20:26:46.833    Parse> Guid: 0 took 2.07 sec, it was attempted 696 times
2014/02/27 20:26:46.858    Parse> Encryption guid found, count: 86, stream Id: 101
2014/02/27 20:26:50.675    Parse> Descriptor pass done, using 2001 guids in 3.84 sec
2014/02/27 20:26:50.675    Parse> Unknown Guid summary: 6 instances of 2 unique unknown guids encountered
2014/02/27 20:26:50.675     >  1E BE C3 C5 43 92 DC 11 85 E5 00 12 3F 6F 73 B9 {c5c3be1e-9243-11dc-85e5-00123f6f73b9}
2014/02/27 20:26:50.675     >  F7 10 02 B9 EE 7C ED 4E BD 7F 05 40 35 86 18 A1 {b90210f7-7cee-4eed-bd7f-0540358618a1}
2014/02/27 20:26:50.675    Parse> Total Descriptor parse time: 5.92 sec
2014/02/27 20:26:50.675    Pass 'Descriptor':
2014/02/27 20:26:50.675     >  WtvToPesDemuxer::Parse> total guid headers processed: 2,001
2014/02/27 20:26:50.675     >  WtvToPesDemuxer::Parse> total data packets processed: 433
2014/02/27 20:26:50.680    Remux::FindDescriptors> wtv scanned (5.92 sec), Streams found:
2014/02/27 20:26:50.681     >  Other: ID:100 MS TV Caption
2014/02/27 20:26:50.681     >  Video: ID:101 Unknown
2014/02/27 20:26:50.681     >  Audio: ID:102 AC3 5.1 48000 Hz 384 kb/s
2014/02/27 20:26:50.681     >  Audio: ID:103 AC3 2.0 48000 Hz 192 kb/s
2014/02/27 20:26:50.681     >  Video: ID:104 MPEG-2 MP-HL 1920x1080i fps: 30000/1001 AR: 16:9
2014/02/27 20:26:50.681    Remux::FindDescriptors> Removing 'ID:101 Unknown' for invalid video descriptor
2014/02/27 20:26:50.681    Remux::FindDescriptors> Output streams:
2014/02/27 20:26:50.681     >  Audio: ID:102 AC3 5.1 48000 Hz 384 kb/s
2014/02/27 20:26:50.681     >  Audio: ID:103 AC3 2.0 48000 Hz 192 kb/s
2014/02/27 20:26:50.681     >  Video: ID:104 MPEG-2 MP-HL 1920x1080i fps: 30000/1001 AR: 16:9
2014/02/27 20:26:50.821    StreamProc> 'ts' file created, size: 983,040 in 6.13 sec
2014/02/27 20:26:50.821    StreamProc> total time: 6.32 sec
2014/02/27 20:26:50.847    OpenLiveStream> stream path returned to client: \\SPARE1\Public\Recorded TV\TempSWMC\LiveTV_MediaBrowser^1_Digital Cable_1009_2014_02_27_20_26_44.ts
2014/02/27 20:26:50.847    OpenLiveStream> -----------------done-------------------------
2014/02/27 20:26:50.849    Finished request OpenLiveStream in 6.35s
2014/02/27 20:28:05.967    MaintenanceTimer> callback at 8:28 PM
2014/02/27 20:28:05.968    MaintenanceTimer> callback - complete
 

Link to post
Share on other sites

i got this similar problem till i changed the Transcode folder in MBs to a UNC path and i made sure the UNC folder i set in ServerWMC had the Everyone Full access in the share permissions and Advanced sharing

 

I don't quite follow what you did here. On the server, Under Advanced > Transcoding, you forced a temporary path as a UNC shared path?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...