Jump to content

share url incorrect because of apache reverse proxy


cTurtle98
 Share

Go to solution Solved by dcrdev,

Recommended Posts

hello so I have both a web server and emby running on the same network with one public IP so I have emby running through a reverse proxy to put it on a subdomain of my url

in the share links emby generates a url as if it were the only thing on my network to be used for sharing

if I try to tell it what url its on through the public url box it breaks the reverse proxy because then emby tries to bind to that.

could you add a feature where you can tell emby what url its running at so that share urls work without it trying to bind to it incase you have something else managing that?

 

also in the near future I will be building a server good enough to have both emby and my apache web server on the same machine (this machine also has zoneminer on it) so emby will have to be runnning on a different port from 80 because apache will be already be using it so the share urls will really be messed up then unless there is someway for me to tell emby that it is running on media.98seaturtles.net but just tell it to use that for self identification but actually run on localhost:8080 so I can use apache to deal with the subdomain

 

if you have any advice it would be greatly appreciated

Link to comment
Share on other sites

  • Solution

hello so I have both a web server and emby running on the same network with one public IP so I have emby running through a reverse proxy to put it on a subdomain of my url

in the share links emby generates a url as if it were the only thing on my network to be used for sharing

if I try to tell it what url its on through the public url box it breaks the reverse proxy because then emby tries to bind to that.

could you add a feature where you can tell emby what url its running at so that share urls work without it trying to bind to it incase you have something else managing that?

 

also in the near future I will be building a server good enough to have both emby and my apache web server on the same machine (this machine also has zoneminer on it) so emby will have to be runnning on a different port from 80 because apache will be already be using it so the share urls will really be messed up then unless there is someway for me to tell emby that it is running on media.98seaturtles.net but just tell it to use that for self identification but actually run on localhost:8080 so I can use apache to deal with the subdomain

 

if you have any advice it would be greatly appreciated

 

Your configuration is likely wrong - works for me.

 

It sounds like you may be trying to add your subdomain to the "local network address box" - don't do that, instead change the "External domain:" box to that of your subdomain. Also change your public http port to 80 and your public https port to 443.

 

If that doesn't work your reverse proxy configuration is wrong, probably not sending the correct referring domain.

  • Like 1
Link to comment
Share on other sites

^ You don't want the local port to be 80 and 443 otherwise that will interfere with Apache.

 

Most likely the next time you restart emby server it will fail to start.

 

Your proxy should listen on 80 and 443, emby should run on ports inaccessible from the outside world i.e. the defaults 8096/8920.

 

Like this:

59adc8236602c_Screenshot_20170904_223842

Edited by dcrdev
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...