Jump to content

"Server stopped" after Installation Version 3.2.26.0-1


liandenis
 Share

Go to solution Solved by solabc16,

Recommended Posts

liandenis

Hello,

 

i just installed Emby Server 3.2.26.0-1 on my Synology DiskStation. As i wanted to start the Server i became the answer "The package task could not be executed". So the Server is still down. Can somebody help?

 

cheers,

 

Denis

Link to comment
Share on other sites

solabc16

Hello @@liandenis

 

Was this an upgrade from a previous release or a new install? Release 3.2.30.0 is now available, if you haven't picked it up already.

 

If you still have the problem and are able, please can you send the support logs using the guide here: https://github.com/MediaBrowser/Wiki/wiki/Synology-:-How-to-Send-us-Support-Logs

 

Best

- James

Edited by solabc16
Link to comment
Share on other sites

liandenis

Here are my requirements:

 

1. 4 CPUs x Intel® Xeon® CPU E3-1225 V2 @ 3.20GHz

2. DS3617xs (virtual)
3. DSM Version: DSM 6.1.3-15152 Update 3
4. Emby Server Version: 3.2.30.0-1
5. Open VM TOOLS: open-vm-tools_bromolow-6.0_10.0.7-1.spk
Link to comment
Share on other sites

solabc16

Hi Liandenis

 

That looks right, had you configured that from the very first install? The problem you are facing is that detailed here (https://emby.media/community/index.php?/topic/40411-xpenology-users-read-me/) and here (https://github.com/MediaBrowser/Wiki/wiki/Synology-:-Custom-Package-Architectures-for-XPEnology).

 

The Intel® Xeon® CPU E3-1225 V2 @ 3.20GHz should support all of the processor features our default architecture (nehalem) targets. (https://en.wikipedia.org/wiki/List_of_Intel_Xeon_microprocessors#.22Sandy_Bridge.22_.2832_nm.29)

 

Best

- James

Edited by solabc16
Link to comment
Share on other sites

liandenis

Hi James,

 

I've already read all this, but I havn't understood it. I just can't get to the solution.

 

I thank you very much to here

 

greets,

Denis

Link to comment
Share on other sites

solabc16

Hi Denis

 

The problem appears to be that we're trying to use instructions that should be available on your CPU, but for some reason they are not available.

 

Can you try the following:-

  • Uninstall the package you currently have installed.
  • Change the Package Center URL for Emby LLC to

     https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-core2
  • Restart your NAS
  • Install the Emby Server package again.
Let me know how you get on...

 

Best

- James

Edited by solabc16
Link to comment
Share on other sites

xpeno3617

I am on DS3617xs (Virtual ESXi) and Emby is not working?

Droping DS3617 for DS3615 do no make Emby work on DS3617...

 
Strange?? For me to get the "emby" package available in Package Center, I need to put in package source "https://synology.emby.media"
instead:
 
Regular  - https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586
AMD      - https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-barcelona
Core 2   - https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-core2
 xpen-core2-sse41[/size]    - https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-core2-sse41
 xpen-sandybridge   [/size]https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-sandybridge
 
-------------------->> Emby not working: "Failed to run package service."
 
Config:[/size]
- 4 CPUs x Intel® Xeon® D-1527        ------------ True CPU: Xeon X5690 @ 3.46GHz
- DS3617xs (virtual Exsi) with16Go RAM
- DSM Version: DSM 6.1.3-15152 Update 3
- Emby Server Version: 3.2.30.0-1
 
I did diagnostics : https://github.com/MediaBrowser/Wiki/wiki/Synology-:-How-to-Run-Diagnostics
And go the same result as user Liandenis.

 

And it work perfectly on my DS3615xs Xpenology, Emby work perfectly. But the DS3615 is on DSM 6.0.2-8451 Update 9

 

I might be wrong but seem that Emby have issue to work on a 4 core Xeon?

I am planning to have Emby onto DS3617 because it have 4 core so very very useful for video re-encoding... if that issue can be solve I will be very very happy

 

Thank you

Link to comment
Share on other sites

solabc16

Hello @@xpeno3617

 

Thanks for getting in touch, here's what I believe is happening....

 

- The original XPEnology solution emulated the DS3615xs platform, so reported its architecture as 'Bromolow'.

- I suspect the virtual DS3617xs will be reporting its architecture as 'Broadwell'.

- All of the current Emby Server builds for XPEnology target the original virtual NAS solution, i.e. 'Bromolow'.

- The package will show up when you use the default package source URL, but the package will target the 'real' DS3617xs h/w.

- Depending on CPU feature compatibility this may or may not work, in your case not.

- The specific issue here, is that your CPU does not support AVX, see below:-

"Broadwell-DE" (14 nm)
MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, AVX, F16C

"Westmere-EP" (32 nm) Efficient Performance
MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2

I'll start looking at updating our XPEnology support to cover the Broadwell architecture based virtual NAS platforms as well, that will resolve the issue.

 

Best

- James

  • Like 1
Link to comment
Share on other sites

xpeno3617

Thank @@James

Thank you for your quick answer.

And cross finger that the DS3617 will be soon supported by Emby.

Emby work so well for me that I advertise and recommend to all my friends

 

Forgot to precise:

- Both Xpenology DS315xs (Intel Core i3-4130 with 8Gb) and DS3617xs (Intel Xeon D-1527 with 16GB) are both VM Xpenology in a Dell R710 dual Xeon X5690 @ 3.46GHz

- Emby is working on DS3615

- So keeping both Xpenology VM but Emby should benefit of the 4 core of DS3617 for transcoding.

 

Thank

Link to comment
Share on other sites

  • Solution
solabc16

Hello @xpeno3617

 

Thanks for the feedback and support. I've re-released Emby Server 3.2.30.0 for XPEnology with support for the 'broadwell' architecture.

 

If you currently have Emby Server installed, please uninstall it first.

 

Then configure Package Center as detailed in https://emby.media/community/index.php?/topic/40411-xpenology-users-read-me/?p=377703, Emby Server should now appear.

 

I will look at adding an optimised build for the 'westmere' processor architecture in the coming weeks.

 

Do let me know how you get on...

 

Best

- James

  • Like 1
Link to comment
Share on other sites

xpeno3617

Hi @@solabc16 (James)

 

My hate down for the support!! And on this issue.

It is not everyday I say it but: OMG! That was done quickly. Maybe it was a random coincidence BUT from the issue identified and solution solution. From customer view (my view) it was like a half day!

 

Your dedication and support for Emby for Xpenology is a exemplary.

 

THANK YOU James!

 

- Device: DS3617xs Intel Xeon D-1527   -  Xpenology DSM 6.1.3

- Emby showed up in package manager with default path

- Install done successfully

- Folder and user embysvr ---> OK

- Scan a little folder (Library)  --> OK

- Play from client OK

 

Thank again

Edited by xpeno3617
Link to comment
Share on other sites

solabc16

Hello @@xpeno3617

 

You're welcome, glad we've got you up and running. Getting this up and running for the 'broadwell' based XPEnology systems I'm sure will be of benefit to the wider community as well.

 

I've discussed Synology/XPEnology in a number of places, fundamentally the combination of Intel h/w + XPEnology + Emby Server makes a very good and easy to maintain 'HTPC'.

 

As promised, there is now an optimised build for 'westmere' based Intel processors available. (see https://github.com/MediaBrowser/Wiki/wiki/Synology-:-Custom-Package-Architectures-for-XPEnology)

 

If you haven't configured your system yet, the quickest way to update would be to change your Package Center URL to that shown below, then uninstall and reinstall Emby Server.

https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586&package_architecture=xpen-westmere

Best

- James

  • Like 1
Link to comment
Share on other sites

xpeno3617

Thamk You @solabc15,

 

Emby is working as expected on my Xpenology.

The DS3617 is still in test for me so did have some issue in the beginning but since the system is settle down, Emby is working wonderfully.

 

I don't know if need to open a new "Topic"

The only little glitch it is Emby is unable to "Application updates" or "Plugin updates". 

And no "plugin updates" mean unable to access to plugin section to install.

 

But that is not a big concern for me right now. My library seem working flawlessly.

Everything work as expected on my DS3615xs Xpenology with DSM 6.1.3-15152 Update 4.

 

Thank you

Link to comment
Share on other sites

solabc16

Hello @@xpeno3617

 

It's unlikely there is anything platform specific regarding the above, so it would be best to start a new topic.

 

If you could include some screenshots/examples of the problem, that would help.

 

Glad to hear you're making good progress...

 

Best

- James

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...