Jump to content

Roku and Windows Firewall


Go to solution Solved by ruoccop,

Recommended Posts

Hi.

 

I'm new to Emby and trying to make it work with the Roku 3.

 

It is working when I switch off Windows Firewall, but not when it is on.

 

I've opened up the port with an inbound rule, but I still get nothing on Roku.

 

Anyone able to give me any assistance?

 

Thanks

 

 

 

Link to post
Share on other sites

So there are two ports, one is insecure (normally 8096) and the other is secure (normally 8920). Did you unblock both on your windows firewall?

 

Also, the app may be connecting you through Emby connect which would mean that your connection is going out to the Internet and then back to your local LAN. My assumption at this point is that you already have the port opened on your firewall and forwarded to your Emby server's reserved or statically assigned IP address as it works when windows firewall is off.

 

There is another setting in your inbound rule for your Emby ports titled allow edge traversal (or something like that) that will need to be enabled. This setting allows devices that come from different IP subnets than your server's local LAN (ex: the public Internet).

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

Yeah. Both ports have incoming rules.

 

The Connection Troubleshooter was already my starting point, but alas, no success.

 

At this point I am not going outside of my LAN, but I did Port Forward from the router whilst experimenting.
 

As I mentioned, I can access fine when Windows Firewall is off.

 

it's very strange.

Link to post
Share on other sites

I'm not sure what you mean by tests, so following the web page set up...

 

Test on a web browser on a different device on my home network:
- Only works when Windows Firewall is switched off

Antivirus scan - found nothing

External Connections - which I don't care about right now, but -
 

Canyouseeme.org - This did not find it - but my guess is that this is because I am installing Emby on a laptop which is not my main server.

Link to post
Share on other sites
Happy2Play

There is something broke in your firewall rules then if no other device can access the server.

 

Personally I would unistall Emby, delete the firewall rules, then re-install Emby.

Link to post
Share on other sites

I don't think you need to reinstall. Check windows firewall to make sure there are no rules blocking the server .exe file.

Link to post
Share on other sites
  • Solution

Okay. Finally figured this out.

 

My home network appears to have been changed to 'Public' (it should be Private, of course).

 

Since I only selected the 'Private' settings for the Windows Firewall access, the Emby-created Firewall rule was inadequate.

 

Thanks for your help guys.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...