Jump to content

error downloading subtitles opensubtitle


tomdh76
 Share

Recommended Posts

tomdh76

Hello,

Emby on my synology version 3.2.26.0 does not download subtitles from opensubtitle. It seems like an error in permissions. I have however changed permissions on the folders using 0777 and also the emby user has read and write permissions.

 

This is part of the log:

 

2017-08-26 15:02:20.1011 Error App: Error downloading subtitles
    *** Error Report ***
    Version: 3.2.26.0
    Command line: /var/packages/EmbyServer/target/server/MediaBrowser.Server.Mono.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartpath /var/packages/EmbyServer/scripts/restart
    Operating system: Unix 3.10.102.0
    64-Bit OS: True
    64-Bit Process: True
    Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Sat Apr 22 20:18:08 CST 2017)
    Processor count: 4
    Program data path: /var/packages/EmbyServer/target/var
    Application directory: /volume1/@appstore/EmbyServer/releases/v3.2.26.0
    System.UnauthorizedAccessException: Access to the path "/volume1/Films/Ghost in the Shell (2017)/Ghost in the Shell (2017) Bluray-1080p.dut.srt" is denied.
     at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.Boolean anonymous, System.IO.FileOptions options) [0x0025f] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0
     at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.IO.FileOptions options) [0x00000] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0
     at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare,int,System.IO.FileOptions)
     at Emby.Common.Implementations.IO.ManagedFileSystem.GetFileStream (System.String path, MediaBrowser.Model.IO.FileOpenMode mode, MediaBrowser.Model.IO.FileAccessMode access, MediaBrowser.Model.IO.FileShareMode share, MediaBrowser.Model.IO.FileOpenOptions fileOpenOptions) [0x00045] in <c0b17ba779b144e891439898017fa679>:0
     at Emby.Common.Implementations.IO.ManagedFileSystem.GetFileStream (System.String path, MediaBrowser.Model.IO.FileOpenMode mode, MediaBrowser.Model.IO.FileAccessMode access, MediaBrowser.Model.IO.FileShareMode share, System.Boolean isAsync) [0x0002a] in <c0b17ba779b144e891439898017fa679>:0
     at MediaBrowser.Providers.Subtitles.SubtitleManager+<DownloadSubtitles>d__15.MoveNext () [0x001d6] in <0b6f2305b6f44b8b8bfc04d7888a353e>:0 

Link to comment
Share on other sites

hi @@tomdh76, I believe you that you did, nonetheless Emby still does not have permission to save to the folder, so that's something you'll need to resolve in order for this feature to work. Thanks !

Link to comment
Share on other sites

tomdh76

Thx Luke, I checked again and found that i did not check the checkbox: "Set group, owner and permissions recursively" and it now works!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...