Jump to content

Watched status not syncing anymore


linds1234
 Share

Recommended Posts

Are you saying when you start Kodi, the watch status don't update? Or are you saying while Kodi is running, the watch status does not update?

Link to comment
Share on other sites

Hi @@Angelblue05,

 

I have 2 Kodi boxes..

 

If I watch something on Box #1, the watched/play-state updates locally on that box, this then gets sent to the Emby server all OK.

 

If I then load Box #2, it will pull down any new show/movie updates, but the play state of what has just been watched on Box #1 is not reflected.

 

When I did all the resetting on both boxes that i mentioned previously, it was working flawlessly for a few hours. Even when both Kodi boxes were on (updates came in "live"). I suspect a change in 3.2.27 is the culprit.

Link to comment
Share on other sites

Ok, try the following: In the add-on settings > sync options > Disable fast sync. That should do the trick, it's a little slower than the fast sync but it will pick up on those updates. I'm not sure why the plugin is suddenly throwing an error. In the works, the fast sync is being replaced, but I need a bit of time to get it done. (However, the plugin should still be working until then...)

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Does that mean it will bypass the Emby.Kodi Sync Queue plugin on the server entirely?

  • Like 1
Link to comment
Share on other sites

Will give it a shot tonight, thanks. 

 

Curiously is it not a setting that can be fixed/reverted in Emby server itself? Or is it something that needs to go forward on the server end and the plugins way of doing it is simply outdated?

Link to comment
Share on other sites

@@Angelblue05

 

All working with fast sync turned off. 34s to sync vs ~4s  :(

 

Time to visit Pledgie to encourage that updated FastSync plugin work  ;)

  • Like 1
Link to comment
Share on other sites

No. Thank you for your patience. Don't worry this is only a temporary solution. And the fast sync plugin should still be working for everyone (at least it still is for me on windows). But in linds1234' situation, the plugin is throwing an error on mono.

 

What is your server platform @@mireki1975

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

@@Angelblue05

 

Do you think it would make a difference if I ran Kodi 17 instead of 16.1? I'm guessing the Emby Kodi addon is probably coded the same for Kodi 17 but just thought I'd double-check.

Link to comment
Share on other sites

Same problem here.  Watched status not syncing anymore. Server: 3.2.28.0 Plugin: 1.4.6362.2868. I've got a big collection. so disabling fast startup is not an option. (its taking over a minute to sync server status without plugin)

Link to comment
Share on other sites

@@Luke

Do you know why this happened? Also, did you get a chance to add the rest of what we discussed so I can replace the fast sync completely?

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

I'll get an update to the plugin out, thanks.

Thank you Luke. Always on top of things. :)

 

@others Once this is done, you can re-enable the fast sync option in the add-on settings. Everything will be back to normal then. Keep me posted.

Link to comment
Share on other sites

I pushed the plugin update. It requires the latest beta server. If you don't run the beta server that's OK, you'll get the plugin update after the next stable release. Thanks.

  • Like 2
Link to comment
Share on other sites

My watched status is also not syncing, but I think I have a different problem. I'm using Kodi 17.4 and Emby plugin 2.3.51. After upgrading to 2.3.51 (not sure what version I was using before), I'm getting a login error and watched status is not syncing. The error summary is "User does not have admin access." and the full log is here: https://pastebin.com/W6eeg6kW

 

I have tried turning off fast sync and adding a startup delay but neither has had any affect. Any idea what is happening?

Link to comment
Share on other sites

I have release the update already (2.3.51). It just catches the error and disables series pooling in Kodi. There should be nothing else different. Can you post your Kodi log?

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

Thank you. I think I see the problem.

 

Edit: Try version 2.3.52. Let me know if it resolves this. Thank you.

Edited by Angelblue05
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...