Jump to content


Photo

Emby on ReadNAS -


  • Please log in to reply
3 replies to this topic

#1 Keldraxas OFFLINE  

Keldraxas

    Newbie

  • Members
  • 2 posts
  • Local time: 03:53 PM

Posted 25 July 2017 - 03:52 PM

Hi all,

 

There are quite a few posts on this forum with people asking for support for ReadyNAS, and a few replies saying there are already .deb files / cryptic clues on what you might have to do to get it working. As most of these are over 1-2 years old I thought I'd give it a go and see where I got up to.

 

I'm by no means an expert. I've worked in IT for quite some time but when it comes to Linux am definitely a novice.

 

Anyway - I have a ReadyNAS 314, running firmware 6.7.5. Having researched this appears to be a version of Debian Wheezy, with kernel 4.4.

 

Starting from here I found a post that said there was a .deb file to install so went here - https://software.ope...age=emby-server

 

Debian Wheezy is apparently Debian Version 7, so I tried that:

 

 

echo 'deb http://download.open...mby/Debian_7.0/ /' > /etc/apt/sources.list.d/emby-server.list 

apt-get update
apt-get install emby-server

 

This told me I require Mono

 

https://emby.media/c...tgear-readynas/  confirmed that mono is required.

 

So I looked up adding mono to ReadyNAS which led me here - https://community.ne...ono/td-p/989615

 

 

apt-get update

apt-get -y install apt-transport-https sudo nano git-core python python-software-properties software-properties-common
 
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono...com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
 
sudo apt-get update
sudo apt-get -y install mono-devel

 

This failed as it said various mono dependencies were missing.

 

Looking up one of those found - https://forums.sonar...libmono/14685/4

 

 

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

echo "deb http://download.mono...om/repo/debian2 jessie main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
echo "deb http://download.mono...om/repo/debian2 wheezy-apache24-compat main" | sudo tee -a /etc/apt/sources.list.d/mono-xamarin.list
echo "deb http://download.mono...om/repo/debian2 wheezy-libjpeg62-compat main" | sudo tee -a /etc/apt/sources.list.d/mono-xamarin.list
sudo apt-get update
Next do:
 
apt-get remove mono*
then do:
 
apt-get clean
apt-get autoclean
apt-get update
Next, do
 
sudo apt-get install mono-devel

 

At the end of this mono was installed (hurrah!). So I went back to the first step - https://software.ope...age=emby-server

 

And tried Debian Version 7 again

 

echo 'deb http://download.open...mby/Debian_7.0/ /' > /etc/apt/sources.list.d/emby-server.list 

apt-get update
apt-get install emby-server

 

Sadly this failed as while I now have mono, I have an old version.

 

The following packages have unmet dependencies:

 emby-server : 
               Depends: embymagick but it is not going to be installed
               Depends: mono-devel (>= 4.6) but 4.2.1.102+dfsg2-6 is to be installed
E: Unable to correct problems, you have held broken packages.
 

 

This is where I've managed to get to. I feel it's closer than previous posts and was wondering if anyone else can take it up from here or offer further advice?


  • MoonSire likes this

#2 Jdiesel OFFLINE  

Jdiesel

    Advanced Member

  • Members
  • 2936 posts
  • Local time: 08:53 AM
  • LocationRegina, SK

Posted 25 July 2017 - 03:58 PM

Mono and its dependencies can be a pain sometimes. I suggest trying to install mono-complete instead 

apt-get install mono-complete

Either that or maybe look into running Emby in Docker if Docker is available on ReadyNAS.


Edited by Jdiesel, 25 July 2017 - 04:00 PM.


#3 MoonSire OFFLINE  

MoonSire

    Newbie

  • Members
  • 1 posts
  • Local time: 04:53 PM

Posted 29 July 2017 - 11:10 AM

I had the same problem when upgrading my ReadyNAS from 6.1.? to 6.7.4.

 

I thought I had written down what I did to solve it, but I can't find where... I remember adding the official mono repository from this page http://www.mono-proj...load-lin-debian

 

Then I did

apt-get install mono-complete

 

if I remember correctly I had problems with apt still wanting to install from the ReadyNAS repository so I either changed the priority of the Mono repository or managed to force it to install from the Mono repository in some other way.

 

I had these pages in my browser history (together with alot of others on the same subject) 

https://askubuntu.co...ific-repository

https://askubuntu.co...ocal-repository

which might have something to do with it :)

 

Good luck!



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157196 posts
  • Local time: 10:53 AM

Posted 08 August 2017 - 03:33 PM

@Jdiesel

@MoonSire

@Keldraxas

 

We're please to announce Emby for NetGear ReadyNAS is now available for testing:

 

https://emby.media/c...etgear-readynas

 

Please try it out and report your experience. Thanks and enjoy.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users