Jump to content

Show Intro Skip Option (Plugin)


Liquidfire88

Recommended Posts

samuelqwe
17 minutes ago, crusher11 said:

The core is disabled in my setup. 

I was replying to Cheese who quoted one of my comments from a few days ago, sorry for the confusion.

Link to comment
Share on other sites

VirulentPip

Not sure what I am doing wrong. I reinstalled the server (restored from back-up) started Plug-in tasks all over again, title sequence is in the chapters but nothing appears, I am supposed to see a button right that's how this works?

 

Screenshot 2022-06-25 072929.png

Screenshot 2022-06-25 073040.png

Screenshot 2022-06-25 073351.png

Link to comment
Share on other sites

rbjtech
2 hours ago, VirulentPip said:

Not sure what I am doing wrong. I reinstalled the server (restored from back-up) started Plug-in tasks all over again, title sequence is in the chapters but nothing appears, I am supposed to see a button right that's how this works?

 

Screenshot 2022-06-25 072929.png

Screenshot 2022-06-25 073040.png

Screenshot 2022-06-25 073351.png

What emby server version are you running ? 

I don't *think* this will make any difference, but why are there no  thumbnail images ?  I presume you ran the Chapters task (below) - can you also check the Enable Image Extraction slider ?

This all definitely still works (on 4.8.0.3 beta) as I use it everyday and the manual button shows for me where I have not turned on Auto Skip.

If you turn on debug logging - after the chapter task has run - you will see the markers being inserted - look for 'MarkerType = IntroStart' and 'MarkerType = IntroEnd' - if they exist - then the button should appear.  See below as an example.

2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: TV Show: WeCrashed - Season 1
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Getting Chapter Info for 2: WeMoved
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Title Sequence Starts at 00:00:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters:  Starts at 00:00:00 with MarkerType = IntroStart
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 2 Starts at 00:01:02 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 2 Starts at 00:01:02 with MarkerType = IntroEnd
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 3 Starts at 00:10:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 4 Starts at 00:15:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 5 Starts at 00:20:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 6 Starts at 00:25:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 7 Starts at 00:30:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 8 Starts at 00:35:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 9 Starts at 00:40:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 10 Starts at 00:45:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: Chapter 11 Starts at 00:50:00 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters: End Credits Starts at 00:50:21 with MarkerType = Chapter
2022-06-25 09:52:19.160 Debug Intro Skip:Chapters: Fetch Existing Chapters:  Starts at 00:50:21 with MarkerType = CreditsStart

 

image.png.b87b039eefb7547128d896a28f81ab4d.png

Edited by rbjtech
Link to comment
Share on other sites

VirulentPip

Server Windows (11) - 4.8.0.3 Beta
image.png.a28f0a0ed4748146b45ad47a640d14e2.png

image.png.1c8b8ce43eaa685cd9b53c7acca2c9a0.png

Edited by VirulentPip
  • Like 1
Link to comment
Share on other sites

rbjtech

ok - so looks perfect - er... it should show the button !

Does it show the button for ANY show or none at all - I'm wondering if it's browser related ?

Link to comment
Share on other sites

Cheesegeezer
2 minutes ago, VirulentPip said:

Server Windows (11) - 4.8.0.3 Beta


image.png.1c8b8ce43eaa685cd9b53c7acca2c9a0.png

Everything looks perfect chief. 
 

the button that appears is what the core has kindly added from their side however it is a premiere feature. Are you a premium member? This is the only reason i can see why the buttons dont show. 
 

@Luke @samuelqwe sorry i must have misinterpreted what you said in your post. 👍👍

  • Like 1
  • Agree 1
Link to comment
Share on other sites

VirulentPip

Premier member indeed, so I need to enable intro on the app settings? But what about ones that don't have that feature? I thought the Plugin was independent and incorporated it's own button. 🤔

Edit - Okay so if I enable "Show Skip Intro" button in the app settings one does indeed appear. So do I have to wait till my other clients are updated to be supported by core for this? I am so confused. 

Also yeah why don't my chapters have images?

Edited by VirulentPip
Link to comment
Share on other sites

Cheesegeezer
2 minutes ago, VirulentPip said:

Premier member indeed, so I need to enable intro on the app settings? But what about ones that don't have that feature?

You don’t need to enable introskip from core, but there may be a slider you need to enable to show buttons. Can’t think where. @rbjtech can you remember 

2 minutes ago, VirulentPip said:

I thought the Plugin was independent and incorporated it's own button. 🤔

It is independent, but we don’t have access to any core components so the only way Chef could utilise the markers was to add an autoskip feature, we never have been able to display buttons.

Link to comment
Share on other sites

VirulentPip
11 minutes ago, Cheesegeezer said:

You don’t need to enable introskip from core, but there may be a slider you need to enable to show buttons. Can’t think where. @rbjtech can you remember 

It is independent, but we don’t have access to any core components so the only way Chef could utilise the markers was to add an autoskip feature, we never have been able to display buttons.


Okay thanks.

Now another issue, AutoSkip works on my Nvidia Shield (non Beta) however not if the "Intro" scene is at the start is there some sort of minimum threshold? It comes up with the message the skip has happened but doesn't actually skip. 

Edited by VirulentPip
Link to comment
Share on other sites

rbjtech
12 minutes ago, Cheesegeezer said:

You don’t need to enable introskip from core, but there may be a slider you need to enable to show buttons. Can’t think where. @rbjtech can you remember

 

Right - sorry, I thought that was a browser in your screen shot - but I guess not..

Yes, the clients a) need to have this feature included (not all do, you probably need to use Beta clients if they do) and b) it needs to be turned on in the client as it's a 'per user' setting.

In this hybrid state of having both the Plugin and Core (for the button only) it's a little messy we agree - but once the Core catch's up with the Plugin - then things should get easier to setup and use ...

This is the current state of play of what each version can and and cannot do ..

https://github.com/chefbennyj1/Emby.IntroSkip.Release/wiki/Feature-List-Plugin-vs-Core

Edited by rbjtech
  • Thanks 1
Link to comment
Share on other sites

Cheesegeezer
2 minutes ago, VirulentPip said:


Okay thanks.

Now another issue, AutoSkip works on my Nvidia Shield (non Beta) however not if the "Intro" scene is at the start is there some sort of minimum threshold? It comes up with the message the skip has happened but doesn't actually skip. 

Have you enable autoskip for users. Dropdown box at the bottom
my power is out at the minute so can’t show you any screenshots.

Link to comment
Share on other sites

rbjtech
2 minutes ago, VirulentPip said:


Okay thanks.

Now another issue, AutoSkip works on my Nvidia Shield (non Beta) however not if the "Intro" scene is at the start is there some sort of minimum threshold? It comes up with the message the skip has happened but doesn't actually skip. 

ok - interesting - we did see some evidence of this during the Plugin testing many months ago - it's due to the latency of the show starting vs the instruction to 'skip' (it happens too late so it gets ignored..).

What show - as I may be able to test this myself.

Link to comment
Share on other sites

VirulentPip
1 minute ago, rbjtech said:

ok - interesting - we did see some evidence of this during the Plugin testing many months ago - it's due to the latency of the show starting vs the instruction to 'skip' (it happens too late so it gets ignored..).

What show - as I may be able to test this myself.


911 Lone Star - Has some sort of crappy "Also on our network" thing that lasts for 16 seconds. For some reason loading is taking around 5 seconds, so If I put the intro start at 6 it will skip properly but I have to watch 6 seconds once it's loaded.. No idea why it takes so long - All wired up local network. 

Link to comment
Share on other sites

rbjtech
3 minutes ago, VirulentPip said:


911 Lone Star - Has some sort of crappy "Also on our network" thing that lasts for 16 seconds. For some reason loading is taking around 5 seconds, so If I put the intro start at 6 it will skip properly but I have to watch 6 seconds once it's loaded.. No idea why it takes so long - All wired up local network. 

ok - so that's the issue then.  I'm pretty certain we added a small delay (maybe a second) for this very reason - but if it's taking 6 seconds to load, then there is not a lot Introskip can do about that as the plugin is telling the session manager to 'skip' the Intro but it's not yet listening because playback has not started.  The manual button should appear though once it starts ?  

Maybe raise in the AndroidTV thread why it's taking so long to start - it may be transcoding or something but it shouldn't be taking that long ...

Link to comment
Share on other sites

VirulentPip
6 minutes ago, rbjtech said:

ok - so that's the issue then.  I'm pretty certain we added a small delay (maybe a second) for this very reason - but if it's taking 6 seconds to load, then there is not a lot Introskip can do about that as the plugin is telling the session manager to 'skip' the Intro but it's not yet listening because playback has not started.  The manual button should appear though once it starts ?  

Maybe raise in the AndroidTV thread why it's taking so long to start - it may be transcoding or something but it shouldn't be taking that long ...


Yep will do, I figured out what is causing it and will open a thread - It's Refresh Rate switching which is causing the delay. 

Thanks for the assist in figuring that out, although any idea why my chapters are "blank" - Or is that an issue to open up elswhere?

Link to comment
Share on other sites

rbjtech
7 minutes ago, VirulentPip said:


Yep will do, I figured out what is causing it and will open a thread - It's Refresh Rate switching which is causing the delay. 

Thanks for the assist in figuring that out, although any idea why my chapters are "blank" - Or is that an issue to open up elswhere?

image.png.0ddad8a76ad09f398905b72045756504.png

In the TV Series library - ensure you have Thumbnails enabled ?

If you've never had this turned on - it will take a while to initially create them !

After which, the Plugin 'create chapters' task (just re-run it) will then create accurate thumbails for the exact Title Sequence/End Credit locations .. :)

  • Thanks 1
Link to comment
Share on other sites

VirulentPip

Sorting that now thanks @rbjtech :)

Interesting fact, the latest Android TV Beta still loads slow with refresh rate switch on, however doesn't try to skip until it's loaded. 

  • Thanks 1
Link to comment
Share on other sites

fillidill

I've been using this plugin for a while and it works great most of the time. Love it! :Title sequence and end credit sequence are added perfectly to my shows. The intro skip button shows and works just as expected.

The only part that is not working is below:

Quote

Credit Markers
For Credits - you will see the 'Next Up' on screen display (OSD) appear on the detection point from the Plugin. ie if the credits started at 3 mins from the end, then you can manually skip to the next episode without having to wait for the standard 30 second 'Next Up' OSD to appear :)

 

I am using server version 4.7.5.0 and the browser version of emby (but it is the same for all clients I've tried). Even though the end credit sequence is detected and inserted as a chapter it is not showing the next episode prompt earlier than the default 30 seconds before the end of the episode. What can I do to troubleshoot this?

  • Thanks 1
Link to comment
Share on other sites

Cheesegeezer
1 hour ago, fillidill said:

I've been using this plugin for a while and it works great most of the time. Love it! :Title sequence and end credit sequence are added perfectly to my shows. The intro skip button shows and works just as expected.

The only part that is not working is below:

 

I am using server version 4.7.5.0 and the browser version of emby (but it is the same for all clients I've tried). Even though the end credit sequence is detected and inserted as a chapter it is not showing the next episode prompt earlier than the default 30 seconds before the end of the episode. What can I do to troubleshoot this?

Not sure where that quote has come from, but the core team need to implement that feature into the clients.  The only one i know about is the Android Beta, however i guess they are rolling it out to more.

We have no control on the VideoOSD overlays in clients or how they operate.

Cheers 

  • Like 1
Link to comment
Share on other sites

fillidill
51 minutes ago, Cheesegeezer said:

Not sure where that quote has come from, but the core team need to implement that feature into the clients.  The only one i know about is the Android Beta, however i guess they are rolling it out to more.

We have no control on the VideoOSD overlays in clients or how they operate.

Cheers 

Oh, I see, thanks for the fast response! I read it on the wiki on below link and thought it was a available feature.
https://github.com/chefbennyj1/Emby.IntroSkip.Release/wiki/Integration-of-Emby-Introskip-Core-'Skip-Intro'-Button#credit-markers

 

Link to comment
Share on other sites

rbjtech
1 hour ago, fillidill said:

Oh, I see, thanks for the fast response! I read it on the wiki on below link and thought it was a available feature.
https://github.com/chefbennyj1/Emby.IntroSkip.Release/wiki/Integration-of-Emby-Introskip-Core-'Skip-Intro'-Button#credit-markers

 

It is available but has only been implemented in the Android TV beta v 2.0.75+ (FireTV and Shield) thus far -

https://emby.media/community/index.php?/topic/42240-emby-android-tv-release-notes-beta/

2.0.75 (31 May)

  • Remove delayed fade of skip intro button
  • Add official rating to some queries
  • Update translations
  • (future) Recognize end credit marker

This has been been tested by me (2.0.75) and appears to work as designed - thus I added it to the Wiki.  (I have now added a note on the client restriction ;).)

If you are using the above Android TV platform and Beta v 2.0.75+ and this does not work - then please let me know ! 

Edited by rbjtech
  • Like 1
Link to comment
Share on other sites

crusher11

I've just had an entire season of end credit times wiped again.

Link to comment
Share on other sites

52 minutes ago, rbjtech said:

It is available but has only been implemented in the Android TV beta v 2.0.75+ (FireTV and Shield) thus far -

https://emby.media/community/index.php?/topic/42240-emby-android-tv-release-notes-beta/

2.0.75 (31 May)

  • Remove delayed fade of skip intro button
  • Add official rating to some queries
  • Update translations
  • (future) Recognize end credit marker

This has been been tested by me (2.0.75) and appears to work as designed - thus I added it to the Wiki.  (I have now added a note on the client restriction ;).)

If you are using the above Android TV platform and Beta v 2.0.75+ and this does not work - then please let me know ! 

FYI this is now released on the Fire platform.  Google is in review.

  • Like 2
  • Thanks 2
Link to comment
Share on other sites

rbjtech
Just now, ebr said:

FYI this is now released on the Fire platform.  Google is in review.

Great news - thanks for the update Eric.

  • Agree 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...