Jump to content


Photo

How to prevent server computer from sleeping

sleep

  • Please log in to reply
20 replies to this topic

#1 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 16 February 2014 - 06:14 AM

I have my HTPC, which is currently running MB3 server, set to sleep after 45 mins. When using it for WMC, it does not go to sleep. I assume WMC somehow prevents it.

However, when I'm using my Roku, which is in another room, the computer DOES go to sleep, even while I'm watching a movie. Is there some setting in the server dashboard to prevent this?



#2 gcw07 OFFLINE  

gcw07

    Roku Master

  • Members
  • 2505 posts
  • Local time: 10:47 AM
  • LocationOklahoma

Posted 16 February 2014 - 06:48 AM

Not that I know of. I would think the communication with the server would be enough. It sounds like it isn't.



#3 Deihmos OFFLINE  

Deihmos

    Advanced Member

  • Alpha Testers
  • 1091 posts
  • Local time: 10:47 AM
  • LocationNYC

Posted 16 February 2014 - 08:26 AM

The htpc going to sleep while looking at a movie means that you have it enabled to sleep even when sharing media. Change the setting in power options. I



#4 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 16 February 2014 - 02:01 PM

The htpc going to sleep while looking at a movie means that you have it enabled to sleep even when sharing media. Change the setting in power options. I


I think your right, but I wonder why it doesn't sleep when I'm using WMC? I think I had changed the sleep/media sharing setting because the computer was waking from sleep on it's own. I also think I eventually traced that issue to a wake from NIC setting and never changed back the media sharing setting.

I hope changing it back doesn't bring back that issue!

Anyway, thanks.

Sent from my generic not my computer device.

#5 Deihmos OFFLINE  

Deihmos

    Advanced Member

  • Alpha Testers
  • 1091 posts
  • Local time: 10:47 AM
  • LocationNYC

Posted 16 February 2014 - 03:15 PM

Go to device manager and check the power management settings for your network adapter. Make sure it is set to only wake by magic packets

#6 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 16 February 2014 - 04:23 PM

The htpc going to sleep while looking at a movie means that you have it enabled to sleep even when sharing media. Change the setting in power options. I

 

I just checked. "When sharing media" setting is already set to "Prevent idling to sleep". So that's not it. :(



#7 Deihmos OFFLINE  

Deihmos

    Advanced Member

  • Alpha Testers
  • 1091 posts
  • Local time: 10:47 AM
  • LocationNYC

Posted 16 February 2014 - 05:09 PM

you can always check why your pc went to sleep in command prompt or event viewer. The roku isn't accessing your shared media so maybe that is why it still goes to sleep when idle. I will test it when on my roku. Maybe the PC is too fast and transcodes the video quickly.

 

command prompt commands

powercfg lastwake - reports the event that last woke the pc

powercfg /requests - reports what is keeping your pc from entering sleep


Edited by Deihmos, 16 February 2014 - 05:24 PM.


#8 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 17 February 2014 - 03:42 AM

powercfg lastwake - reports the event that last woke the pc

powercfg /requests - reports what is keeping your pc from entering sleep

 

Well, but, it IS going to sleep (while streaming a movie to the Roku), so I don't see how either of those will help in my situation.

Weird no one else seems to be having this issue. Maybe it's not so common to put your computer to sleep? I may have to change the sleep time to two hours. That'll waste electricity and wear on my hard drives though.



#9 trusselo OFFLINE  

trusselo

    Advanced Member

  • Members
  • 483 posts
  • Local time: 09:47 AM
  • LocationEdmonton, Alberta

Posted 17 February 2014 - 04:29 AM

5301c867d5daa_Capture.png

 

or just disable sleep mode all together. it is a server...



#10 Deihmos OFFLINE  

Deihmos

    Advanced Member

  • Alpha Testers
  • 1091 posts
  • Local time: 10:47 AM
  • LocationNYC

Posted 17 February 2014 - 09:17 AM

He wants the pc to sleep. I have my server set to sleep after being idle for 30 minutes and the hard drives will sleep when not active for a specified time. If the pc goes to sleep while streaming to roku you should then check event viewer to see why the pc went to sleep. I don't understand why it would sleep while transcoding a video because the pc wouldn't be idle.

Edited by Deihmos, 17 February 2014 - 09:20 AM.


#11 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 17 February 2014 - 02:05 PM

^ This. Eventually I hope to build a true server that will run 24/7, but for the time being I have to use my HTPC which goes for long periods of not being used each day. Next time I stream a movie from it and it goes to sleep, I will check event viewer.

Sent from my generic not my computer device.

#12 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 20 February 2014 - 05:52 PM

I see ServerWMC has an option for "Prevent computer from sleeping whenever a client is connected" (something to that effect), but it's only for XBMC clients.  :angry:



#13 Koleckai Silvestri OFFLINE  

Koleckai Silvestri

    Advanced Member

  • Alpha Testers
  • 3768 posts
  • Local time: 08:47 AM

Posted 20 February 2014 - 06:19 PM

powercfg lastwake - reports the event that last woke the pc

powercfg /requests - reports what is keeping your pc from entering sleep

 

Well, but, it IS going to sleep (while streaming a movie to the Roku), so I don't see how either of those will help in my situation.

Weird no one else seems to be having this issue. Maybe it's not so common to put your computer to sleep? I may have to change the sleep time to two hours. That'll waste electricity and wear on my hard drives though.

 

 

Increase the sleep timer. The issue is that even with Transcoding, that doesn't occur over the entire video. In my experience the transcoding is done in 30% of the time it takes a video to play. After that the client is just reading .ts files off the server. So the system goes to sleep. 

 

Increasing your sleep timer to two or three hours would prevent this but your device won't sleep much. I actually don't sleep my server/workstation to avoid this problem.

 

The solution could be:

 

The Roku sends a magic packet every XXX seconds. It doesn't support this currently. Or...

 

The MB server tells the OS that it is busy every XXX seconds.


Edited by Wayne Luke, 20 February 2014 - 06:37 PM.


#14 gcw07 OFFLINE  

gcw07

    Roku Master

  • Members
  • 2505 posts
  • Local time: 10:47 AM
  • LocationOklahoma

Posted 21 February 2014 - 01:48 AM

The Roku sends a magic packet every XXX seconds. It doesn't support this currently. Or...

 

The MB server tells the OS that it is busy every XXX seconds.

I'd think it would be a server thing. I mean the Roku is communicating playback progress as it goes so it is in constant (well every 10 seconds) contact with the server. A magic packet to wake something should only be done at the startup of the channel.



#15 pd veeps OFFLINE  

pd veeps

    Advanced Member

  • Members
  • 61 posts
  • Local time: 11:47 AM

Posted 24 February 2014 - 01:44 PM

I'm having the same issue. This morning, my son wanted to watch a show and the roku or my iphone wouldn't wake the server. Usually or in the past it worked. So I manually turned on the pc. Then the pc went to sleep in the middle of him watching a 30 min show. Sleep is set at 30 min which is weird.

#16 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2328 posts
  • Local time: 11:47 PM
  • LocationPerth, Australia

Posted 19 March 2014 - 03:18 AM

Bumping this old thread...

 

Yesterday I had my server running a "Chapter Image extraction" and after a while it went to sleep - seems strange as the CPU usage during that process is quite high.



#17 chipper OFFLINE  

chipper

    Advanced Member

  • Members
  • 32 posts
  • Local time: 03:47 PM

Posted 19 March 2014 - 09:31 AM

I have to agree with the server sleeping.

 

On my server I also have PLEX installed.  I can watch a movie in PLEX without any issues, but the computer will sleep while using MB3 even while watching a movie, playing music, etc.



#18 gcw07 OFFLINE  

gcw07

    Roku Master

  • Members
  • 2505 posts
  • Local time: 10:47 AM
  • LocationOklahoma

Posted 19 March 2014 - 02:07 PM

At this point I think we need to see what the server guys can say about it. Cause yeah that would be annoying to have it sleep mid streaming.

 

@Luke



#19 leebo OFFLINE  

leebo

    Advanced Member

  • Members
  • 256 posts
  • Local time: 08:47 AM

Posted 19 March 2014 - 02:10 PM

I have to agree with the server sleeping.

On my server I also have PLEX installed. I can watch a movie in PLEX without any issues, but the computer will sleep while using MB3 even while watching a movie, playing music, etc.


I guess that was the point I was trying to make. I have no idea how to write code, it just seems to me that there might be some way to put that into MB3. So many other media server programs do it.

I watched paranoia the other night, thank God for cetons my media center and it's wol feature. Had to use it three or four times.

Eventually I'll build a real server and let it run 24/7.

Sent from my generic not my computer device.

#20 chipper OFFLINE  

chipper

    Advanced Member

  • Members
  • 32 posts
  • Local time: 03:47 PM

Posted 19 March 2014 - 05:05 PM

I'm sorry you watched Paranoia - just recently saw it....

 

I installed a ROKU app that will wake up the server by sending the magic packet.  Very easy to use.







Also tagged with one or more of these keywords: sleep

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users