Jump to content


Photo

Connecting to Windows Shared Folders --> CIFS VFS Error 104 & Error 32

CIFS networking samba

  • Please log in to reply
2 replies to this topic

#1 rett448 OFFLINE  

rett448

    Newbie

  • Members
  • 4 posts
  • Local time: 08:04 PM

Posted 29 May 2017 - 03:08 PM

Let me start off by saying while I have a lot of experience with windows server, I am new to Ubuntu/linux, so please forgive me if this is a very easy issue to solve.

 

I am running windows server 2008 R2 on my main server with media stored on several raid arrays and shared via windows file sharing across my network. I also run several virtual machines on this box via hyper-v, one of which is Ubuntu server 16.04 LT (command line only) with Emby Server.  The Ubuntu server connects to several of the windows shared folders via CIFS (attached the FSTAB configuration file) and mounts automatically when the VM boots.

 

I set up the Ubuntu/Emby VM last October and it worked perfectly until I started getting errors about a month ago. Now after the Emby server has been running for a few errors hours my Movies or TV shows all disappear from Emby.  When I open up the Ubuntu server console via hyper-V I get two errors that repeat:

 

 “CIFS VFS: Error -104 sending data on socket to server” and “CIFS VFS: Error -32 sending data on socket to server”

 

There is significant network traffic be directed towards the windows server machine and the Ubuntu virtual server has above average CPU usage. When I reboot the error temporarily disappears but comes back after a few hours later. I tried rolling the VM back to a clean install (circa October 2016) but after installing all the ubuntu/emby updates the problem came back. When I try to run “sudo umount –a” I get several errors saying “target is busy”.  I can manually browse and play all the media files on any of the windows PCs on my network, so I don’t think the issue is on the windows server side.  

It looks like CIFS is getting suck in some sort of loop. Can anyone provide some insight on why this is happening? Let me know if there is additional information I can provide to help debug this.

Attached File  CIFS Erros.png   42.14KB   0 downloads

Attached File  FSTAB.png   23.12KB   2 downloads



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148765 posts
  • Local time: 08:04 PM

Posted 29 May 2017 - 03:26 PM

hi, what do the paths look like that you added in emby library setup?



#3 rett448 OFFLINE  

rett448

    Newbie

  • Members
  • 4 posts
  • Local time: 08:04 PM

Posted 29 May 2017 - 10:27 PM

Luke,

 

Is this what you are looking for?  The file paths have not changed since I originally set up the server in October (prior to when this issue began).  I have created a folder for each "type" of media on the Ubuntu server and those are mapped to the shares on the Windows Server.  Like I said above if I reboot the Ubuntu VM everything works fine for the first few hours, but eventually the shares drop off.  

 

I think this may be a general Ubuntu issue rather than an emby server specific issue.  Unfortunately I am not very proficient with Ubuntu, especially the command line only server, so it is difficult for me to troubleshoot myself.   

 

 

 

 Attached File  Emby Paths.png   367.48KB   1 downloads


Edited by rett448, 29 May 2017 - 10:30 PM.






Also tagged with one or more of these keywords: CIFS, networking, samba

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users