Jump to content


Photo

How to choose audio output device?

audio output device

  • Please log in to reply
36 replies to this topic

#21 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 04:09 AM

Exclusive mode is the device, not parameters. The parameters are set by Windows. As I said, you need to choose that device/card, and bitstream to it. But it needs to be able to decode the audio, and I don't think it has the ability to do that. At least not all of them. Just because it's an internal card/device, doesn't change how the mechanics, work. Bitstreaming isn't exclusive to HDMI. You need to digitally send the audio to the card, and let the card decode it to analog. 



#22 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 04:17 AM

Both MPC-BE and Foobar2000 support WASAPI exclusive mode with my soundcard, playing FLAC and DTSHD.  Yes, the software is decoding but the decoded bits are still "streamed" to the soundcard.  I know the soundcard doesn't decode DTSHD, it doesn't need to.

Attached Files


Edited by lifespeed, 02 February 2019 - 04:22 AM.


#23 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 04:28 AM

Do you have the audio exclusive option enabled?



#24 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 04:35 AM

Do you have the audio exclusive option enabled?

Yes, it is shown in the MPC-BE screenshot.  Foobar2000 lets me do the same thing.  Or maybe you mean windows sound configuration?  The answer is still yes.  I would like to know if MPV supports configuration for exclusive mode.  In the log file it clearly states it is using shared mode.

 

I know exclusive mode works because when I play audio in a web page while another application has the soundcard in exclusive mode the web page audio (or windows sounds for that matter) are not heard.


Edited by lifespeed, 02 February 2019 - 04:37 AM.


#25 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 04:48 AM

I meant in Theater.

 

5c55593b872c7_Snapshot_138.jpg



#26 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 05:06 AM

Darn, I thought that was it (I did not have it checked).  Unfortunately it doesn't work, still in shared mode as you can see below, changes to the windows 48KHz setting instead of the original media 96KHz, and allows web browser sounds to play simultaneously.

 

That checkbox doesn't appear to do anything.

 

[   0.834][v][af] [in] 96000Hz 5.1(side) 6ch s32
[   0.835][v][af] [userspeed] 96000Hz 5.1(side) 6ch s32
[   0.835][v][af] [userspeed] (disabled)
[   0.835][v][af] [convert] 96000Hz 5.1(side) 6ch s32
[   0.835][v][ao] Trying audio driver 'wasapi'
[   0.835][v][ao/wasapi] requested format: 96000 Hz, 5.1(side) channels, s32
[   0.835][d][ao/wasapi] Init wasapi
[   0.835][d][ao/wasapi] Find device ''
[   0.838][v][ao/wasapi] No device specified. Selecting default.
[   0.841][v][ao/wasapi] Selecting device '{edd9b2bc-e144-4577-81ef-ab33074e02aa}' (Speakers (ASUS Essence STX II Audio Device))
[   0.841][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{edd9b2bc-e144-4577-81ef-ab33074e02aa}
[   0.845][d][ao/wasapi] Init wasapi thread
[   0.845][d][ao/wasapi] Activating pAudioClient interface
[   0.848][d][ao/wasapi] Probing formats
[   0.848][v][ao/wasapi] Trying 5.1(side) s32 (32/32 bits) @ 96000hz (shared) -> ok
[   0.848][v][ao/wasapi] Closest match is 5.1(side) float (32/32 bits) @ 48000hz
[   0.848][v][ao/wasapi] Accepted as 5.1(side) float @ 48000hz -> 5.1(side) float (32/32 bits) @ 48000hz (shared)
[   0.848][d][ao/wasapi] Fixing format
[   0.849][d][ao/wasapi] IAudioClient::GetDevicePeriod
[   0.849][v][ao/wasapi] Device period: 10 ms
[   0.849][d][ao/wasapi] IAudioClient::Initialize
[   0.904][i][refreshrate] Current Refresh Rate -: 60
[   0.904][i][refreshrate] Saving Initial Refresh Rate -: 60
[   0.904][i][refreshrate] Querying Device Refresh Rates...
[   0.914][d][ao/wasapi] IAudioClient::Initialize pRenderClient
[   0.914][d][ao/wasapi] IAudioClient::Initialize IAudioClient_SetEventHandle
[   0.914][d][ao/wasapi] IAudioClient::Initialize IAudioClient_GetBufferSize
[   0.914][v][ao/wasapi] Buffer frame count: 2400 (50 ms)
[   0.914][v][ao/wasapi] IAudioClock::GetFrequency gave a frequency of 1152000.
[   0.916][d][ao/wasapi] IAudioClient::Initialize pAudioVolume
[   0.916][d][ao/wasapi] Entering dispatch loop
[   0.916][d][ao/wasapi] Init wasapi done
[   0.916][v][ao/wasapi] device buffer: 2400 samples.
[   0.916][v][ao/wasapi] using soft-buffer of 9600 samples.
[   0.916][i][cplayer] AO: [wasapi] 48000Hz 5.1(side) 6ch float
[   0.916][v][cplayer] AO: Description: Windows WASAPI audio output (event mode)


#27 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 02:05 PM

I think I see the problem. You are using the device ID not the name (I've edited my earlier post to remove the ID). Try this in your mpv.conf

audio-device=wasapi/Speakers (ASUS Essence STX II Audio Device)

And also enable exclusive mode. That will prevent other apps from using the audio device while you're watching something.

 

You can't use the ID because that will change over time, but the name, won't. If you were to reinstall that audio device, the ID will be different, so you can't use that.

 

You can also try adding the command to your mpv.conf

audio-exclusive=yes

If this doesn't work, then something else is not letting it happen. You're using Windows 7, correct? 

 

You should see something like this;

[   0.688][v][ao] Trying audio driver 'wasapi'
[   0.688][v][ao] Using preferred device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.688][v][ao/wasapi] requested format: 192000 Hz, 7.1 channels, spdif-truehd
[   0.688][d][ao/wasapi] Init wasapi
[   0.688][d][ao/wasapi] Find device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.694][v][ao/wasapi] Selecting device by name: 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.694][v][ao/wasapi] Selecting device '{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}' (marantz-AVR (NVIDIA High Definition Audio))
[   0.694][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}
[   0.700][d][ao/wasapi] Init wasapi thread
[   0.700][d][ao/wasapi] Activating pAudioClient interface
[   0.702][d][ao/wasapi] Probing formats
[   0.753][v][ao/wasapi] Trying 7.1 spdif-truehd (16/16 bits) @ 192000hz (exclusive) -> ok
[   0.753][v][ao/wasapi] Accepted as 7.1 spdif-truehd @ 192000hz -> 7.1 spdif-truehd (16/16 bits) @ 192000hz (exclusive)

Edited by Doofus, 02 February 2019 - 05:40 PM.


#28 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 06:19 PM

I am using Windows 10 64-bit.  Once I changed the audio configuration from "auto" to "5.1" in Emby as well as inserted

audio-exclusive=yes

in MPV.CONF it started working in exclusive mode.  I don't need to specify the audio device, it uses the soundcard default, although specifying the soundcard by name instead of ID as you suggest did work also.  If you look at the log below it tries many different channel configurations and bit rates/depths.  Ultimately it does arrive at the appropriate 96/24 5.1, and it is in exclusive mode.

 

However, it would seem there is still a bug here for @Luke to look at.  The exclusive mode checkbox does nothing for me, I have to hard-code exclusive mode in my MPV.CONF file as shown:

vd-lavc-o=deint=adaptive
audio-exclusive=yes
log-file="C:\Users\Clay\AppData\Roaming\mpv\theater mpv log.txt"

It sounds like with a receiver you don't need to put exclusive mode in your MPV.CONF file?  Perhaps the developers are testing with receivers, not sound cards, for exclusive mode?  Maybe didn't look at the soundcard use case.

 

Below is the (somewhat longer) log file showing the negotiation of channel configurations and bit rates/depths, ultimately arriving at the correct result.

[   0.563][v][ao] Trying audio driver 'wasapi'
[   0.563][v][ao/wasapi] requested format: 96000 Hz, 5.1 channels, s32
[   0.563][d][ao/wasapi] Init wasapi
[   0.563][d][ao/wasapi] Find device ''
[   0.566][v][ao/wasapi] No device specified. Selecting default.
[   0.569][v][ao/wasapi] Selecting device '{edd9b2bc-e144-4577-81ef-ab33074e02aa}' (Speakers (ASUS Essence STX II Audio Device))
[   0.569][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{edd9b2bc-e144-4577-81ef-ab33074e02aa}
[   0.573][d][ao/wasapi] Init wasapi thread
[   0.573][d][ao/wasapi] Activating pAudioClient interface
[   0.576][d][ao/wasapi] Probing formats
[   0.578][v][ao/wasapi] Trying 5.1 s32 (32/32 bits) @ 96000hz (exclusive) -> unsupported
[   0.578][v][ao/wasapi] Trying stereo s32 (32/32 bits) @ 48000hz (exclusive) -> unsupported
[   0.579][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.579][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 48000hz (exclusive) -> ok
[   0.579][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 44100hz (exclusive) -> ok
[   0.579][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 96000hz (exclusive) -> ok
[   0.579][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 88200hz (exclusive) -> unsupported
[   0.580][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 192000hz (exclusive) -> ok
[   0.580][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 176400hz (exclusive) -> unsupported
[   0.580][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 32000hz (exclusive) -> unsupported
[   0.580][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 22050hz (exclusive) -> unsupported
[   0.581][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 11025hz (exclusive) -> unsupported
[   0.581][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 8000hz (exclusive) -> unsupported
[   0.581][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 16000hz (exclusive) -> unsupported
[   0.581][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 352800hz (exclusive) -> unsupported
[   0.581][v][ao/wasapi] Trying stereo s32 (24/24 bits) @ 384000hz (exclusive) -> unsupported
[   0.582][v][ao/wasapi] Trying 5.1 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.582][v][ao/wasapi] Trying 7.1 s32 (24/24 bits) @ 96000hz (exclusive) -> ok
[   0.582][v][ao/wasapi] Trying 6.1 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.582][v][ao/wasapi] Trying mono s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.583][v][ao/wasapi] Trying 2.1 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.583][v][ao/wasapi] Trying 4.0 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.583][v][ao/wasapi] Trying 5.0 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.583][v][ao/wasapi] Trying 3.0 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.584][v][ao/wasapi] Trying 3.0(back) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.584][v][ao/wasapi] Trying quad s32 (24/24 bits) @ 96000hz (exclusive) -> ok
[   0.584][v][ao/wasapi] Trying quad(side) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.584][v][ao/wasapi] Trying 3.1 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.584][v][ao/wasapi] Trying 5.0(side) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.585][v][ao/wasapi] Trying 4.1 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.585][v][ao/wasapi] Trying 5.1(side) s32 (24/24 bits) @ 96000hz (exclusive) -> ok
[   0.585][v][ao/wasapi] Trying 6.0 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.586][v][ao/wasapi] Trying 6.0(front) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.586][v][ao/wasapi] Trying 6.0(front) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.586][v][ao/wasapi] Trying 6.1(front) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.586][v][ao/wasapi] Trying 7.0 s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Trying 7.0(front) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Trying 7.1(wide) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Trying 7.1(wide-side) s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Trying empty s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Trying octagonal s32 (24/24 bits) @ 96000hz (exclusive) -> unsupported
[   0.587][v][ao/wasapi] Channel layouts:
[   0.587][v][ao/wasapi]  - stereo
[   0.587][v][ao/wasapi]  - 7.1
[   0.587][v][ao/wasapi]  - quad
[   0.588][v][ao/wasapi]  - 5.1(side)
[   0.588][v][ao/wasapi] result: 5.1(side)
[   0.588][v][ao/wasapi] Accepted as 5.1(side) s32 @ 96000hz -> 5.1(side) s32 (24/24 bits) @ 96000hz (exclusive)
[   0.588][d][ao/wasapi] Fixing format
[   0.588][d][ao/wasapi] IAudioClient::GetDevicePeriod
[   0.588][v][ao/wasapi] Device period: 10 ms
[   0.588][d][ao/wasapi] IAudioClient::Initialize

Edited by lifespeed, 02 February 2019 - 06:29 PM.


#29 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 06:32 PM

Well, with an internal card, Windows is essentially the device, as you aren't bitstreaming. So mpv needs to probe the capabilities. I trust that you've configured Windows audio and the device settings?

 

5c5619d977384_Snapshot_141.jpg 

 

5c561a02080e8_Snapshot_142.jpg

 

5c561a44dd478_Snapshot_143.jpg



#30 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 07:17 PM

Because it is a sound card I don't have the "supported formats" tab delineated like you do in your receiver, but everything else is set up.  I set Windows to the most-common 48/24 sound format, using WASAPI exclusive to force 44.1/16 CD audio and 96/24 hi-def to play without requiring either re-sampling or manual bitrate reconfiguration through the windows sound panel.

 

I have a 4.0 physical speaker configuration, which Windows implements as 5.1 without center channel or subwoofer.  You can see those speakers are greyed-out in the sound panel config.

 

It does all seem to be working with Emby now, thanks to the forced exclusive mode in MPV.CONF.  I still think this is an Emby bug.  You don't have to force exclusive mode to have it work?

 

 

5c5623af71de1_sound1.png5c5623c0ebb64_sound2.png5c5623c807054_sound3.png


  • Doofus likes this

#31 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 07:26 PM

 

It does all seem to be working with Emby now, thanks to the forced exclusive mode in MPV.CONF.  I still think this is an Emby bug.  You don't have to force exclusive mode to have it work?

 

 

It works as expected, for me. I wonder if the speaker config option and the way it's implemented has something to do with what you're experiencing? In your case, it's all handled by software, so there may be a stumbling block somewhere in there. But I'm glad you've got it to work :)



#32 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 07:50 PM

It works as expected, for me. I wonder if the speaker config option and the way it's implemented has something to do with what you're experiencing? In your case, it's all handled by software, so there may be a stumbling block somewhere in there. But I'm glad you've got it to work :)

Looking at the MPV log files it appeared to be ordinary 5.1 sound.  I suspect the difference is sound card with software decoding of the audio vs. bitstreaming over HDMI.  In which case I would like to ask @Luke to try to reproduce MPVs failure to follow Emby's exclusive mode check box.  I doubt it is anything unique to my setup other than using a soundcard vs. a receiver.

 

Emby was the last of my important media player apps that wasn't using WASAPI exclusive which implies the bitrate appropriate for the media, so I'm glad to see it working now even if it is a MPV.CONF entry.  As we've seen there is still work to do matching MPV's configuration of nVidia deinterlacing, HDR, and now WASAPI exclusive mode with Emby's user-selected configuration.

 

Thanks again for your help.  Someday soon I hope to look at the videophile aspects with a 4K HDR screen.  For now the sound is a big deal to me.


  • Doofus likes this

#33 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 08:16 PM

I just tested disabling bitstreaming and left exclusive mode, enabled. It gets disabled, too.

[   0.648][v][ao] Trying audio driver 'wasapi'
[   0.648][v][ao] Using preferred device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.648][v][ao/wasapi] requested format: 48000 Hz, 7.1 channels, floatp
[   0.648][d][ao/wasapi] Init wasapi
[   0.648][d][ao/wasapi] Find device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.654][v][ao/wasapi] Selecting device by name: 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.654][v][ao/wasapi] Selecting device '{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}' (marantz-AVR (NVIDIA High Definition Audio))
[   0.654][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}
[   0.660][d][ao/wasapi] Init wasapi thread
[   0.661][d][ao/wasapi] Activating pAudioClient interface
[   0.663][d][ao/wasapi] Probing formats
[   0.723][v][ao/wasapi] Trying 7.1 float (32/32 bits) @ 48000hz (shared) -> ok
[   0.723][v][ao/wasapi] Accepted as 7.1 float @ 48000hz -> 7.1 float (32/32 bits) @ 48000hz (shared)

But it still works when I test in the standalone

[   0.661][v][af] [in] 48000Hz 5.1(side) 6ch floatp
[   0.661][v][af] [userspeed] 48000Hz 5.1(side) 6ch floatp
[   0.661][v][af] [userspeed] (disabled)
[   0.661][v][af] [convert] 48000Hz 5.1(side) 6ch floatp
[   0.674][v][ao] Trying audio driver 'wasapi'
[   0.674][v][ao] Using preferred device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.674][v][ao/wasapi] requested format: 48000 Hz, 5.1(side) channels, floatp
[   0.674][d][ao/wasapi] Init wasapi
[   0.674][d][ao/wasapi] Find device 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.681][v][ao/wasapi] Selecting device by name: 'marantz-AVR (NVIDIA High Definition Audio)'
[   0.681][v][ao/wasapi] Selecting device '{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}' (marantz-AVR (NVIDIA High Definition Audio))
[   0.681][v][ao/wasapi] Monitoring changes in device {0.0.0.00000000}.{8e7d87f0-6c1b-4a30-ad52-87708369ca9d}
[   0.687][d][ao/wasapi] Init wasapi thread
[   0.687][d][ao/wasapi] Activating pAudioClient interface
[   0.689][d][ao/wasapi] Probing formats
[   0.740][v][ao/wasapi] Trying 5.1(side) float (32/32 bits) @ 48000hz (exclusive) -> unsupported
[   0.741][v][ao/wasapi] Trying stereo float (32/32 bits) @ 48000hz (exclusive) -> unsupported
[   0.741][v][ao/wasapi] Trying stereo s32 (32/32 bits) @ 48000hz (exclusive) -> unsupported
[   0.741][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.741][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 44100hz (exclusive) -> ok
[   0.742][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 96000hz (exclusive) -> ok
[   0.742][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 88200hz (exclusive) -> ok
[   0.742][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 192000hz (exclusive) -> ok
[   0.742][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 176400hz (exclusive) -> ok
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 32000hz (exclusive) -> ok
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 22050hz (exclusive) -> unsupported
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 11025hz (exclusive) -> unsupported
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 8000hz (exclusive) -> unsupported
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 16000hz (exclusive) -> unsupported
[   0.743][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 352800hz (exclusive) -> unsupported
[   0.744][v][ao/wasapi] Trying stereo s32 (32/24 bits) @ 384000hz (exclusive) -> unsupported
[   0.744][v][ao/wasapi] Trying 5.1 s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.744][v][ao/wasapi] Trying 7.1 s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.744][v][ao/wasapi] Trying 6.1 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.744][v][ao/wasapi] Trying mono s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.744][v][ao/wasapi] Trying 2.1 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.745][v][ao/wasapi] Trying 4.0 s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.745][v][ao/wasapi] Trying 5.0 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.745][v][ao/wasapi] Trying 3.0 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.745][v][ao/wasapi] Trying 3.0(back) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.746][v][ao/wasapi] Trying quad s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.746][v][ao/wasapi] Trying quad(side) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.746][v][ao/wasapi] Trying 3.1 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.746][v][ao/wasapi] Trying 5.0(side) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.747][v][ao/wasapi] Trying 4.1 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.747][v][ao/wasapi] Trying 5.1(side) s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.747][v][ao/wasapi] Trying 6.0 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.747][v][ao/wasapi] Trying 6.0(front) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.748][v][ao/wasapi] Trying 6.0(front) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.748][v][ao/wasapi] Trying 6.1(front) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.748][v][ao/wasapi] Trying 7.0 s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.748][v][ao/wasapi] Trying 7.0(front) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.749][v][ao/wasapi] Trying 7.1(wide) s32 (32/24 bits) @ 48000hz (exclusive) -> ok
[   0.749][v][ao/wasapi] Trying 7.1(wide-side) s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.749][v][ao/wasapi] Trying empty s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.749][v][ao/wasapi] Trying octagonal s32 (32/24 bits) @ 48000hz (exclusive) -> unsupported
[   0.749][v][ao/wasapi] Disabling multichannel output.
[   0.749][v][ao/wasapi] Channel layouts:
[   0.749][v][ao/wasapi]  - stereo
[   0.749][v][ao/wasapi]  - 5.1
[   0.749][v][ao/wasapi]  - 7.1
[   0.749][v][ao/wasapi]  - 4.0
[   0.749][v][ao/wasapi]  - quad
[   0.749][v][ao/wasapi]  - 5.1(side)
[   0.749][v][ao/wasapi]  - 7.1(wide)
[   0.749][v][ao/wasapi] result: stereo
[   0.749][v][ao/wasapi] Accepted as stereo s32 @ 48000hz -> stereo s32 (32/24 bits) @ 48000hz (exclusive)

So I think the speaker layout option is getting in the way. 


Edited by Doofus, 02 February 2019 - 08:17 PM.


#34 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 08:24 PM

I honestly don't see the need for the speaker layout option. As long as windows audio is configured, that's really all you need. It's just one more thing to get in the way and confuse people. In that last test I did, it actually messed up what was supposed to happen, and I got an incorrect output. I say just remove it.

 

EDIT:

 

Or use it only for music, as it's tied to using the upmix option.


Edited by Doofus, 02 February 2019 - 08:32 PM.


#35 lifespeed OFFLINE  

lifespeed

    Advanced Member

  • Members
  • 430 posts
  • Local time: 11:34 AM
  • LocationSan Jose, CA, USA

Posted 02 February 2019 - 10:04 PM

You're referring to the speaker layout in Emby causing exclusive mode to fail?  I also saw that exclusive mode only worked when I set Emby to 5.1 audio, which is what Windows is configured as.  However, in my case with a soundcard, I still have to force exclusive mode in the MPV.CONF file.



#36 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 10:28 PM

You're referring to the speaker layout in Emby causing exclusive mode to fail?  I also saw that exclusive mode only worked when I set Emby to 5.1 audio, which is what Windows is configured as.  However, in my case with a soundcard, I still have to force exclusive mode in the MPV.CONF file.

 

Only with audio passthrough, disabled. When enabled, exclusivity, fails. And I think it's failing in that circumstance because the audio layout has to match everything else. Take a look at this.

 

5c564deb55e06_Snapshot_144.jpg

 

I think there's a point in the way this is implemented that it hits a wall, and fails. Like the layout is taking precedence, and dis-allowing exclusivity. And that's why you can use it in the mpv.conf, because Theater can't affect it. It's only the option in Theater that gets defeated. It's like the audio passthrough option is directly tied to exclusivity. Disable one, and you disable the other. Now that I'm writing this out, that actually makes more sense than the audio layout. Exclusivity should be a global function, and not be linked to anything. A simple on/off.

 

And there it is. Line 325 in the playbackhandler

  if (options.exclusiveAudio && mediaType === 'Video') {
        list.push('--audio-exclusive=yes');

It shouldn't be for a specific media type. 

 

Luke, could that be changed to only use?

list.push('--audio-exclusive=yes');

But I guess we'd need a no option. How would I write that?


Edited by Doofus, 02 February 2019 - 10:34 PM.


#37 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 11:34 AM

Posted 02 February 2019 - 10:36 PM

Would it be 

  if (options.exclusiveAudio) {
        list.push('--audio-exclusive');






Also tagged with one or more of these keywords: audio, output device

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users