Jump to content

HTTPS not working on TS-251+


sstt671
Go to solution Solved by sstt671,

Recommended Posts

sstt671

Hello,

 

I am not able to setup SSL on my emby server hosted on QNAP TS-251+. 

 

Server details:

QNAP TS-251+ 

Firmware  v4.3.3

Emby v3.2.14

Qmono v4.6.2.7 (64bit)

 

When I supply my own ssl cert with .pfx, I can connect via http but not https. Port forwarding is done correctly. 

Also, if I do not supply my own cert then connect via https works fine with warning.

 

Here is the log snippet:

2017-05-08 14:46:32.9377 Error App: Error loading cert from /*****/SSLcertificate.pfx
	*** Error Report ***
	Version: 3.2.14.0
	Command line: /*****/.qpkg/Emby/Emby/MediaBrowser.Server.Mono.exe
	Operating system: Unix 4.2.8.0
	64-Bit OS: True
	64-Bit Process: True
	Mono: 4.6.2 (Stable 4.6.2.7/08fd525 mercredi 23 novembre 2016, 17:45:54 (UTC+0100))
	Processor count: 4
	Program data path: /*****/.qpkg/Emby/Emby/ProgramData-Server
	Application directory: /*****/.qpkg/Emby/Emby
	System.Security.Cryptography.CryptographicException: Unable to decode certificate. ---> System.Security.Cryptography.CryptographicException: Input data cannot be coded as a valid certificate. ---> System.Security.Cryptography.CryptographicException: Input data cannot be coded as a valid certificate.
	  at Mono.Security.X509.X509Certificate.Parse (System.Byte[] data) [0x00041] in <1d0bb82c94e7435eb09324cf5ef20e36>:0 
	   --- End of inner exception stack trace ---

Any suggestions?

 

 

Thanks,

 

 

Link to post
Share on other sites
Luke

Interesting. We have advised going forward that mono 4.8.1 is now the recommended version. In mono 4.8 they overhauled the TLS stack so I think that may affect this. I will have to discuss the rollout of mono 4.8 with our QNAP contact. Thanks.

  • Like 1
Link to post
Share on other sites
  • Solution

Update: I figured out the problem(?), my original .pfx file had password. I created new one without password and now I can connect to my emby server with https.

I am on Emby v3.2.15 and QMono v4.8.1.

Link to post
Share on other sites
Luke

Thanks for the feedback ! In a future update we will allow you to specify a password for the pfx.

Link to post
Share on other sites
Swynol

Thanks for the feedback ! In a future update we will allow you to specify a password for the pfx.

 

that's good new Luke. will the option be available for Windows Servers aswell?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...